SketchUp is suddenly very slow

#1

Hi there,

First of all, I am an IT person who is trying to help a SketchUp user who is not familiar with computers and I’ve been asked to try and resolve the problem.

The computer is a new, 2 month old Dell workstation with Xeon W-2123 CPU with 8GB RAM, 512GB M.2 SSD (3000MB/s read, 1800MB/s write, checked with Crystal Disk Mark, today). Video card is an nVidia Quadro P1000.

File being opened is on the local SSD, not on network. It should be FAST!!!

Sketchup Pro 2018 was installed just over 2 months ago and haven’t had any reported problems until today. Starting yesterday, the user’s SketchUp experience has deteriorated badly and everything is very laggy. When trying to do something, it often takes many seconds longer than it should and task manager shows it as “Not responding”. It seems to be only Sketchup being slow, as using the web browsers and general windows configuration navigation isn’t experiencing any lag or issues at all.

Just now, I went to check the version and got “Not responding” while the About box displayed! I right clicked on something, and went “Not responding”.

Things we’ve tried:

  • Rebooted computer
  • Upgraded Nvidia driver through Windows Update
  • Upgraded Nvidia driver to latest Enterprise from Nvidia
  • Disabled autosaves (it was set to 5mins, but problem happened way earlier than that)
  • Disabled “Use fast feedback”
  • Upgraded SketchUp 2018 to 2019

No recent Windows updates (02/22 was last one) other than antivirus definitions (almost daily). Does not have the recent KB update that was effecting mouse/game performance that I read on this forum.

Any other ideas on resolving this issue?

Thanks in advance for any advice/help/suggestions.

#2

I hate to add insult to injury but for over two weeks now, I’ve had similar issues with slowness and crashes with SU 2019. A model project I’d been working on for quite a long time has gotten worse to open and manipulate, despite doing an SU cleanup of the file, as well as using a SU extension for cleanup. Both seemed to get rid of a lot of unwanted items, but it still didn’t seem to fix the main issue.

I’ve done the same about disabling fast preview, disabling animation, upping the antialiasing, even went so far as to customizing the performance of my GTX 1080 to try and squeeze out more performance. I have an i7-7700k with the GTX-1080, 64gb of RAM and all SSDs for drives…beats the heck out of me what it could be, maybe bad code in SU needing an update???

1 Like
#3

I just tried creating a 1GB Ramdisk and put the 734MB .skp file there. I right clicked on it and said to Open in SketchUp 2018, and the app starting seems to take longer than when I opened SketchUp and selected the last opened file. Hmm, it seems trying to right click and open it generally seems to take longer to open than if I opened from within Sketchup.

Opening a file from ramdisk should not be doing this!

What are considered large or typical .skp files?

#4

@TimJones

This size skp file is very very big. Did your user give you any information as to what they were doing right before the slowdown? Where they importing cad files into the existing skp file?

If you are able to load the skp, while in SketchUp can you go to Window > Model Info dialog and take a screenshot of the model statistics. This will give us an idea of how many surfaces, edges, groups, and components are in the model.

35%20PM

CD

1 Like
#5

It varies, but most start to experience slow moving orbits and sluggish behavior once over 100mb. 734MB is a monster, never had a file that big, not surprised it wont run. Do they have earlier versions saved, could they determine when the bloat took place, was it gradual or all of a sudden?

2 Likes
#6

Apart from trying to optimize the model, some other issues / fixes to consider -

WORK STATIONS

Gaming PC’s having traditionally been better performers than servers / work stations.

The P1000 performance is mid to low by todays standards.

8 GB of ram is a bit lite for a work station (likely runs slower than gaming PC memory).

M.2 drives have throttling issues when they overheat (may be a small issue).

Windows Enterprise services - there may be way too many background processes operating for a work station? - could test performance by disabling a few known unnecessary services (and even apps) and disconnect from the internet (when some services don’t run).

Not sure about an Intel GPU - if you have one you could try disabling it in the bios.

1 Like
#7

She showed me a 498MB file she was working with that I thought she said she started from. She said it wasn’t slow, but SU would crash and close and then she’d continue on with the auto saved file. When I tried opening that file, it seemed worse than when I was trying the newer 734MB one. But it’s hard to compare very slow vs very slow.

So I don’t think she was thinking the crash closing was a problem, but I would say it is!

I noticed other files were more like 2-50MB in size, but much simpler (one room vs floorplan?).

So sounds like a bump to 16GB would be minimum, and even upgrade the video card. Any recommendations for best value? The P1000 was supposed to be cheap but qualified, but I had no previous experience and neither did she in terms of PC specs.

I’ll get model information later tonight when I can.

#8

Well, by all means get her whatever tech edge you can, Ram and Graphics card are the big ones as Sketchup is a single processor operation and multiple cores are no help here. But honestly I think Deep Blue would choke on a 750MB sketchup file.

My guess is this is less a hardware issue and more about poor model management. I’m not sure how experienced your client is but this kind of file bloating is often caused by a lack of understanding how components work and by indiscriminately downloading components from the 3D warehouse without checking their size or poly count. If you are not paying attention to file size it’s easy to add a 15MB faucet here, a few 10MB windows over there, a 40MB car in the driveway and a slew of 15MB doorknobs. The warehouse is a publicly fueled repository and many of the models are poorly crafted and waaaayyy to big. You can search by poly-count, but you have to know what you are doing. Plants are the worst, so many little facets, some of the good looking ones are tempting but the files are hugh, I’ve seen lots of simple models of tiny cottages have their poly-count go through the roof by adding landscaping.

There are best practices that allow detailed modeling while controlling the file size and it’s possible your client is a total pro and paying attention to the poly count and file size, watching the statistics like a hawk and leveraging textures to keep geometry simple, and layers to control visibility, but then they would have already known that they had a very big file on their hands. For reference, today I’m working on a 15000 sq ft facility with a 300 seat theater in it and I’m at about 110MB (1.5M edges, 850K faces), and that’s with a few of 8MB photorealistic people in it and some indulgently curvy curtains.
If you can get a file to stay open then check out the statistics as suggested, purge unused components, purge and set the style to monochrome, and for god sakes turn off the shadows if they are on. Then have her search the forum for ways to lower file size.

Good Luck

4 Likes
#9

Here are the screenshots. Not sure if its because I’m over a remote connection, but it won’t let me resize the window to fit it all in one view?!?!

While on that screen I did “purge unused” and saved that as a different file. It resulted in 631MB from the original 712MB. And still laggy as hell, of course.

And yes, I believe it would be correct to say she is a student still learning and taking courses using this software. Also, based on the previous computer being severely under the task, I would say she was used to expecting it to be slow and doing smaller projects and now that she has a better machine, making bigger projects. But now finding out there is a limit to how much stuff and the impact.

I can’t tell from these numbers if they are nonsensical and indication of a corrupt file, or just a beast of a file. It’s just a single floor plan of a few rooms… (or I just haven’t been able to zoom out to see more) so I’m leaning towards corruption or some other unnecessary waste.

I will show her this thread tomorrow and see what can be causing all the size. Any chance there is a rough reference guide for what sizes to expect for various complex components? A way to eyeball whether a component is poorly made or pretty efficient to avoid in the marketplace in the future? The edges and faces are like 5X what you have and the size is about 5X, so hmm…

But knowing that files shouldn’t typically be over 100MB helps tremendously as points to a process/input problem than physical hardware problem or broken SketchUp install (other than not taking advantage of more CPU cores and allowing the filesize to get so large).

Thanks to all for your help!

1 Like
#10

It’s a quirk of SketchUp - the window won’t resize.

Your model info number of layers may be your issue - possibly a lot of duplication / hidden unused geometry there?

A few screen captures of some details or the model if possible would help us see what’s going on.

1 Like
#11

More than 7 million edges and 4 million faces is quite a lot. SketchUp, like all 3D modelling apps, is single threaded, so all those have to go through that when you zoom or orbit. Roughly, the 3D geometry is processed by your CPU, and raster things like textures and shadows by the graphics card.

A typical reason for model bloat is 3D entourage components (like trees, cars and people) downloaded from the 3D Warehouse. Using those should be limited to a minimum. Never build a forest out of 3D trees. A reasonable alternative is to use “2D cutout” type components that turn to face tha camera.

2 Likes
#12

Have to agree with most everyone else… unnecessary bloat in the model. I see three areas of concern.

Components, You stated “she’s a student, Learning SketchUp”. Going to guess a lot of components downloaded from 3D Warehouse ? Are they unnecessarily detailed or poorly modeled ? It’s best to download Warehouse models into a separate file and give them a good examination before using in your models.

Layers, How many are not needed. Possible place for unneeded hidden geometry to be floating about.

Materials, Are there unnecessary duplicate textures or texture images of a much higher resolution than needed.

Have never had a model quite this large but have had a good number over 300mb and the only issues were very minor slowdowns when saving.

1 Like
#13

1532 Component Definitions with only 3443 instances… this could result from an import of a 2d/3d model.

1 Like
#14

I have also noticed that Sketchup Make 2017 is very laggy and unresponsive recently even in under 10Mb project. I have 16Gb RAM, 1060 6Gb video card, 1Tb Seagate HDD, 233GHz dual core processor. I used components for building details like windows, doors, lights, even floors are one component. Sketchup is installed run as administrator. File Size: 9,51Mb, Edges: 42791502 (nested only) Faces: 17207932 (nested only) Component Definitions: 51, Groups: 264471 (nested only) Component Instances: 1 unnested, 45453 nested, Layers: 1, Materials: 177, Styles: 1, else 0.

#15

As said before, it is not the project file size but the actual edge and face count that determines the load it places on your system. In those terms, your project at least twice as large as the one previously discussed in this thread. 3D trees?

#16

Multiple 11 story apartment buildings with interior walls, no furniture or 3D trees. Strange that similar project worked well last year and I also assembled basically a whole city without much problems.

#17

Almost 43 million edges? Over 17 million faces?

Does it perform better with face style set to Monochrome and shadows turned off?

How about updating and completing your profile? It indicates your graphics card is NVS3100M.

#18

I don’t use shadows when drawing, I had it shaded without texture but I can try the monochrome trick.
By the way the city project I was talking about has over 299 million edges and over 111 million faces with file size over 300Mb and area of roughly 20 square kilometers of buildings and infrastructure.

#19

That’s quite a project for a hobby.

4 Likes
#20

Tested with face style set to monochrome, same lag. I used to make projects ten times the detail amount on my old laptop, now sketchup chokes on itself on a Windows 10 gaming PC. Amazing.