SketchUp does not start after pressing "Start using SketchUp"

startup
windows

#1

I’m new to Sketchup. I’ve just installed “SketchUp Make 2016” and tried to use it. The splash window shows up fine. I choose a default template, then press “Start using SketchUp” and then nothing happens. (At least, visually; in the “Task Manager”, I see that there’s a process called “Sketchup Application” that’s using about 30% of the CPU and 75MB of memory). I’ve waited for minutes, and still nothing happens.

I’ve seen that some people reported something similar, and got it solved by installing the 32-bit version. In my case, the behavior is the same whether I install the 32-bit or the 64-bit versions.

During the installation, I was asked to close some programs running on my machine; I chose the option to not close them and instead restart the computer later. Which I did.

The only potentially out of the ordinary thing is that in the Device Manager, there are two devices shown under “Display Adapters”:

  1. AMD Radeon R7 M270
  2. Intel® HD Graphics Family

Don’t know if it has any impact, but it may be worth mentioning.

Any solution/nudge in the right direction is appreciated.


#2

When you installed it, did you right click on the installer and choose Run as administrator?


#3

Thank you for the reply.

No, I have not, but it does not matter – I’m asked to provide the ‘admin’ approval for the installer, even if I just double click on the installer. Just as a precaution, I’ve uninstalled and ran the installer with ‘Run as Administrator’ and the behavior is the same (this time I’ve installed the x64 version).


#4

This is totally normal, especially for a mobile system (laptop, notebook, etc.)

#2 is the GPU that is built into the Intel CPU & chipset (called collectively an APU.) This is known as “integrated graphics”.

#1 is apparently either an expansion card installed by your OEM, or an extra GPU built onto the motherboard by your machine’s OEM. This is called “discrete graphics”.


#1 is most likely better than #2, but often the integrated Intel graphics (#2) is what gets used as a default for most applications.

I would suggest downloading the latest available AMD driver package which should also give you a utility to set the system default as the AMD R7 GPU. (This utility can also be used to set individual applications to use a preferred GPU.)


Newer AMD Crimson drivers for R7 200 series:
(You could likely use either the stable or “hotfix” versions.)


Older AMD Catalyst Beta drivers for Windows:


FYI


#5

Dan, thank you for your detailed reply. I’ve installed the newer AMD Crimson driver (the first link for x64 systems). Unfortunately, the result is roughly the same. The only differences are:

  • Sketchup still does not show up, but this time it consumes 0% of the CPU (instead of about 30%) and
  • The name of my card changed in “Device Manager” to “AMD Radeon R7 M265 Series”. This change does not seem to have any impact on other things (e.g. video play), but thought to mention it.

I’ve even uninstalled and installed Sketchup again, and it’s the same behavior.


#6

(1) Did you verify that SketchUp is using the AMD GPU via the AMD Radeon Settings ?


(2) Use a 3rd party utility to switch OFF SketchUp’s OpenGL Hardware acceleration, from outside SketchUp. (To verify that perhaps your driver has OpenGL deficiencies.)

@sketch3d_de, Has this tool been updated to set SU2016 registry attributes ?
(The date still says 2014 on the download page.)


(3) Verify (via the Windows file explorer,) that you have read and write permissions on this folder:

%APPDATA%/SketchUp/SketchUp 2016/SketchUp/

… and all it’s sub-folders.

(You can paste that path into the Windows explorer breadcrumb bar and it will go to this folder. Windows knows what it’s environment variables are.)

The first time SketchUp starts, it will create “Classications” and “Plugins” sub-folders, then copy the distributed plugins and an IFC classifications schema into these folders.

So this step is to verify that these sub-folders are being created, and the 5 “shipped extensions” are being copied, (ie, “su_advancedcameratools”, “su_dynamiccomponents”, “su_sandbox”, “su_trimble_connect” and “su_webtextures”,) as well as the IFC schema “IFC 2x3.skc” to the “Classifications” sub-folder.


(4) Get the SketchUp Diagnostics utility and create a diagnostics logfile:

SketchUp Diagnostics for Extension Problems


(5) See also this thread re Crimson drivers and SketchUp 2016:


#7

Hi Dan, thank you again for your reply.

I’m not sure how to verify that SketchUp uses or not the AMD GPU – I’ve looked in Radeon Settings (after watching the video), and it’s not clear what to set.

However, #3 seems to have fixed the problem (in a way). I’ve looked in that directory, and there was no ‘Plugins’ subdir. So I’ve decided to delete %APPDATA%/SketchUp, uninstall SketchUp and then install it again. And, this time it actually worked. So, problem solved. I’m not sure why the Plugins folder was not created first time, since I did not need to change any folder permissions.

Thank you for your patience and for your help.


#8

[quote=“DanRathbun, post:6, topic:33143, full:true”]@sketch3d_de, Has this tool been updated to set SU2016 registry attributes ?
(The date still says 2014 on the download page.)[/quote]

@DanRathbun of course, this is the date of adding to the file repository.