Sketchup Pro 2017 won't start after download


#1

Hi,
Started having trouble with SU Make back about December. I have an HP Notebook Core i7 7th Gen with an AMD Radeon R7 M340 graphics card. SU started failing after the initial screen when I would click “start using Sketchup”. After clicking start using sketchup nothing would happen. I upgraded to SU 2017 Pro last week with the same result. I sometimes get a bug splat, sometimes I don’t. Sometimes I report it, and sometimes I don’t. I am not nearly as computer proficient as the folks here, but I have done the following:

  1. Ran SU Checkup and all was good except first item which said to the effect of “Intel Graphics card only has 1 mb, SU requires min 256 mb”. Everything else was ok.
    1.5 Internet research seemed to indicate wrong card was being used.
  2. Uninstalled “AMD Software” from the Control panel and installed/reinstalled Crimson ReLive from the AMD website,version 17.2.1.
  3. Used Crimson ReLIve to set the graphics card to High Performance.
  4. Tried SU, same problem (nothing after clicking" start using Sketchup")
  5. Reran SU CU. It said “AMD Radeon R7 only has 1 mb, SU requires minimum 256 mb.”
  6. Reinstalled Sketchup (incidentally, it remembers my license number which seems like it isn’t uninstalling completely?)
  7. Reran SU CU same error report
  8. Reran SU, same problem after clicking start using SU
  9. Searched the internet extensively
  10. Repeated steps 1 thru 9 ad infinitum ad nauseum
  11. INstalled SU make 32 bit and it worked but couldn’t open files from previous SU 2017 version
  12. Found similar thread on this website which pointed to problem with MS Visual C++ 2014 version 14.0.24210. I don’t have that. I have a pile of MS Visual C++, but not that one.
  13. Became frustrated
  14. Became exceedingly tired
  15. Somewhere in this process associated .sulog with internet explorer, so now when I run SU CU the .sulog comes out as a internet explorer file. Internet says I need to do something in Regedit . Seems WELL BEYOND my ability level.

Any help in laymen’s terms would be greatly appreciated.


#2

I don’t see it in your long post so I’ll ask: When you installed SketchUp, did you right click on the installer and use Run as administrator?


#3

Hi Dave,
Yes I did. By that, I mean that I went to my downloads folder, found the SU installer file, and right clicked it, then selected run as administrator from there.

Also, sorry for the long post, but wanted to include as much detail as I had.

Also sorry, as after rereading it is seems to show more frustration than I intended. It’s just a frustrating process.

Also would add that after posting, I read about restore points, and thought that could be a way out. This computer isn’t very old, and it is really just for personal use, MS word, Excel, surfing etc. Not even a gamer, so going back in time would not be a big deal. But I only have a restore going back a week to when this process started. I don’t seem to have a way to go back to December.


#4

…is always a problem. Check Windows software uninstall panel for a software called “Play.TV” and uninstall if found.

SU v2017 has in general higher demands on the OpenGL support of the used graphics driver (OpenGL v3.0 and higher).

Update the intel HD graphics driver to version 10.18.10.4061 (or higher) by using the notebook makers support tool or by downloading from their website. Try if running SU on the integrated intel HD works, at least as a workaround.

Ignore results of SU 2017 CheckUp tool regarding the reported Video RAM, results are extracted from MS info tool which does have issues with several graphics subsystems.


#5
  1. Checked uninstall and no play.tv listed.
  2. Used device manager to display adapters to right clickon intel graphics card and updated
  3. restarted machine-device driver says version is 21.20.16.4542
  4. tried sketchup and same thing (clicked start using SU-nothinghappens)
  5. opened Crimson panel and set SU.exe and SU.webhelper to power saving (which I think makes the intel card the primary)
  6. tried SU again and bug splat-sent report

Every time I report a bug splat the window that opens says try uninstall MS Visual C++ Redistributable, but the internet advice elsewhere seems to say that’s a bad idea.

Additional thoughts?


#6

SU v2016/2017 requires MS Visual C++ 2015 to be installed… which is normally done during the installation of SU.

Check Windows software uninstall panel for the “MS Visual C++ 2015 Redistributable (x86/x64)” and uninstall, restart Windows and download/install (“r-click > Run as Admin”) the MS Visual C++ 2015 Redistributable Update 3 separately.


#7

Ok, so I:

  1. Downloaded MS visual c++ 2015 redistributable x64 Update 3 version 14.0.24215 from the MS website
  2. uninstalled MS visual c++2015 redistributable x64 from my programs which also said it was version 14.0.24215
  3. installed the update 3 version.
  4. restarted machine
  5. started SU… took a while, but then got the first screen
  6. Clicked “start using sketchup”, and it took a while longer, but then started right up
  7. SUCCESS!

Thank you so much for the help! Literally couldn’t have done it without your help!

Slight sidebar… I noticed I also have MS visual c++ 2015 redistributable x86. Do I need that since my machine is 64 bit i.e. could I uninstall that without consequences?

Again, thank you so much for the support!


#8

Keep the MS visual C++ for x86. It would be for 32-bit apps - which you can still install and run. Don’t know if the bug that was in the C++ you removed also occurred in the 32-bit version though.