Sketchup Make 2017 cannot even start

Hello all,

I’m using Microsoft Windows 10 Home Edition. I’m trying to install Sketchup Make 2017, as I require offline mode and plugins. Unfortunately, I haven’t been able to start it up even once, as it keeps loading to the Bug Splat report page immediately (I’ve submitted Crash Report #1631840). I’ve tried to follow all the troubleshooting steps on an official post, but it seems nothing works. The link to the help page for AMD graphics cards is broken, and I am not that familiar with Radeon (Using a Lenovo laptop with an integrated Intel graphics card and an AMD graphics card).

Can anyone please offer some advice on what to do next? I used Sketchup a lot in 2013 but never encountered these issues before.

Thank you in advance.

dxdiag:

Bug Splats on startup are typically due to graphics problems. SketchUp requires a graphics processor that is up to the task. In older versions you could switch to CPU rendering to compensate for GPUs that weren’t up to the job. That’s not an option in SketchUp 2017.

Integrated GPUs are not recommended due to their weak support for OpenGL. According to a variety of benchmark sites, your Radeon graphics card isn’t great either. You could try updating the drivers for GPU and see if that helps.

FWIW, you are showing a page related to DirectX. SketchUp doesn’t use DirectX. It uses OpenGL.

On one site that consolidates GPU benchmarks, the overall benchmark performance for your Radeon card is shown as 0.80 on a scale of 0.00 to 100.00.

1 Like

Following on from @DaveR’s excellent advice…

Another cause of issues is an incorrect installation…
Never install any complex app from its installer’s exe file by double clicking it to ‘Run’ it - it causes unpredictable permission issues…
You can fix an installation thus…
While logged into Windows as your normal user account, ensure SketchUp is not running.
Find its installer exe file - probably in your Downloads folder.
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair” [for a brand new install it’s obviously “Install”]
When it’s done, restart and see it SketchUp behaves better…
Even if you have admin-powers using ‘Run’ is NOT the same as using “Run as administrator”…

1 Like

Thank you, I’m using a standard laptop. The web version is pretty fast but unfortunately lacks the features I require. I found the log file output and here’s what it said:

======== Starting GL ========
WGLUtils::IsExtensionFinderWindowClassRegistered: Class is not registered.
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY1 : Intel® HD Graphics 520 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY2 : Intel® HD Graphics 520 : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY3 : Intel® HD Graphics 520 : PT 1
WGLUtils::UtilsState::ctor: Max GPU perf is 1
GlInformation: Starting graphics capabilities tests.

I’ll try finding some new drivers in the meantime.

Thanks @TIG … I’ve tried repairing as admin then starting it up as admin, but the Bug Splat error window comes up almost instantaneously.

The Intel HD Graphics 520 isn’t a great GPU either. Good luck with the graphics drivers.

@anon63373689 See my post here with instructions …

2 Likes

Try getting into the Radeon setting and set it as the graphic card to be used for sketchup.
Sometimes you can even do that when you start sketchup by right clicking the icon and choosing the Graphic to use there.

Wonderful, it works now! I had no idea it wasn’t choosing the AMD Graphics card though I was plugged in. Thank you all for the useful advice :grinning:

1 Like

That’s not what I said !
Install as your normal-user by using “Run as administrator” on its installer exe file.
After that use the installed SketchUp [exe] your normal-user.
Do not run SketchUp as administrator, or reset its properties to do that…
If you do it’ll cause other problems - like breaking drag-and-drop !

If it works OK now you can let it be, but your screenshot shows that your AMD graphics driver is quite old. When in the mood, or if problems come back, it wouldn’t be a bad idea to go to the AMD sit to look for a newer one.

2 Likes