Sketch up Make


#1

Ive re-installed sketchup make 2017 on my laptop recently and for some reason it does not wasnt to start up. constantly getting the crash bug splat screen.
Latest visual studio has been installed. and graphics card updated.


#2

Are your computer running in power saving mode? Mine lives a peaceful and plugged in life on my desk at home most of the time, but a year ago when I took it with me to the SketchUp devcamp SketchUp crashed immediately on startup. It turned out the computer switch to power saving mode when unplugged, and that this somehow prevented SketchUp from running.


#3

Ive switched of power saving and plugged in the power cable. still no luck


#4

This sort of problem is often caused by an inadequate graphics driver or adapter.

Are you submitting the BugSplat reports? If you do so and include your contact info, someone from Trimble should get back to you.


#5

I did submit previously but with out details. Will try re-submitting with… Im running a Intel HD graphics 520.


#6

That could be your problem. Intel HD graphics are notorious for broken OpenGL drivers. You could try updating the driver to the latest from Intel and see if that helps. Beware that Windows 10 is notorious for sneaking a broken driver from Microsoft back onto your computer during silent updates!


#7

Drivers updated , still the same. Crashes immediately without opening


#8

When you installed it, did you right click on the installer and choose Run as administrator?


#9

When it crashes, are you getting a BugSplat dialog?


#10

The source of the driver is important.

It’s not clear if you let Windows search for the driver or if you went directly to Intel.
The latter is best.

This article has links to what you need.

How can I update my computer’s graphics driver? — SketchUp Help
https://help.sketchup.com/en/sketchup/how-can-i-update-my-computers-graphics-driver


#11

this is the pop up.
image


#12

ive went to intel website , no updates were available for the graphics as the latest drivers were installed.


#13

Thanks. Are you submitting them (i.e. clicking Send Error Report)?


#14

I have submitted numerous times. no responses yet


#15

use the OpenGL-wise less demanding SketchUp Make 2016 version instead… additionally if display issues are persistent you can disable the use of hardware acceleration (= GPU) at “Window > Preferences > OpenGL”.


#16

I’ve asked a developer to look at the crashes. Stay tuned.