Sketchup Pro 2021 Crashes on Startup shows bug splat no report details

Hello everyone,

I installed the latest version of Sketchup Pro2021, and opened a file I created with Sketchup 2020 and it worked just fine for a little over 24 hours. I actually rendered a complex scene with Maxwell Render 5.2.

I went back to edit the drawing and tried to import a door from Warehouse, then it crashed with no report details. I tried to run it again it kept crashing again and again on startup.

I have deleted and reinstalled the SU Pro 2021 a few times, installed and run as administrator, changed video card drivers, reverted to latest drivers which it ran on perfectly during the 24 hours that it worked.

Nothing has worked.

I have a drawing that is over 3GB that I was working on for a clients project and presently I just want my life back (lol) if I cannot get the SU 2021 it to run properly. The file has been saved in 2021 already with no backup in 2020.

Please, if there is no known solution to this startup issue, I will really appreciate it if someone would be so kindly to help me receive the file and save back in Pro 2020.2.172 or earlier 2020 and return to me. This will be greatly appreciated as this is a serious work/client related case

Please see the system specs below, I hope it helps.

Further information- my computer was bought configured with the Quadro card from EUROCOM, never had video driver clash issues and the only drivers it shows is the NVIDIA Quadro P3200 no intel or other.

Microsoft Windows 10 Pro
Version 10.0.19042 Build 19042
EUROCOM Tornado F7W, x64-based PC
Intel(R) Xeon(R) E-2176G CPU @ 3.70GHz
Installed Physical Memory (RAM) 64.0 GB
NVIDIA Quadro P3200, 6GB
Adapter Type Quadro P3200,
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nvmiwi.inf_amd64_ac755a61daec48d1\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvmiwi.inf_amd64_ac755a61daec48d1\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvmiwi.inf_amd64_ac755a61daec48d1\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvmiwi.inf_amd64_ac755a61daec48d1\nvldumdx.dll
Driver Version

Please help.

Thank you

That is a humongously large file for SU. I wonder if the 3D Warehouse component just ‘tipped it over the edge’ and/or was malformed and caused the crash?

Do you still have SU2020 installed and working?

If so, I wonder if Eneroth’s Open Newer Version plugin might enable you to use SU2020 to open your 2021 file and save it back to v2020?
Extension | SketchUp Extension Warehouse.

It’s a long shot, though.

I’ve offer to try for you myself but my machine is over five years old, and has really struggled even to open a model of a fifth of the size of yours, let alone to edit it.

But maybe some forum member with a top end machine might be able to help?

Thanks for your response, I appreciate your suggestion, I’ll try it.

Unfortunately, open newer version doesn’t read 2021 files. Also, if it’s 3 GB as a 2021 file, it may be 6 GB as a 2020 file.

I looked at the bugsplat reports, and they look like they are to do with the Visual Studio C++ libraries that SketchUp uses. Try these steps, which we use in other cases where C++ needs fixing:

  1. Go into the Windows Add or remove programs control panel (the one whose title is “Apps & Features”).

  2. In the search text field, type C++. That will produce a list of the different versions of the libraries.

  3. Click on the latest version, currently that will have a name of “Microsoft Visual C++ 2015-2019 Redistributable”.

  4. Click on Modify, then Yes if asked by Windows for permission to run their installer.

  5. Choose the Repair option in their installer window.

  6. After the repair is finished, restart Windows as instructed.

Thanks for that information, @colin. I haven’t used Open Newer Version recently (it’s Windows only, and I mainly use Mac OS X) and didn’t know it won’t open 2021 files.

I hope your suggestion of repairing the Visual C++ files will work for the OP.

Thanks @colin, I followed your instructions to repairs the c++ and it did not work. I went back to the list and noticed there were two of them and I also repaired the other

Still the same bug splat.

Also I do not think it should have anything to do with the file size, it was already 3.5Gb in 2020, which is where the file was originally created and working perfectly.

I think the solution may be more in the direction of what @colin is talking about… perhaps!

I am still hoping and looking to hope someone finds a solution

It would be suspicious that a 2020 SKP that is 3.5 GB is still 3.5 GB as a 2021 file.

If you can find somewhere that can host such big files, can I look at the file?

Okay, I’ll try that tonight and let you know

By the way, should it be smaller in 2021?

Typically half the size.