SketchUp 2021 Pro Crashes

This is a brand new laptop.

Win10 21H1
Intel Core i7-1165
32GB Ram
Intel Iris Xe
nVidia Quadro T500 RTX

Sketchup worked great for the first 3 weeks, then suddenly it got an update to v21.1.299 and now when I try to open a file it crashes to bugspat but I cannot click the view details, if I try to create a new file it does the same thing.

I have no plugins or extensions installed.

It is installed in the default location.

I have set SketchUp to only use the nVidia T500.

I have tried uninstalling and reinstalling, I even tried installing the old version and still same problem happens.

Any help would be great. I have a major project due today and as of right now I am trying to use the online version of sketchup to finish and it is brutal.

check for updated video drivers directly by the makers of the graphics cards used first.

Try if toggling between the integrated intel Iris and the dedicated nVidia Quadro from inside the nVidia 3D settings changes something.

Install(/Repair) SketchUp by “Right-Click > Run as Admin” only.

I have tried all that.

1 Like

Does anyone else have some solutions?

The other problem is that I have paid for 2021 Pro and I am still under the 30 trial, which means I have not received my serial number yet to be able to contact Support, which seems like a stupid problem to have.

You won’t. You log in with the e-mail you used to purchase, and assign the application to yourself.

if a new user you should have received 2 emails from Trimble (check junk/spam folder too), a Welcome email and an Activation email w/ an activation link which needs to be opened within 72 hours.

For activating your license in the Welcome splash screen select “License > Subskription” (and not “> Classic” which is for users of the discontinued perpetual licence) and login w/ your registered email address and your according password defined by yourself.

today also received the update popup.
unfortunately the updated version kept crashing while opening my files and even when trying to open a simple basis sketchup template.
updated the videocard drivers as suggested by my distributor.
still couldn’t open my files or any template.
so uninstalled sketchup and re-installed the previous version from my backup installers.
finally could start editting my files again.
always nice to receive these kind of updates … NOT!
anyways, hopefully this post may help someone who also struggles with the updated version…

greentings from the lowlands o/

this is surely something system specific because allmost all other users can obviously use the recent SU version w/o similar probs… I suspect the drivers of the nVidia Quadros causing the issue, they have led to problems in the past already and are btw overkill anyhow, at least for SketchUp.

  • did you have instelld SU f. Windows by “right-click > Run as Admin”?
  • any plugins/extensions installed or copied from the previous version?

So after working with Trimble for the past few weeks on this, it has come down to a problem with the Visual C++ redistributable that is used by Sketchup. What we did was to completely uninstall all versions of SketchUp and all versions of the Visual C++ redistributable (2015, 2017, 2019, 32bit and 64bit) and then we reverted back to an old version of Sketchup in my case the latest one that works is version 21.0.392. Since doing that everything is working again, I just won’t be updating to the latest version until I know the problem is fixed.

In my case they are thinking it comes down to a possible group policy or global policy on our corporate network that might be causing issues with the Visual C++ redistributable. Though our network admins can’t find anything that would be causing this.