SketchUp Pro 2021 crashes on startup after newest update 2021.0.1

Just downloaded and installed SketchUp Pro for Windows 2021.0.1. Immediately pops up a “Bug Splat” report every time. Tried reinstalling, Uninstalling all older versions, restarting. Updated NVIDIA graphics card drivers. Nothing helps. Sent bug report 2 times. Waiting on response. Any info would be helpful.

Thanks.

System:
Windows 10
Laptop - MSI GS75
CPU - Intel i7
Graphics Card - Nvidia GeForce RTX 2080 with Max-Q
Video Ram - 8gb
System Ram - 32gb

I looked at the two bugsplats that you sent in, and the error that shows is the same one as discussed on this page:

As you will notice, that’s an Intel GPU issue, and you have an Nvidia RTX GPU, so I’m not sure why Intel GPU drivers would be involved.

Are you only using the internal screen, or are you connecting to a docking station as well? Does that laptop have two GPUs, and if it does, is SketchUp set to run with the Nvidia GPU?

I see that you sent in a support request as well. It’s late here, and it will be about 10 hours before I’ll have a chance to ask colleagues for ideas. But, others in the forum may reply before then.

1 Like

On many systems you have the option to right click on the program icon and choose to run using the better card. That might avoid the intel driver issue. You should also be able to set Sketchup to use the Nvidia card in the nvidia options.
But it may still default to the intel if there are other issues.

1 Like

My current computer has an Intel processor without integrated graphics so I haven’t had this kind of problems lately, but I have seen that the Nvidia control panel 3D application settings default to “automatic selection”. In practice that has led Windows to select the Intel chip every time, presumably to save power.

1 Like

Thanks everyone for the input. Looks like the Intel on-board GPU was the culprit as you all eluded to. Here’s what happened:

I went into the Nvidia “Control Panel”, added Sketchup 2021 as a selected program and set it to ONLY USE the Nvidia RTX card and CUDA drivers. Tried opening Sketchup and still immediately popped up a Bug Splat window, so that didn’t exactly work.

THE FIX:
*Note - this may not work if you only have the onboard Intel GPU. I have a nice RTX card so the onboard GPU seems worthless to me, so I disabled it all together. See below:

I went into the Windows Device Manager (Right click on Windows Icon and find in menu). Find “Display Adapters”. Click the arrow to get the dropdown. Select the Intel UHD Graphics 630 (or whatever you have). Right click on it, go to “Properties”. On pop up window go to “Driver” tab and try to update the driver. Mine was already updated and still had the bug splat. Might help in anyone else’s situation though. I’d suggest this first.

Next, In the same pop up window, go to the “General” tab. You should see a button to “Disable Device”. This is what what worked for me. Note again that I have a really nice Nvidia Graphics card that can handle the entire load. I run high end graphics software, 3D programs, AutoCAD, editing and compositing software. I also run 3 HD monitors plugged into my MSI GS75 Laptop. It’s a beast and I know it can take anything I throw at it. This might not work for someone with a normal laptop. Just a word of caution guys.

If anyone comes up with a better actual fix, please let me know.

Thanks again for your responses. I hope this thread helps anyone else that might run into this issue.

UPDATE:
Per Box’s suggestion, I went directly to the Intel website, looked up drivers for my Intel onboard GPU. They actually did have a newer Driver than the one that I currently had (Windows said I had the most recent. Liars.) I downloaded and installed it, but still got a Sketchup pop up error rather than a bug splat. The error window read:

“Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated card.” and pointed to their website:

https://help.sketchup.com/en/context-initialization

The website only noted “SketchUp will not run if your graphics card does not support hardware acceleration.”

I went ahead and disabled the Intel onboard GPU, relying on the RTX card only and Sketchup works fine again. Hope this extra info help the developers and anyone else.

Thanks for giving me some direction Colin. Not sure if you guys can fix anything on your end but might be worth further investigation. See my workaround fix below. Not the best thing but it worked.

That was updated by windows, a check of the intel site may have given you another driver option.

1 Like

Very good, I’ll have a look. Thanks!

I found newer drivers on the Intel website but still didn’t work. Thanks for the info though.

When you have a moment to do an experiment, could you try the following (and if you’ve already done this, please disregard):

  1. In the NVIDIA Control Panel in the “Global Settings” tab change “Preferred graphics processor” to “High-performance NVIDIA processor” (BTW this is the choice that the NVIDIA Control Panel shows me on my own Windows machine but the wording might be different for you).
  2. Go back to the Windows Device Manager and re-enable your integrated Intel GPU.
  3. Launch SketchUp 2021.

At this point does it BugSplat? Or does it pop the SketchUp graphics capabilities dialog (where it would tell you that hardware acceleration is not supported)?

If you’re still not able to launch SketchUp at this point. Keep your settings the same from step 2 above and now remove the program setting you created for SketchUp 2021 in the NVIDIA Control Panel and launch SketchUp again. Does it BugSplat? Does it pop the graphics caps dialog?

I have followed all of the directions you highlighted and i still receive the Bugsplat upon attempting to launch the program. Its the same even if I try the 2020 version. Any other workaround?

If you mean you followed what Thayer had said, those were ideas for dvo3500 to try. As it didn’t solve the problem for you, read through dvo3500’s long post, and see if his solution works for you.