SketchUp crashes when I try to open anything

I just updated to the latest version of 2021 Pro yesterday (from an earlier version of 2021), and now the program falls on its face when I try to open any file in my library. I cannot tell what the problem is for the life of me.

Edit: The program is also crashing if I try to create a new file. I can literally do nothing with this software right now, and that’s a big problem being in the middle of a build. I’ve ran a repair and uninstalled/reinstalled with no avail.

When you installed/reinstalled did you right click on the downloaded installer and choose Run as administrator?

Have you updated graphics drivers lately? Check in the Nvidia control panel to make sure that graphics card is set to display SketchUp.

I didn’t run as Admin, I’ll try that. I did update the drivers a few weeks back, but that didn’t affect the old install. I’m not sure what you mean by “set to display SketchUp”? I’m more than happy to check the settings, but not sure what I’m looking for.

Edit: also of note, LayOut works perfectly fine and opens all my files. This is the part that is scrambling my noodle.

You should always install complex applications like SketchUp by right clicking and choosing run as administrator. At this point do that and then click on Repair if given the option.

Right click somewhere in the blank area on your desktop and choose Nvidia Control Panel. Then in Manage 3D Settings look at the Program Settings tab for SketchUp.

The repair as admin didn’t help. I’m going to do full uninstall/reinstall after I mess with the video settings.

I know how to get to the program settings for the video card, I just don’t know what settings you’re wanting me to verify. I.e. what should be on or off.

Just make sure that SketchUp is shown to be displayed by the Nvidia graphics card. You could also check in Sketchup’s Preferences>OpenGL.

Are you getting Bug Splats or just silent closing of SketchUp?

Yes, it’s showing up, and I reset it to defaults for the program for good measure.

Bug Splats. I get the initial UI for opening files or creating new, but the moment I make a selection, it Splats.

Are you sending the Bug Splat reports in? It’s only 6:10 am in Colorado so kind of early but if @colin has a chance when he gets in to work he could look up the Bug Splat report and give you an idea of the cause.

Some of them, not all. I figured it would be obnoxious to have 82 Bug Splats submitted for the exact same problem.

Might be but it might get some attention.

We’ll hope @colin comes up with something brilliant.

Thanks for your help. You’ve been the usual great person for me this morning. I just tried the full uninstall/reinstall as admin to no avail. I’ll keep trying different things.

1 Like

Sorry I didn’t get you back up and running though.

Maybe it needs the Fonzy touch.

This is interesting. I tried to open a file from Explorer directly, and they aren’t associated with the program.

And if I try to open one of the files, I get this:
Install problems2

Something tells me that “%1” shouldn’t be there…

Very strange indeed.

I found 2021 clashed with earlier versions on one of my systems, Once I uninstalled all other versions it worked. 2021 not showing in the app menu is the main similarity. I didn’t have the crashing issue.
A bit drastic if you keep older versions for compatibility with some extensions.

You just made me think of something there. The app menu shows TWO versions of 2018 (which I don’t have), so maybe something’s getting confused there. Standby…

Do you have multiple monitor’s attached?
How are they connected?
A lot of ‘hubs’ don’t play well with OpenGL

There is an issue we know about that is provoked by certain docking stations. The only certain work around for now is to not use that docking station. You could try a test running only on the main monitor, and see if the crash goes away.

If you do have that situation, do you have time for me to do a test on your machine? It might helps us to figure out why the crashing happens. We have not yet been able to get one of our PCs to fail that way, which makes it hard for the developers to track down the issue.

Not using any docking stations or hubs. Just two ports out of my video card. I’m available until the early afternoon if you want to troubleshoot this.

We did a screen share so that I could investigate the known issue I mentioned. It turned out though that it was quite a different issue, and that you would get a bugsplat even if all you did was close the welcome screen. The bugsplat report suggested something wrong with the C++ libraries.

Following a support article about that (on Autodesk’s site), we uninstalled all versions of C++, and then normally would have downloaded the latest installer from Microsoft. Instead I ran the 2021 installer again, to find that it didn’t install the C++ libraries. I will report that to colleagues.

What did solve the problem was to install and run 2020.2, after that 2021.1.2 ran ok, and the original crashing issue was fixed.

I realized something. With SketchUp I had done a repair, and not an uninstall and reinstall. It could be that the SketchUp repair does not also do the C++ repair. Which does mean that in some cases a repair won’t help, and an uninstall reinstall might. In this case though I think something was wrong with the C++ libraries.