Program won't open after update 2023 pro

I updated my program(2023) and the program won’t open.
Please help me.
Thank you

What happens when you try to open it?

Try repairing the installation. Right click on the downloaded SketchUp 2023 installer, choose Run as administrator, and then, when prompted, Repair. After that completes do a power off reboot of the computer and see if SketchUp will open.

not work… any suggestion?

Answer my question:

and then closed …

I’ll go a step further,
Open the task manager, and try to open sketchup, layout or stylebuilder
Does any process pops up in the task manager ?

and after it closes, do they also close ? or does anything remains stuck ?

1 Like

I’m having the same issue. I’ve uninstalled, reinstalled, repaired, and done all the possible fixes you can think of, but still nothing.

Immediately I launch a project it closes sketchup.

Have you all the drivers up to date? Specially the gpu drivers. After the program shuts, do you get a bugsplat window or nothing? If you get a bugsplat, have you sent any of them with your mail and detailing the issue?

All my drivers are up-to-date and there is no bugsplat message.

Have you tried to open sketchup from the file you saved in your pc? for example on the desktop or documents folder, not by opening sketchup and selecting the recent files on the welcome window, also what happens if you try to open an empty file?

Did you download the GPU driver directly from NVIDIA’s website or rely Windows to find “the best” driver for you ?

What Paul said is true, windows updates are not trustworthy, you must download the drivers from the Nvidia’s website or a better option is to install the GeForce experience software and install the studio drivers.

I use GeForce Experience to update the GPU drivers I’m currently using Studio drivers and I checked for updates today. Also tried launching from a project instead of from the launcher directly still isn’t working. Layout and Style builder are working without a hitch though.

1 Like

One thing to check is to open the Nvidia Control Panel 3D application settings and check that SketchUp is set to use your Nvidia graphics. Automatic selection doesn’t work correctly.
Next thing to check would be your extensions, especially if you have copied them directly over from an older version of Sketchup.

Can you open a Sketchup file from layout? Can you open a new empty file?

I can’t open a new file or an existing one.

Do you use a 3d mouse?

No, I use a normal mouse…

As Anssi suggested above – have you been into the Nvidia Control Panel 3D settings and set SketchUp to use Prefer Maximum Performance.

You could also check Windows settings > System > Display > Graphics to see if SketchUp is set to High performance.