2023 closes on open

I installed 2023, and I got to the Home window. When I try to open a SU file or create a new model, the new window begins to open, and then the program closes.

I have re-installed a few times. Any thoughts or suggestions?

1 Like

Did you right click on the installer and choose Run as administrator? If not, do that and then choose the Repair option.

Make sure your graphics drivers are up to date. Check with the manufacturer and don’t trust Windows to tell you.

I have the same symptoms for SketchUp 2022, and so thought I may as well try to figure it out.

The installer repair, even as admin, didn’t help, so next I tried deleting the app data folders. Deleting those didn’t help either. Then I tried the SketchUp folder inside c:\ProgramData\SketchUp\SketchUp 2022. Deleting or renaming that folder then let SketchUp start a new document.

In my case I narrowed it down to the 3Dx plugin that was in SketchUp 2022.

So, look in c:\ProgramData\SketchUp\SketchUp 2023\ (you can copy and paste the path I gave into File Explorer), and see if there is a Plugins folder. If there is, what plugins are in there?

I had an idea about uninstalling all 3Dx software and installing using the latest installer. I did the removing part, then found out there seems not to be a Windows 11 driver for SpaceMouse. Would be happy to be wrong about that.

I had this same issue. Just rolled back to the previous version

I appreciate the responses. I have not had the chance to address this issue again.

No “plugins” folder

Yes on updating all drivers and still closes on open.

I have tried all the options, and it still closes on opening. I have to go back to work but please tag me if any similar issue with other uses comes up. Thanks for your help.

BTW … Layout 23 installs and appears to work fine.

I am continuing to install 2023. All of the 2023 APPs are installed (Layout etc.) but Sketchup 2023. When I try to run the “Repair” option, I get a popup saying “SketchUp 2023.msi” is on a network resource that is not available. Which is not true because I can open the file. When I do open the msi file, another installer (different window graphics versus the default ibstaller but labled as SketchUp 2023) for Sketchup 2023 opens and completes the installation. However, this installation also fails. That is SketchUp 2023 opens to the welcome screen, I select any option (one of my files, or a default template) and the program begins to open and then closes.

Is no one having this issue?

Just ran into this issue myself today- started with a bluescreen, with vanilla 2023, so I thought that by updating to 2023.1 that I would fix everything… unfortunately I have been installing/uninstalling/repairing Sketchup and video drivers for several hours now… to no avail- the only thing that changed today was that I installed Twinmotion 2023.2 Community Edition which had some C++ things that came with it, and I did not restart my machine after I installed it- so the Bluescreen force restarted my machine- which is the only thing I can think of- but can’t figure out how to backtrack that part of things… :sweat: :sob:

Looks like Twinmotion was not necessarily the culprit- looks like 2023.1 isn’t compatible with Enscape currently- just putting an x in front of the name in the folder fixes everything for now.

Colin… trying to make this work … in Programdata/Sketchup/Sketchup 2023 there is a liclog.txt file. Last of lines the file for SU 2023;

CheckExtensionLicense: 378db250-9692-4534-9aa0-2f81daa3daee, version 1.0
Extension is not licensed: No license for product (-1)

Last lines of the same file for my working 2022;

CheckExtensionLicense: 378db250-9692-4534-9aa0-2f81daa3daee, version 1.0
Extension is licensed

So the 2023 reads “not licensed” versus working 2022 reads “Extension is licensed”

Is that an indicator of something?

Which extension is that? I looked at your account, and could see a potential problem with Sketch-Cuisine, but I think this one isn’t that extension.

I fixed the problem I saw. Try uninstalling any extension that isn’t working, and reinstall it, to give the license another chance to be created.

The problem I am having is the new installation of SketchUp 2023 opens to the welcome screen and then closes after I select any option on the welcome screen. I assume 2023 is loading without any extensions as did previous versions.

To be clear, I have not been able to open SU 2023. So, I assume there are no extensions in my SU 2023. Correct? I am searching for a solution to get 2023 open.

Did you have 2023.0 installed? 2023.1 will use the same extensions.

This thread has been about SU 2023 not installing for me. It successfully installs and then when I open it, the welcome screen opens and no matter what option I select (open a template, open a file etc.) SU closes. I have tried your suggestions on the 3D mouse and suggestions from others. NO success. Layout, Style Builder etc. all run. Not SU.

I am realizing another odd behavior. When the welcome window opens for SU 2023, the recent files shown and the template are from my SU 2022. Since SU 2023 runs as a new and separate APP, why are recent files from my SU 2022 showing? Should the welcome screen be only default templates and no recent files?