SketchUp Desktop 2023.1 Crashes

Hi Guys,

I have installed the latest update for SketchUp Desktop 2023.1 on my computer.

Whenever i launch the desktop sketchup application, it crashes and the app close.

I can not even go further from " Welcome to SketchUp Page".

Any ideas how to resolve this issue?

Is anyone else is facing the same?

Need urgent advise…

For me, that would happen because I had the 3Dx plugin installed, on Windows 11. I don’t think they have Windows 11 drivers yet. Removing the extension solved the problem of SketchUp crashing.

Do you use a Space Mouse?

I do have some plugins installed. What you said now make sense to me because I realized that there is small dialogue box pop up, which is stopping my SketchUp 23.1 v to launch.
How should i fix that?
I don’t use Space mouse.

If you are on a PC, you can open File Explorer and paste in this path:

%AppData%\SketchUp\SketchUp 2023\SketchUp\

Inside that folder is a Plugins folder. Rename the folder to something like OldPlugins, then reopen SketchUp. If SketchUp opens and runs ok, one of the plugins you have installed is causing a problem.

Look inside the folder OldPlugins, and tell us what files are in there.

Hey!

After renaming the Plugins folder, my SketchUp runs ok!

However, sometime it show me this dialogue box after i relaunch my SketchUp.

After i log out and resign again, the application run fine. Not sure why the screen said my device is not authorized.

So, how do I reinstall back my plugins to use?

And the following screenshots are the plugins that i have installed previously.

Remember the small dialogue box, that pop up was , Zhouxi_Magiz.

I suspect it was the one stopping my latest SketchUp version to run.

Duplicate the (renamed) Plugins folder and rename it to the original name (Plugins) and then delete all files from that specific extension (Zhouxi_Magiz.rb and it’s corresponding folder)

1 Like

Thanks Mike! i will do that.

Thank you. It worked like a charm.

1 Like

Yes, I’m facing the same problem as well ~ These few days I have been installing the plugins few times, but all my installation done, SU crashed.

Today I purposely listed down the plugins and install one by one, and jotting down if anything pops up. Magiz, Zhouxi_Magiz.rb is the suspicious one. Also I find out that Zhouxi_Magiz folder in the plugin folder couldn’t be delete, not evenwhen running command prompt.