Hangs upon opening SketchUp Pro 2017

win10
startup
windows10

#1

Hi my name is David. I purchased a new computer ROG 751 with 32 GB Ram and NVidia GeForce card (8GB)
running windows 10. I’ve had to uninstall and reinstall twice because the program is not responsive after welcome screen.
Anybody else have same problem?
Thanks!


#2

I’m having the same issue. I’ve had Pro since this was a google product and upgraded each year. 2017 takes forever to load a model or even open a new file. Hope this can be sorted out because it’s eating up a lot of my drawing time.


#3

When installing SU 2017 you need to right-click on the installer and select Run as Administrator.

Also, make sure that your graphics card driver is updated. Often times this means that you need to visit the computer manufacturer or graphics card vendor’s site rather than relying on Windows update.

If your system has onboard and discrete graphics cards, make sure that SketchUp uses the latter.


#4

There is no on board graphics card, the driver is updated the only thing I haven’t tried is running as admin.


#5

is there a way to attach the sketchup check log or an image file here?


#6

You can upload a file by clicking on the 7th icon from the left (the arrow pointing up) when posting.


#7

A ROG 751 is a laptop. By default, laptops use integrated Intel graphics chipset (and its driver) to save power.

Open the Nvidia control panel. Go to 3D settings. Open the tab to custom the Nvidia card for individual programs. Check that the Nvidia card is selected to run SU.


#8

there 22 settings for sketchup avail. on nvidia 3d settings. No idea which one to set.
any ideas?


#9

Look for the setting that has a dropdown menu indicating a selection for something like a display adapter. There aren’t that many settings with a dropdown menu. Look for the one listing your Nvidia card.


#10

If your driver version doesn’t have the dropdown menu at the top, the setting is usually “OpenGL-rendering GPU”. Mine is set to Automatic as my computer is a desktop with no integrated graphics present.

Anssi


#11

AND on Windows you can simply drag and drop allowable file types into the post edit box.


#12

SketchUpLog.sulog (96.2 KB)


I don’t have that option on my dialogue box.
I’ve attached all the setting available to me. Maybe its called something different in mine?
thank you,
David


#13

Look at the Power Management Mode. Using your Nvidia card is definitely not optimal for power conservation with a laptop.


#14

I’ve tried the power conservation setting to no avail. If I do an uninstall and reinstall it works for first save but won’t open after that. I may need to forget about sketchup and just start using formit 360 pro instead. What a shame love using sketchup.


#15

Laptop - gaming laptop - right? That’s what I saw after Googling your model. Odd to not have an option to select graphics preference. Your menu options are the same as my desktop machine. And as I mentioned above, a setting option would actually list your card by name.

You have very good computer specs to run latest SU and should be good for a number of years. There are more things to check, including a few unfortunate MS updates…

  • R-click on installer and choose Run as administrator?
  • Did you get graphics driver update from either computer manufacturer or directly from Nvidia (don’t rely on Windows update)?
  • Add any extensions/plugins?
  • Important Update on a few Potential SketchUp 2017 issues on Windows look for manually updating .NET Framework and possibly uninstalling all VC++ installs from add/remove programs and downloading and installing VC++ fresh from Windows Update.
  • Slow selection tool (SketchUp 2017) related to a problematic MS automatic update

#16

Joy, I looked at his log files, and only the Nvidia card is listed.
The processor is supposed to come with a integrated HD 530 GPU, but perhaps it has been switched off in the BIOS settings ?

At this point I’d verify that SketchUp is using the Nvidia GPU via the “Details” button, from SketchUp’s OpenGL panel of the Preferences dialog. (On first start,… if he can get that to happen.)


#17

While verifying which GPU is being used through Window > Preferences > OpenGL > details, disable Use fast feedback to see if that makes any difference. That setting is also in the OpenGL menu.


#18

is this to be done in the Nvidia settings or in windows 10 settings, and if windows 10 setting how do I access the preferences?
(Hope I don’t sound too stupid here…)


#19

This (above) is referring to SketchUp’s Preferences dialog, opened via the Window menu.
Once it is opened, you switch to the OpenGL panel, and click the Details button.
After the Details dialog is displayed, you can press ALT+PrintScreen keys to copy the dialog image to the clipboard, then click inside the forum post editbox, and press CTRL+V to paste in the image.

This is an example from my old student grade notebook I use for websurfing.
(It shows SketchUp 2016 is using an integrated Intel GPU):


#20