SU 2018 "Not Responding" on my new laptop running Window 10 Pro, version 1709

Hi SU Community,

I am new to SU, I have bought a new gaming laptop with NVIDIA graphic card, bought SU pro and downloaded SU 2017 version which appeared to open and work fine, and then I got an email from SU to download the 2018 version within days of original purchase… great right!

But after downloading SU 2018, the program opens, the window is blank, then when I click on a the “file” pull down menu the software locks up “Not Responding” in upper left corner of the window.

I have had three back and forth conversations with support, downloaded graphic card drivers for NVIDIA; updated Intel drivers, but nothing is solving the problem…

this is expensive software, and I can’t use it! Appreciate the SU community help. thanks.

Have you set SketchUp to use your Nvidia graphics card in the Nvidia control panel 3D application settings?
image

As well as making sure that the Graphics-Card is properly configured…

Also make sure that you always install SketchUp correctly.
Double-clicking the installer icon etc is NOT sufficient [even if you have admin-powers].

Close SketchUp.

As your normal-user login…
Find the installer’s exe file’s icon [probably in your Downloads folder ?]
Select its icon.
Right-click > context-menu…
"Run as administrator"
When prompted choose "Repair"
When it completes restart SketchUp…

Any better ?

Hi, thanks for reply, this is what I see on my system…

screenshot4_SU_v3

thanks TIG for the suggestion, but the “repair” did not work either…
totally bummed

In your version of the control panel, the “OpenGL rendering GPU” setting should be set to show your Nvidia card, not the “automatic” option. Is your card a Quadro?

Hello Anssi,

thanks for the advice,

unfortunately it does not seem to do the trick …

I don’t think I have a quadro, it is not noted in the hardware info window…

I’ve had the exact same issue, whenever I try to load any file, with 2018 and 2017. or if I start the program, I can choose my template on 2018 and then click next and then it stops at Untitled - Sketchup Pro 2018 (10 days left in TRIAL) (not responding)… And seeing how I can’t get any work done and I have deadlines comming up, while I can’t access my work.
I updated my Bios and Drives on my computer as my preformance suddenly had taken a plunge, preforming in the bottom 15% of what my hardware is capable of. And then my windows update.
Everything leaving me with the exact same issue. And as I have two NVIDIA Geforce GTX 980 Ti. So here it shouldn’t matter which of the two my computer uses for rendering. Even though going through “OpenGL rendering GPU”. And noteworthy is that I have been using the same computer ever since last year with the same program and hardware setup. I am considering if the actual creators fall update did something to both 2017 and 2018 or that 2018 version has changed something that was nessesary for any of the two versions to work. I mean, as my computer has worked just splendidly untill nov/dec 2017, I don’t see how the fixes from 2014 could fix this?

Try going to settings > apps and features > Microsoft Visual C++ > Select it > click on Modify > Repair . Do this with all that will allow the process. The 2012, 2013 and 2017 versions.

Allright, so the strangest thing happend last night while I was smashing my head on the wall, I had kept trying to change the 3D settings for a while, and eventually I got boored of that and turned on the SLI bridge on my graphics cards, then turned them off… So what happend next was that my nvidia graphics cards, stopped showing up as GPU 0 & 1 on the task manager and were now starting to get assigned as GPU 4 and 5… Even though on my stationary computer only have the same two physical cards on my motherboard. I am starting to doubt my sanity. Even though my devicemanager shows only the two…

What I basically changed on my Settings was anisotropical filtering 4x, G-sync, CUDA GPU is the same as for open GL, gamma value correction on, transperancy multisampling, maximal preformance, 2 pre render frames,textfilfters: anisotropic optimizing on, quality preformance, force negative detail, tillinear opt, V-sync use 3d Program setting, in which I use my 3D setttings balanced. And my SLi is off, since I use two screens.

I also, made the changes for multiple thrimble Sketchup versions, as 17 and 18 show up seperatly but doesn’t tell anywhere as it’s name is Sketc…)

The recommended setting for anisotopic filtering, antialiasing etc. is “application controlled”.

Okay, so my system worked for a few days, but now I am back where I started.
I ran the Sketchup 2017 Checkup and I got this , Results:

Error: Your “GeForce GTX 980 Ti/PCIe/SSE2” graphics card has 1 MB of graphics card memory. SketchUp requires a graphics card that has 256 MB or more of memory.

Which again. Now working. With all settings on, with all options to program control on. SLI: The Max 3D preformance is only working with only one screen. And the program doesn’t seem to work without it.

Checkup relies on a wrong informationen generated by the internally used MS System Information tool (“msinfo32.exe”), do ignore.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.