SketchUp Make Not Responding Upon Opening


I just purchased a new laptop. I downloaded SketchUp 2017 and everything was working great. All of a sudden, it began to malfunction. When I went to move certain toolsets around the screen I would get a ghosting effect - the only way to get it to disappear was to minimize the window and maximize it again. Now, my Sketchup is not responding after my first click and I can’t do anything. I am unable to adjust any of the settings. My graphics card is a NVIDIA GeForce GTX 1017 with MAX Q Design and like I said, its a brand new gaming laptop. I have updated the drivers and restarted the computer. Would someone please help. I’m still within the time frame to return this laptop if that is what the problem is.

Thank you kindly,


Make sure SketchUp is using the Nvidia card and not the integrated Intel GPU. Go to Window>Preferences>OpenGL and see what it indicates. Also update the Nvidia graphics drivers. Although the computer is new to you, the drivers are probably not up to date.

And another thing. When you installed SketchUp, did you right click on the installer file and choose Run as adminsitrator? If you didn’t, do so and when prompted, choose the Repair option.

Thank you for your help. I uninstalled it and downloaded 2019 trial version.

Does that work? When you installed SketchUp 2019, did you right click on the installer and select Run as administrator? Did you update your graphics drivers?

So far it does. I double checked that it was running the correct graphics card and installed it as an administrator. Also, the drivers for the graphics are all up to date. I was unable to do anything with the 2017 version, it was immediately Not Responding upon opening so I wasn’t even able to check the graphic card on the last version. I will let you know if I encounter any more problems. Thank you for your help.

1 Like

Hi DaveR,

I’m having the same issue where SketchUp is Not Responding. I’ve been working on a file all day, closed it and now I’m wanting to open it again and its been Not Responding for about 4 mins now. I’m running the 2019 trial version. Can you please help again.

Thank you kindly.

I don’t know if I can help or not. How big is the file you’re trying to open?

The file I am trying to open is 144MB but I’m not even able to open a new drawing with nothing in it.

Do you get a not responding message when opening a blank file?

Yes. That’s what is strange. This is the same issue that happened yesterday with the 2017 version. I uninstalled 2017 and reinstalled the 2019 version. It was working just fine up until now.

I just received a notification saying: File Insight. High CPU usage. 99% of CPU is being used. I have a brand new i7 processor, wonder what’s going on?

Not sure. Try shutting the computer down completely. Power of. Then restart. If it’s a notebook, make sure it is plugged in to mains power.

I’ve tried that twice already. I’m in the NVIDIA Control Panel, are there any settings that need to be toggled on or off?

I don’t think but while you’re look at it, go to Manage 3D Settings and then click on the Programs tab. Do you see SketchUp listed?

I do, Yes. I have it set to use the high performance NVIDIA processor. Played with some of the settings, restarted, still can’t open a blank SketchUp doc.

I’ve open up my task manager as well, when I start a blank SketchUp doc, my power usage is Very High. Is this due to a Graphics Card Isssue or an issue with my processor?

Is it power usage or CPU usage that is high?

Both. I received a notification from Norton saying that my CPU usage was at 99% capacity. When I try and open a blank document, my Task Manager says that my Power usage is Very High. Looking at my Task Manager now, my CPU is at 15% and my GPU is 0% whilst SketchUp is Not Responding

Very strange. My CPU usage doesn’t go above about 18% on startup.

Is the computer plugged into Mains power?

Is it possible your antivirus software is blocking SketchUp? It needs to ping its servers during startup.

Its plugged in, yes. I’ll check with Norton - its a new computer so I only have the trial version and haven’t really looked at it. I’ll check.

Just disabled all of the Norton features - restarted. Still the same issue. My CPU doesn’t go above 18% now when I try and open.

So now the CPU doesn’t max out but it still shows as Not Responding?

Can you open the attached file?
Test.skp (16.6 KB)