Upon startup of Sketchup 2017, window opens but message "Not responding"


#1

My problem seems about the same or similar as a few others, giving a fair bit of frustration.
I am new to blogs, new to forum, and new to SketchUp, trying to evaluate if to purchase pro 2017 or NOT???
I have read a few of the posts I thought were close to my needs but they did’t seem to give the answers I need.
I have down loaded SketchUp 2017 make version with the 30 day trial of the pro version, all goes good with the “right click and install as administrator”, I open it choose template and of I go, HAD A BALL playing with my new toy, did some tutorials etc. Closed program down after saving my drawings.
But when it comes to opening the program again, this is where problems begin, it opens the SketchUp window with the tool bars in place but no red blue green crossy thing and when I click any where on the window to try and open something or just in open space in window I get the “Program not responding” at the top left of window. The only thing I can do from there is close it down, with a choice of “wait for program to respond” or “close down now” (and waiting does not work , I tried)

I have used the “SketchUp Check System” and my system comes up all good to use with all green lights.
I have an Intel® Core™ i7-6700HQ @ 2.60GHz 8.0GB RAM 64bit window 10 home Nividia GTX970M that my system tells me is openGL

So all should be good I think. The one thing that does work is to reinstall the SketchUp exe. and use the repair install, then I can use it just fine again until I close down and try and restart program next time. And it all starts again.

Cheers for any help to sort this issue

PS Layout and Style Builder that come with the pro 30 day trial ( I’m guessing) open and I can click things in them as they do stuff but I don’t know what to do and how to use them,so I can’t say they work properly LOL.


#2

Very odd.
Try holding down shift as you launch the program.
This will open a fresh version, it may be trying to open an autosave that isn’t correct.


#3

When you installed SketchUp did you right click on the EXE and choose Run as administrator? IF not, do that and repair.


#4

Make sure SketchUp is set to use the Nvidia card and not the integrated Intel graphics.
Do this via the Nvidia Control Panel.

Verify in SketchUp via Preferences > OpenGL > Details that the renderer is the Nvidia card.


The only other things that could be happening is permissions issue on one of the resource folders needed by SketchUp. (Perhaps it is having trouble copying the set of Trimble extensions distributed with SketchUp to the user %AppData% path ?)

Or… it wants to check licensing via the internet and is having trouble … thinking your not online,… or your firewall is blocking those couple of ports SketchUp licensing needs ?


#5

@Box cheers for the effort
just tried that and didn’t work


#6

@DaveR
cheers anyway but yes done that


#7

Have you installed any plugins? If so manually removing them from the plugin folder could help.


#8

@eneroth3
Hi
No, I haven’t got that far yet, no plugins
cheers


#9

What OS are you using? Perhaps an automatic update stopped things from working.


#10

@DanRathbun
Cheers for the advise. SketchUp is all set up good to go with Nvidia card and verified in preferences … I eliminated firewall possibility by turning it of, and it still was not responding. The AppData thing sounded too confusing.
I have played with it and posted my efforts for all to see what I did if that’s what I’m meant to do. AndI’ll see how it goes.


#11

Hi all and thanks for all your time and effort,
It took a while with uninstalling and installing program over and over to where I think found what is triggering the issue, and that seems to be that SketchUp doesn’t like my second screen. Don’t know why because I do. It runs fine on the second monitor as an extended screen BUT DOES NOT LIKE to be shut down from that screen, if I drag the SketchUp window back to my laptop screen and close it down from there and reopen SketchUp it opens fine on the laptop screen, then I can drag it over and it’s fine again. D’oh!
I will have to investigate that issue later.
cheers again for everyone’s effort and time I’ll see how it goes. :relieved:
Now I mite get through my 19 days left on my trial


#12

Oh I run SketchUp on my external 25" display, but I have the external display set as the primary, and the internal notebook 15" display set as the secondary. All works fine.

ADD: I do seem to remember there being some issues with SketchUp and the Nvidia Desktop Manager, in the past.