Sketchup Pro "Not Responding"

Hi all,

Sketchup pro 2020 randomly will not load upon opening, even a new file. Starts to open, and just says “not responding” Never had any issue. Tried re-installing, updating drivers, etc. Please help if anyone has any solutions. Also tried using 2021, same issue. Very Frustrating. I tried looking around and can’t seem to find any solutions. Thank you for your help!

I should also mention, Windows 10, NVIDIA GTX 1070

The “Not Responding” message indicates SketchUp is busy doing something.

Make sure you installed SketchUp correctly. You should have right clicked on the downloaded installer and selected Run as administrator. If you didn’t do that, find the installer, use Run as administrator and then select Repair if you are given that option.

A lot of things happen during startup. Extensions are loaded and SketchUp checks the Extension Warehouse to see if any extensions need updating. Depending on your internet connection that might take a bit of time.

Also look in Window>Preferences>OpenGL and see that the Nvidia card is being used.

Thank you for the response… Still have the same issue. I also mention that sketchup will open but will have a partially loaded screen, only when I click anywhere on the screen then “not responding” and have to close out of the program

this sounds like a graphics card issue. Go to the Nvidia site and install their latest drivers.

Thanks again. Latest driver still same issue. Even did a rollback on the driver to a time when everything was working properly. Still same issue. Other programs such as CAD open no problem. Any other suggestions?

2019 Version works. But my previous 2020 which worked perfect a few days ago now has that issue. What could possibly be causing this?

Well, SketchUp 2020 hasn’t changed since last year so you need to look at what has changed on your computer. A Windows update? Some new extension?

What you’re describing can happen if the combination of monitors you’re using has changed in some way. One thing to test is to open SketchUp and see if you get to the welcome screen ok, then start a new document. My guess is that it also will go into the not filled , then not responding after a click. Doing that test will at least rule out the problem being a specific file or files.

Yes the same issue happens. It’s not a specific file

Can you think of any changes in your displays or their settings that have happened recently? Including whether SketchUp is still opening documents in the same display as it did before.

What happens if you disconnect additional monitors?

I think we are onto something… When I open sketchup 2019 (which works) it opened in my left monitor( I have two) when I tried to open 2020 or 2021 it opened half on each screen and then would not proceed

More and more information slowly leaks out. :wink:

SOLVED! for anyone who may have this issue: I had to change which monitor the program opened on. If it opened partially or fully on my right monitor (slightly older) somthing got jammed up. 2021 now working perfect!

Something to watch for is that the welcome window and the document window need not open on the same screen.

The age of the monitor shouldn’t matter, but whether the RTX GPU is what is driving the older monitor will matter. One option you could try is to turn off the Intel GPU in the device manager settings, then the Nvidia should be in use for both monitors.

It also matters where you have plugged your monitors. On a desktop computer, you may have ports connected both to the motherboard and in the graphics card. You would need to use the latter. Newer graphics cards may not have connectors like DVI or VGA but, like on mine, they might be available on the motherboard side while the RTX card only has DisplayPort. If your computer has an integrated video chip, the motherboard connectors would most probably use that. I have also met laptops and laptop docks that only support integrated graphics on external monitors, or that don’t support OpenGL on external monitors connected through a dock.

1 Like

I have the same problem …

Then you should have a same solution… :wink: post 14

2 Likes