SketchUp Pro 2017 Windows 10 Not Responding

win10
windows10
windows_update

#1

every time I open an existing sketchup file it takes forever. I then get the blue circle that says “not responding.” After a few minutes it will finally load, and then within 5 minutes of doing anything (moving an object, importing an object from 3d warehouse, etc) it will again give me the blue circle and the not responding notification. I have to close the entire program, find the backup file that was created, and then reopen sketchup (and repeat the same exact steps).

I did the sketchup “checkup” and all items “passed”.

what can I try next? This is very frustrating as I can only work in 5 minute segments until it freezes again

thanks in advance,

Jackie


#2

There have been similar reports recently. Some users found removing recent Windows updates helped while others found that updating their nVidia drivers solved the problem. I’d try the latter, first and see what happens.


#3

I clicked on “update driver” and it says its fully updated.

;(


#4

Maybe it’s time to look at Windows updates. There are numerous threads on this topic here. You don’t have to go back too far to find them.

Are you certain the nVidia card is the one being used?


#5

how would you know what graphics card is being used?

under display adapters I have:
NVidia GeForce GTX 965M
Intel HD Graphics 520


#6

Look at the nVidia control panel and check to see that SketchUp is set up to use the nVidia card.


#7

is this what youre talking about?

I clicked “add” and then tried to open my file and it still took forever


#8

That’s the window.

Out of curiosity, when you installed SU2017, did you right click on the installer and choose Run as Administrator or did you do something else?


#9

honestly i’m not sure. is there a way to find that out? sorry I’m new to sketchup ;-/


#10

I right clicked on sketchup and verified that “run as administrator” was checked.


#11

If you aren’t sure right click on the installer file (The file you downloaded from the SketchUp site) and choose Run as administrator. Then choose the Repair option when it comes up.


#12

Clicking on the Graphics Card Details in Window menu>Preferences>OpenGL will open a window that sows what card SketchUp is currently using and the driver version in use (mine is somewhat old)

Some Nvidia cards have had problems with the Fast Feedback feature so after you have verified that your problem is not due to the misfired Windows 10 security update discussed here in several threads, you might try turning that off and restarting SketchUp.

Anssi


#13

this is what I get when I follow those steps


#14

I know you said it could be a windows update issue. I cant seem to find the post discussing that and how to fix it.

i’m desperate to try and fix this issue as this is my final project in school and i’m at a standstill with this “not responding” issue".


#15

Can you change Multisample anti-aliasing to 4x?

A link to start with.


#16

“Windows update” would be a good search term to find more threads, bu the above link is the main thread dealing with that issue.


#17

thanks for the link. I uninstalled the first security update and opened my sketchup file. it still took awhile to load, but the non responding was fixed…for a short period. It used to do the “non responding” every 5 minutes, but now it can go 30 mins without an issue. but still not “fixed”

heres the list of updates that are still installed. should I delete any more so it’ll run smoothly? I couldn’t find anywhere on the link where other updates were deleted.


#18

now I’m back to slow and not responding. these are the updates that are still on my computer. however if I click an update to uninstall there isn’t a place where I “click” to uninstall.

HELLLLLPPPPPPPPPPPPPPPP!

I don’t know what else to do it get sketchup to work properly


#19

Have you considered that this might even be a hardware problem? How old is your machine and when’s the last time you had it serviced? I’ve had issues in the past like this not with SU specifically but other graphics rich programmes that relied on dedicated graphics. Found that my fan and outlets were flifthy with dust so whole motherboard and graphics card were getting too hot, and just failing every 10 minutes or so. If it’s not this you could try using the Iobit suite of tools like Advanced System Care and update driver pro as windows own built in tools are im afraid just ■■■■! You could sit for months with ancient drivers and be none the wiser! I’d recommend buying the whole suite of tools as the defragmenter tool they have is very good too, I have their apps installed on every machine in the house as they are that good and do exactly what they say on the tin. my machines purr like kittens!
If none of these help I really am sorry but you should probably just uninstall SU and reinstall it as an administrator again, doesn’t take very long. You’ll have to move all your files in their respective folders onto a USB stick and then just copy your created files back to each corresponding SU folder. Easiest way to do it so all the files go back in the correct folders. I do this sort of thing only because I have a poor short term memory. Best of luck I hope you get it sorted😊


#20

my computer is brand new (less than 3 months old). i’m going to try uninstalling SU and hope that works…