Newly downloaded Sketchup 2018 - tools not responding


#1

I recently downloaded Sketchup Pro 2018 on my new laptop (ASUS VivoBook F510UA…if that’s relevant)

Layout opens and works properly. When I open Sketchup, the window frame and toolbars all look normal but all I can see is a green field. No sky, no axis. (The axis are turned on in the view menu) When I select a drawing or shape tool and click around, nothing happens. All I can do is draw rectangles with my selection arrow that are permanent and can’t be erased.
I’ve already tried restarting my computer and uninstalling/re-installing.
Any light that could be shed will be greatly appreciated. Very confused! Thanks!


#2

You have one of the seemingly lower performing Intel graphics cards that has issues running SketchUp. (Intel 620)

First thing, in SketchUp go to:
Window>Preferences>Open Gl and uncheck the box for “fast feedback”. See if that makes a difference. It’s also worth checking your Intel drivers are the latest available version.


#3

Wow, that did it. Thank you so much!

(Also, darn this graphics card. Sigh.)


#4

Start saving your shekels so you can replace it or the computer with a respectable graphics card.


#5

I use Intel integrated and get by pretty well, though my models are small and it does have its limits, as things get more complex it starts to struggle.
They will run SU but not anywhere near as well as the recommended dedicated Nvidia graphics cards.


#6

lol ay ay captain


#7

I’ve been trying to work all day and it sucks. Returning this new laptop asap…
I feel silly for not researching this more thoroughly before but hey…I learn my lessons quickly.

Can I trouble you for your opinion one more time? I’m looking at the Dell Official Outlet website, specifically all the certified refurbished or overstock laptops with Nvidia cards. Is there any other thing I should make sure the laptop has or is that the main thing to look for? Your time is much appreciated! Thank you!


#8

I had a similar problem loading 2018 on my MS Surface Pro 5. I unchecked the “fast feedback” in Window>Preferences>Open GI and it seems to have resolved the issue.

I’m not sure if the graphics card on the i7 Surface Pro is so great? Anyone else have this problem?


#9

There have been numerous reports of problems related to integrate graphics adapters, especially those from Intel and the drivers pushed in Windows updates. Integrated graphics are not recommended and if I was looking for a new computer, those with only integrated graphics would just be off the table.


#10

IMO, … Don’t buy any machine with an Intel CPU older than 6th generation. (The faster the speed the better. SketchUp only uses 1 core, so multi-core doesn’t matter for SketchUp alone, but may help for running other applications concurrently. More VRAM is always desirable. )

Basically 3rd generation Intel CPUs and older are no longer supported, and no new drivers will be released.

The 4th generation Intel CPUs are likely to be “retired” from active support any time. This means the 5th generation support retirement may not be too far distant.

The important thing for SketchUp is OpenGL v2.0 support, and OpenGL v3.0 support for SketchUp 2017 and higher.


#11

Hello SU users,

using SU Pro 2018, I meet a recurrent issue: when I open the SU software and I try to work, the selection tool (the little arrow) is very slow, the selected item takes up to 5" to become blue, so for each work I am losing a lot of time. The problem is casual, sometimes it goes without problem! It could be related whith the web connection, but this is not sure.
Can somebody help me with this slow selection tool problem? All the other tools are working fine.

3D yours,
Clauzi


#12

your profile says W7 but this normally happens with Windows 10 in connection with an integrated intel HD graphics system (see “Win+R > dxdiag > Display”) and SU v2017+ only.

A patch to fix the issue for SUP 2018 here:

Updating the driver doesn’t harm too, for the intel HD go here.


#13

Dear Member,

thank you for your quick answer. It worked upgrading the Intel HD drivers. I first tried with that zip file, but I didn’t know in which file to place it. Thank you very much!

Clauzi


#14

in case: opening the ZIP provides you with the corresponding .BATch file which needs to be copied to the file system e.g. to the Windows desktop and launched from there preferrably by “right-click > Run as Admin”.

btw, updating your profile accordingly does simplify support.