SketchUp 2017 Hangs at First Attempt to Draw or Load File

2017
crash
sketchup

#1

I just installed SketchUp 2017. It is a clean install, no extensions and no modifications.

It appears to work ok. Menus work, and I can pan, zoom, etc.

It hangs however at the first attempt to draw. On drawing a Rectangle, for example, it drags the box, and when you would go to the Push-Pull tool, it is hung and won’t respond further. It does the same on opening a file, that is, hangs with nothing showing. It is not usable.

SketchUp 2016 continues to work fine.

It is using 13% CPU and continues until I kill the SketchUp process, over half an hour if allowed.

My graphics card is the latest available. I have tried rebooting and uninstalling/reinstalling.
This is on Windows 7 64-bit with an Alienware M17X. ATI Mobility Radeon HD 4870, 1024 MB.

I ran the SketchUp 2017 Checkup application, and it reported all successes.


#2

Have a search for an app named ‘plays tv’ it was added with some Radeon driver updates and caused problems for some people.


#3

Thanks, Box. I did find several articles about Play TV, and the issues resemble mine. However, I cannot find it on my computer and don’t see anything in Task Manager that indicates it is running. The problems in the articles seemed to be with Windows 10 and also affected SketchUp 2016. I am on Windows 7, and my SketchUp 2016 works ok.