Sketchup hanging every few seconds

Hi all

I’ve just advised my girlfriend on a new laptop which she’s bought specifically to give her more grunt doing garden designs in Sketchup.

However, unfortunately, a soon as we fired up Sketchup on the new machine and tried it with her model it periodically hangs. It’s not crashing but becomes unresponsive, even when it is not doing anything and focus is on other applications. It happens with a very regular pattern every 5-10s and lasts a similar amount of time - see attached screenshot.

For reference the laptop is an Asus K501U with i7-6700U, 12GB RAM, NVidia 940MX 2GB, and a 512GB SSD. I did a bit of research - here and elsewhere - before we bought it and this looked more than ample for Sketchup’s needs. Her model is admittedly quite large (29MB) but it works (albeit slowly) on her 4 yr old laptop and my Macbook Pro without exhibiting the same issue.

Troubleshooting steps so far…

  • Uninstalled a load of crapware that came on the laptop
  • Uninstalled / reinstalled Sketchup
  • Updated graphics drivers
  • Tried running with the Nvidia GPU and with Integrated Intel GPU
  • Tried turning off hardware acceleration

… but still seeing the same problem

I would appreciate any advice on what else to try. If we can’t get it working i think we’ll have to send the laptop back which would be a shame as it was a good deal.


You want hardware acceleration. In the NVidia control panel under 3D settings you can specify that the computer uses the NVidia card for SU. By default, laptops use the integrated chip to save power.

Did you install SU as administrator?

Thanks for the response.

Yes, I’ve tried both the Nvidia and Integrated GPUs by changing the settings in the Nvidia Control Centre. I only turned off HW acceleration to see if it stopped the periodic hanging. It didn’t.

I’ve also just tried reinstalling but using the 32-bit version. I ran this as Administrator. Results same as before.

Running out of ideas.

Win10? For background info, this is where installing SU 32-bit has helped some people as the 64-bit graphics driver had some issues running 64-bit SU under Win10.

It not running SU as Administrator, it’s running the installer as Administrator first.

Any installed plugins/extension for SU?

SU only uses one core. You could play around with setting core affinity and priority through the task manager > Processes > r-click on SketchUp.exe > Set affinity and Priority are found there. Emphasize SU on one core and other background processes running on the other cores.

Yes it’s Win10 Home. And yeah, I did install the 32-bit version as Admin. We haven’t installed any plugins - just whatever comes with the vanilla install.

I have had a bit of a breakthrough though. I noticed that the problem only occurs when one particular layer was enabled. By experimenting with deleting some of the components in that layer I’ve been able to fix the issue. It seemed to come down to one plant called Salvia which came from the 3D Warehouse. Each one was 5.5MB and there were about 10 of them in the model. I removed them, purged and re-saved which reduced the overall file size down to 12MB.

So we seem to be ok now, although I’m not 100% happy as I don’t really get what the root cause was. Does it just come down to overall file size or could it have been an issue with that one component?

Anyway, I think we’ll stick with the new laptop. (Good job too as I screwed the old one up taking the SSD out to copy the files over!)

Thanks for the other tips BTW - i will definitely try them.

You found out the hard way that some of those geometry heavy warehouse models can bog things down. Odd it didn’t affect your other computers the same though.

The info in the modeling faster pages may be helpful. And regarding the heavy landscape components, pay attention the page on using groups and components. There’s a section on using proxy components that may be useful.

1 Like

Thanks… I appreciate your help. Will delve into the modeling faster area tomorrow.

It may also be helpful to download and install ThomThom’s CleanUp plug in. This addon seems to remove superfluous materials more effectively than the native purge command located under Model Info.