Verify hardware powerful enough to run SketchUp Pro 2015

advice
performance
hardware

#1

Good afternoon! I am in a supportive IT role in the office I work in and have been asked to help our designers look into a problem with their SketchUp Pro 2015 (and also Layout 2015) running very slow and sometimes “not responding” when working with 3D rendered files.

Hardware spec’s are as follows:

  • Intel® Core™ i5-3470 CPU @ 3.20GHz 3.2 GHz
  • 32 GB RAM
  • Windows 7 64-bit with Service Pack 1
  • NVIDIA GeForce GT 640 graphics card
  • (2) 23" displays

Based on this bit of information, are there any suggestions as to any additional upgrades that should be made to avoid future slow-down?

Thank you!!


Hardware Purchasing Advice For SketchUp & LayOut [wiki]
#2

I don’t usually run SketchUp in windows, so I can’t help too much, but if you posted the file size of the models they are working with I think that might help the windows users give a better response. Polygon count and modeling efficiency would be my first concern, but if they asked you to solve it, I know they don’t want you to tell them it’s their fault. But let’s be honest, from one IT guy to another, it’s always the user…


#3

One of the latest files that had issues was less than 500kb. Thanks for the quick response! I’ll keep plugging away and check back here tomorrow morning.


#4

In my opinion, your hardware specs are fine. I’ve seen less spec machines handle normal SketchUp model just fine.

I think the RAM is a bit overkill, the bottle neck would be the graphics card for running SketchUp.
Therefore, I would start from the graphics card if you must upgrade.

One thing to note, because of large size file save and stuff, SSD would be helpful. Since you haven’t listed it.
Not responding sometimes would be caused by auto-save feature (at interval) and would benefit from SSD in that case.


#5

[quote=“josephkim626, post:4, topic:16050”]
Not responding sometimes would be caused by auto-save feature (at interval) and would benefit from SSD in that case.
[/quote]Totally forgot about that, that sometimes caused trouble for my son that still had a magnetic drive, so I switched his laptop over to SSD, and he said it’s loading way faster now.

[quote=“GELH132, post:1, topic:16050”]
Hardware spec’s are as follows:
[/quote]Is that the existing hardware or what you were going to switch to? Because I agree with @josephkim626 , I still have a machine running SU Pro 2015 on a Core2Duo with 2gb of ram, and it runs just fine. I would hate for you to load up the hardware to find it was an issue with the antivirus scanning the auto-saves every time or some such nonsense that won’t be fixed with a hardware upgrade.


#6

The indicated system specification seems adequate to run SU, based on what is identified (assuming the video adapter driver(s) are current). This suggests that the issue may originate in the way the files are being managed. A few questions come to mind that, if answered, may approach a solution:

  1. When your users encounter the slowdown, are they working on models with many active scenes and style settings? If yes, then maybe unaffected scenes and styles not involved in the rendered scene should be deleted if possible to reduce file size and possibly minimize lag time.
  2. Have all unused components, styles, scenes, layers, and materials been fully purged?
  3. Are many skp files open at the same time?
  4. Is the model being rendered being developed with an eye toward physical efficiency (that is, economy in size, number of faces, number of arc segments or circle segments, judicious use of components for repetitive elements, etc.)?

There could be other factors to consider, but this is what comes to mind immediately.


#7

@GELH132

File size is a poor measure of model performance.
Modeling technique has a tremendous impact upon performance.
See … How Do I Make SketchUp Run Faster? — SketchUp Sage Site

Sharing a model file which exhibits the problem will help us help you.


#8

Thanks to all of you who have responded to quickly already with ideas! I have forwarded your ideas to our designers so they can dig a little deeper into their modeling efficiency and check out their auto-save settings. I don’t believe they have their software running off their SSD (only their OS is on a small SSD), so that’s a great suggestion also to utilize that! I’ll hopefully be back on within a day or two with an update. Have a great day guys!


#9

Ok, it turns out we no longer have a problem modeling in SketchUp, but once they’re finished, the slow-down happens when dropping them into a Layout 2015 scrapbook!! Looks like I may need to start a new thread or join another community to get that problem figured out? Otherwise, we’ll take your suggestions on the SSD, etc… and run with them also.


#10

Never have the Outliner inspector window open unless directly using it. (It is a major performance brake.)

Start another thread in the SketchUp > Technical Problems category (where this thread already is,) but name it something with “LayOut” in the topic title. (LayOut is the sister Trimble application to SketchUp Pro.)

[Note: This Discourse system uses a database which categorizes topics, rather than a tree structured hierarchy of separate forums.]

You can add a link from here,… or use the “(+) Reply as linked Topicpopup link to the right of any post. (It fades into view when you move your mouse over a post, and creates a link back to that specific post in the thread.)
If you wish to link back to the topic in general, then scroll back up to your original post, hover over it, and then “(+) Reply as linked Topic” to it.


#11

Yes those specs look out of reach to me. Who runs 32 MB of RAM? You can but it’s expensive and can only be
achieved through an upgrade to my knowledge. My desktop has slots for different RAM configurations but most laptops have limited configurations so check that carefully if you’re buying new and want to add more RAM later.
And the 3.xx processing speed is the first I’ve heard of anything faster than 2.x . Or am I living in the past?

One place to read about the latest laptop hardware developments is a small company out of Ottawa, Ontario Canada called Eurocom.com Go to their site, they put things into their machines I’ve never heard of. Dual video cards for example. A regular one for everything else, and something exotic for 3d and gaming. They also make computers specifically for 3d design, not just re-purposed gaming machines. They also sell computers without OS’s, nothing.
And I just thought, (at the risk of sounding like a sales person, I’m not, I just want to buy one) they have a ‘re-furbished’ page where you can buy last decades Ferrari/laptop for a song. Then you change from Can $$ to US $$ (there is a currency exchange button on the site) and get another 20% discount.


#12

I think he IS USING that machine, and looking to upgrade if the hardware isn’t up to date.
32 GB, not MB. Its not that pricy in desktops. I assumed it is desktops he is talking about since 3.xx GHz CPU and 32 GB would be very difficult to get in a laptop.

3.xx GHz CPUs are quite common nowadays, even my 3 years old 2nd Gen Intel i7 has more than 3.2 GHz. So yeah, you might be living in the past on that point :smiley:


#13

Yes, that is our current config. and the RAM is 32GB :slight_smile:


#14

Generally, any decent graphics card is enough to run SketchUp, and upgrading to an ultracool whizbang new supergamester card will not deliver bang for the buck, but I wonder if you are using a relatively low-range graphics card to feed quite a lot of screen real estate. I have a GT620M in my ultrabook, and it is generally quite enough to run my small models, but I haven’t tested what connecting another fullHD monitor to it would mean.

Upgrading the driver, if possible, is always to be recommended. Also, check in SketchUp (Window menu>Preferences>OpenGL) that Hardware Acceleration is checked (if it is greyed out, I would guess that the driver is missing or is somehow of the wrong type). In the Nvidia control panel 3D settings you could check that settings like Antialiasing and Anisotopic filtering are set to “application controlled” or equivalent, and, that if the computer also has an IntelHD graphics chip, SketchUp is set to use the Nvidia card instead of automatic selection.

Anssi


#15

Those are great suggestions! I’m especially intrigued by your tip to make sure SketchUp is set to use the graphics card rather than the intel chip. Do you have tips on how to set SketchUp to use only the graphics card? Thank you!


#16

This is the Nvidia control panel from my ultrabook:


Windows sets the graphics processor to “auto-select” or equivalent by default, but that tends to make it prefer the Intel chip to conserve power. All computers don’t have an IntelHD chip but I understand that it is built into the CPU in many cases. My desktop hasn’t one.

(BTW, it still reads Google SketchUp there - I don’t know why)

Anssi


#17

For future tougher issues: https://forums.geforce.com/