SU Slow to load models on a powerful Windows system?

slow
quadro
firepro

#1

This is something we’ve been evaluating pretty heavily lately and may have narrowed down the culprit AND have a workaround until we get it fixed.

We seemed to see an unusual number of slowness issues on machines with very powerful specs; specifically on computers with pro-level video cards (Quadro, FirePro). The issue can be described as “It takes a long time for my models to load… longer than it did on my old machine”.

If this issue sounds familiar, please try this.
If your Materials tray is open, try keeping it minimized except for when you need it. Also, when you close SketchUp Pro, make sure that the Materials tray is not expanded. It can be in your tray, but not open where you can see the folders in it. It also seems to affect the speed of SketchUp’s functionality over time.

If you conduct this experiment and see a difference, or see NO difference in load times, please let me know and I will collect some additional info from you. We look forward to getting this issue fixed for good soon.


Sketchup Pro 2018 takes forever to open files
Navigating to Model Info causes Sketchup crash
Sketchup 2018 running very slow on new PC
New PC weirdly slow
#2

It takes about a minute to load any model, regardless of the size. Nothing changes if I close all the trays. Sketchup had been working find. I get “non responsive” for about 30 seconds when the autosave executes when I have model open.

I’ve tried reloading and using as administrator no change. Raydeon RX 580 series Graphic Card


#3

My guess is that your issue is somewhat different then the Original Post (OP)
The way you describe the execution ‘Autosave’ is more likely due to the location of the file. Is it a (remote) server or some kind of cloud-storage?
(Icloud-onedrive-dropbox-google drive etc)
If so, the way SketchUp works best is to upload the file to your local (physical) drive, work it, save and at the end of the day, synchronize with the desired location.
Larger files often get corrupted, due to server time outs, safety check ups etc. I do have my resources (components, material,styles etc) on my Google Drive, and have those filepath set in the Preferences, but these are all s maller files, off course…

If you have extensions installed, some of them might cause the initial startup time-delay, though one minute is not necesarely slow (depending on your hardware, offcourse)


#4

Mike, I amy be saying this wrong. When I open the file “C:\Users\Owner\Pictures\FINLEY SHADY OAK FARM\Farm\welcome patio\SKETCH UP” it takes sometimes a minute or two to open. Then while I am working on the model it automatically saves the file every so often which I assume it’s an auto save feature. This may be happening because the program is freezing.


#5

A file that takes a minute or two to open will also take a long time to save, and SketchUp will indeed freeze while it is doing a save. You can control the autosave behavior in preferences.


#6

maybe it is taking a long time to read that file path :slight_smile:


#7

Have you tried un-checking ‘redefine thumbnail on save’ in Window-model info-file?
That feature used to slow down saves terribly. Disabled it many versions ago and never tried again.


#8

I’m having a similar issue - loading times over 30 minutes for even a blank template. Is this the same issue or something totally different?

Windows 10, i7 8750 cpu and gtx1070 max-q.

During this I notice SketchUp_Application and SketchUp_webhelper are loaded as background process and Sketchup Application is using memory (~100mb) and network (~10Mbps).(which is 100% of my bandwidth)
No sketchup icon is visible in the windows start bar and SketchUp isn’t listed under Apps (in task manager).

I’m opening a blank template file I’ve used many times before without problems. The sme occurs if trying to load a model.
It happens to me, intermittently, and to other people in my team. We haven’t added new extensions in a while (though can’t see how they could cause bad load times - surely the extensions are vetted for such issues?)

I will try the materials panel workaround and report back.

Thanks


#9

Your network bandwidth looks way off - 10mbps is ~1MB/s?!
So 100 seconds to load a 100MB file?


#10

Good thought - I’ll take a closer look at it. I’m plugged in via a USBC cable and the office is on fibre , and it’s typically fast. Maybe its being throttled today.


#11

Just wanted to chime in that I have experienced this ever since upgrading my laptop in 2017. It’s definitely an issue and a resolution would be really helpful.

Intel Xeon E3-1535M v6 Processor (8MB Cache, up to 4.20GHz)
Windows 10 Pro 64
64GB(16x4) DDR4 2400MHz ECC SoDIMM
NVIDIA Quadro P5000 16GB
RAID 1TB SSD PCIe TLC


#12

Have you checked to see if your system would perform better with Win 10 Pro Workstation?

windows-10-pro-workstation


#13

No, but I will now. Thank you!


#14

Any followup here on your conclusions would be much appreciated.


#15

I checked into it and while this laptop definitely is a workstation, I don’t think I need most of the features of Win 10 Pro Workstation, that seems like more of a desktop/server solution. I really just wanted to chime in that I’m looking forward to a more permanent solution to this issue from Trimble. I’m lucky in that I only use Sketchup for a small portion of my work, but I do have to wait a good 10+ minutes for some models to load, which is a bit excessive. A cheap laptop with integrated graphics used to do better than that.


#16

Unfortunately, with most laptops, the Intel GPU is forced to run all monitors external and internal (although you can set the NVIDIA GPU to run the software) - combined with common Windows Intel® HD Graphics P630 driver issues (your intel GPU) may be at least a part of the problem.

You can check on GPU designations in the NVIDIA control panel PhysX config.

Other small issues - ECC memory, CPU and laptop chipset not blazingly fast - unfortunately, cheaper gaming systems tend to have a performance advantage.

Your raid setup and P5000 should be blazingly fast, but held back by the other components.


#17

Thank you for the time and follow up.

I noticed the issue with integrated graphics and disabled integrated graphics in bios. Terrible battery life, but I know that I’m always using the Quadro graphics card. I beg to differ in the ECC memory and CPUs not being fast, the fastest chip on the market in 2017 is not exactly slow two years later. Also ECC memory only has a 2% impact on performance, but I run simulations in SOLIDWORKS that can take hours, and would rather stick with ECC. It also helps reduce errors while running imagine recognition training, worth the very small performance hit for the assurance it’s just going to work the first time.

I appreciate the help, but all things being equal, I went from a $500 laptop with an i5 only integrated graphics, standard plate drive & 12GB of slower RAM to a $6.5k workstation with a Quadro P5000, SSD, & 64GB of faster RAM (even with the 2% performance hit). This is a known issue, apparently, and I’d love to know more of when it’ll be corrected. This isn’t an issue with my laptop, I run SOLIDWORKS, Revit, Enscape (with Sketchup) and a number of VR applications on a routine basis without issue. All of those experiences improved substantially with the laptop upgrade, except the VR, which I couldn’t even run previously. Only file opening and importing in Sketchup experienced a drop in performance. So I know it’s not the laptop.

“The performance is a bit higher compared to the fastest Kaby Lake consumer CPU, the Intel Core i7-7920HQ, thanks to slightly higher Turbo clocks (100 - 200 MHz), so it is the fastest mobile consumer processor in the beginning of 2017.”


#18

Considering the range of apps you run, your setup is close to the best you could get at the time (unless you go for a desktop replacement laptop workstation which uses desktop CPU’s and chipset)…

Interesting to hear you disabled the Intel GPU in the bios - has that made a difference?


#19

Yes, disabling the Intel GPU made a huge difference in overall performance. I couldn’t get everything to run through my Quadro card on an external monitor until I made that change. I tried everything I could think of before going that route, but at the end of the day, 1.25 hours of battery life is typically plenty for me, I usually can plug in. I was having issues in SOLIDWORKS and with VR applications before I made this change. It had little impact on Sketchup, which is seemingly is more CPU bound. Sketchup always ran fine on my old laptop, but the live VR walk through with Enscape and other professional pursuits warranted the workstation specs over a more enjoyable thin and light or gaming laptop. I would much rather have a high end thin and light or gaming laptop, it’s cheaper and would work just as well with Sketchup. It just doesn’t work nearly as well with professional applications like SOLIDWORKS.


#20

SketchUp team,
I just tested this with back to back model openings. Same exact model:

Edges: 3,667,562
Faces: 2,327,880
Component Instances: 479
Guides: 0
Guide Points: 0
Groups: 1,629
Images: 0
3d Polylines: 0
Section Planes: 0
Dimensions: 84
Text: 0
Classification Types: 0
Classification Entities: 0
Component Definitions: 114
Layers: 10
Materials: 133
Styles: 1

  • 33 seconds to open with Materials Tray closed

  • 12 minutes 31 seconds with Materials Tray opened

Knowing this will save me a ton of time. I look forward to this being patched though, as you can see, I use materials quite often while modeling.

Thank you -
Aaron Marr