Sketchup loading very slowly

Hi there,

New on this platform, looking for some help regarding Sketchup Use.

Since a week the loading goes very slowly, and before i already received some errors and it closed the program. I’m not sure if my graphic settings are correctly installed, or what is going on that it is working this slowly. Since it was working quite ok before! Loading times take up too a few minutes, which is driving me crazy…

It does not matter if i’m working with small or big files, they all take very long loading while working in the file. It’s getting worse every day…

Is there anyone who has time to help me out? Hope so! Please let me know.
Thanks in advance :).

Melissa

Does starting a new file also work slowly? Are you saving to “the cloud” or a cloud-synced folder, or over your local network?

I don’t think this is graphics card related, but it is always recommended to keep up to date: Go to the Nvidia website and download and install the newest driver for your card. In the Nvidia control panel 3D application settings check that SketchUp is set to use your Nvidia graphics.

1 Like

Thanks for your reply Anssi!

I’m saving to the cloud, would it be better to save to my local network?
The Nvidia driver is up to date, checked it yesterday.

About the Nvidia control panel, not sure which settings are right. Can I find this somewhere? Uploaded a screenshot here below (but it’s in Dutch)

Yes. Save your files locally. If you want to back them up in the cloud sync to the cloud.

There are plenty of examples in which users were working on files directly saved in the cloud and wound up with corrupted files.

2 Likes

Ok thanks @DaveR, will replace my files locally right now.

Good luck. They should open more quickly, too.

1 Like

Thanks Dave, replaced the files but still having trouble with loading while i’m working in the file. Every few minutes I see the blue circle turning for a minute or longer. Any other ideas?

thanks again

Do you mean you’ve saved the files to an internal drive?

How large are the files? Can you share one so we can see what you’re working with?

I replaced the files from the cloud to the local drive.
The file is 379.541 kb. Hereby a link to the file; WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

And some info about my system;
Processor 11th Gen Intel(R) Core™ i7-11370H @ 3.30GHz 3.30 GHz
RAM-geheugen 32,0 GB (31,8 GB beschikbaar)
Type systeem 64-bits besturingssysteem, x64-processor
Windows 11 home
Intel® Core™ i7: NVIDIA® GeForce RTX™ 3050 Ti GPU voor laptops met 4GB GDDR6 GPU-geheugen

That’s a pretty large file. It’s opening slowly on my computer, too. Hang on and let’s see if I can do anything to make it easier to work with.

1 Like

Fixed incorrec tag usage (all edges and faces should be created and left Untagged.
Screenshot - 1_25_2023 , 8_08_48 AM

Purged unused stuff from the file. Looks like a hoarder’s nest. :wink:
Screenshot - 1_25_2023 , 8_10_26 AM

There are a lot of excessively sized materials in the file. Most of these probably came in with components from the 3D Warehouse. I wonder who thought a plain black color needs an image that is 5200 pixels wide.

I reduced the size of those that are more than 1024 pixels wide. Really a number of the materials in the file could be reduced even further without any negative effect. As it is the file size is reduced by 82%. It could stand to be reduced more but as it is, autosave times should be shorter.

I turned off Profiles in the style which helps reduce the load on your GPU and makes orbiting faster. I’ve also set the face style to Monochrome so the textures don’t need to be processed.

See if this behaves a bit better for you.

I would suggest that you go through and do further cleaning and then make it a practice to keep your models clean and streamlined. The little bit of effort that takes on the front end will pay big dividends later.

2 Likes

Wooha, that’s quite a difference. Thanks so much!
Not really known with how to keep my models clean :sweat_smile:

A few questions do to it myself next time;

  • How did you find the incorrec tag usage?
  • What is the maximum for materials you would use? I need to check this better in the 3D warehouse.
  • Where can I find the material resizer?

It take some practice. Pay attention to the content youdownload from the Warehouse. Best practice is to download it into a separate file to check it out, make sure it’s what you want, and clean it up before you add it into your project. Remember that deleting components from the model space doesn’t remove them (or the materials they carry) from the file. You have to purge the file of them. Purging can be done via Window>Model Info>Statistics. I used a plugin from Sketchucation called Purge All that does the same thing but it provides the little report afterwards.

You can figure out if tags have been given to edges and/or faces by selecting them and looking at the Tag field in Entity Info. I used a plugin by the Venerable TIG called Default Layer Geometry that automatically goes through the entire model and untags the geometry. You can get that plugin from Sketchucation.

It depends on the material and the object is used on. The other day I was looking at a file by another interior designer. They had a stack of magazines on the bottom shelf of a coffee table. Each magazine had a different texture for the front, spine, and back cover (three texture images on each magazine component. Each of those images was over 10,000 pixels wide. There’s no benefit whatsoever to that. In fact most of those magazines shouldn’t even have a texture applied to them. Only the front of the top magazine was visible and it was such a small part of the entire project it probably would have been just fine to use a flat color.

In your model there are a bunch of plain colors that shouldn’t be texture images at all. They should be replaced with colors that won’t really add much to the file size or the load on the GPU.

That is available in the Extension Warehouse.

2 Likes

Thanks again @DaveR, this is very helpfull.
Will work on “cleaning” my files from now on.

Glad you could help met out! :slight_smile:

1 Like