New PC weirdly slow

sketchup-pro

#1

Hi,

I recently got a new custom PC.

AMD Threadripper 2950x 16-core
64GB DDR4 RAM
RTX 2080ti w/ 11GB GDDR6 RAM
1TB m.2 OS drive
Windows 10 64-bit

Two issues:

  1. Sketchup is very slow to open larger files and purging has taken up to 10 minutes, granted it’s an amateurish messy file I got from someone else, but still…
  2. Layout is incredibly clunky, and when I resize a model window it often goes into a spasm for several seconds trying to render the view.

It seems like it’s only the processor having an issue, because I’ve been using Enscape for renderings and it’s running butter smooth. The only thing I’ve found so far that I seems like a possible culprit is “Run as administrator” that I’m pretty sure I didn’t not do when installing.

Should I uninstall and run the installer again as an administrator? It’s my personal PC so I thought I already was an admin on it…?

Thank you for your responses and time.

PS: I’m coming from a mid-2014 MacBook Pro that is running the same files much faster!

Cheers,
C


#2

Uninstall is not necessary. Rerun the installer “as administrator” and choose Repair.

It is not the same thing as an Admin account. There is plenty on this on the Microsoft sight and elsewhere on the web.


#3

thank you, oh Learned One!


#4

Thanks for the tip, but it changed nothing. I just tried opening the same files at the same time on my mid-2014 MacBook Pro and the new PC simultaneously… the Mac opened the file in 10 sec and the PC took 4 min 45 sec. This can’t be right…!?!

MacBook Pro stats:

  • Intel i7 2.8 GHz
  • 16 GB RAM
  • NVIDIA GeForce GT750M 2048 MB

File stats:

  • Edges: 1,805,332
  • Faces: 336,898
  • Component Instances: 13,917
  • Guides: 10
  • Guide Points: 1
  • Groups: 2,391
  • Images: 0
  • 3d Polylines: 0
  • Section Planes: 0
  • Dimensions: 0
  • Text: 0
  • Classification Types: 0
  • Classified Entities: 0
  • Component Definitions: 739
  • Layers: 167
  • Materials: 1,110
  • Styles: 7

#5

What happens with other files?

Not likely the main issue, but M.2 drives overheat and cause issues.

Can you test with a different SSD?

The 2080 GPU has had general issues too.

Check task manager during SU load and operation for gpu status, etc.

Drivers up to date?


#6

If I remember correctly… In another topic, I read the Windows 10 update wasn’t compatible with SketchUp. And I’ve seen a couple other people having similar problems on Windows 10 & SketchUp. I don’t know if that’s the issue. If it still works on the MacBook, then that might be a faster option.


#7

Thanks for everyone’s replies. I restarted and it got better - 23 seconds instead of almost 5 minutes. But it still seems a little slower than my Mac. :sweat_smile:

I’m not sure what happened to make it slow down so much, but I’ll see how things go from here out.

Thanks!


#8

Also make sure the materials panel is closed in your tray.