SU 2018 extremely slow on new fast machine


#1

I just built a new machine with a RYZEN 7 processor. The machine boots in 15 seconds, and all my software (AutoCad, Rhino 6, etc.) is blistering fast, All EXCEPT Sketchup. I don’t know what the problem is, but Sketchup takes almost a minute to load, as does almost any SU file. Once loaded, it functions normally.

I’ve removed Sketchup and reinstalled with the same result, even before adding plugins. Are there any known issues with RYZEN? SU 2018 worked better on my previous 7-year-old 1st gen intel i7 machine.

Windows 10 Pro 64
ASUS ROG STRIX I-B350
Corsair Vengance LPX 16GB Kit (2x8GB Modules) 3200MHz DDR4 DIMM
AMD RYZEN 7 1700X
ATI FirePro V5900
Samsung m.2 SSD 500gb Drive


#2

It could be the GPU, it’s quite an old card (2011) unless you have an updated version?

SketchUp only uses a single core on the CPU also, not sure how many cores and also the clock speed of your Ryzen.

On paper you should have enough to run SU18, how large are the models you are working with?


#3

I was wondering about the GPU, but my other programs work fine. I do have the latest driver. (2017)
The size of the model doesn’t matter. Just opening the program and any file after drags.


#4

What other programs do you have that use OpenGL 3.0 or later?


#5

Without SU running in the background, try right clicking on SU icon and select Run with Graphics Processor and see what Video Cart is shown as the default?


#7

“try right clicking on SU icon and select Run with Graphics Processor and see what Video Cart is shown as the default?”

My only run option on right clicking the icon is “Run as administrator.”


#8

When you installed SketchUp, did you right click on the installer file and choose Run as administrator?


#9

I followed these instructions from TIG on Sketchucation.

“Ensure SketchUp is closed.
Find its installer exe file - probably in your Downloads folder ?
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair”.
If SketchUp is NOT yet installed the correct prompt to accept is “Install”.”


#10

Newer versions of SketchUp (16+) have to read each extension’s hash file and decide whether each one of each extension’s code files are in distributed condition. (It’s the signature security feature.) So this slows down loading more than pre-2016 editions.

But, I see you notice this before adding any 3rd party extensions. There are 4 or 5 that come with SketchUp and you could switch off those you do not use.

Another thing is that since about the same time ~SU2016 the licenses became cloud-based. So it might be that something (firewall, AV, etc.) is interfering with the 2 ports that the license check uses.

From the Help Center …

For you techie types, when you authorize SketchUp Pro, SketchUp communicates with the authorization server via the standard ports 80 and 443.

… and …

For your SketchUp Pro network license to work, ports 5053 and 50530 must be open.


Was that machine running Win 7 or 8 ?

SketchUp 2018 has a fix for some performance lag especially concerning the mouse …


#11

Occasionally Sketchup 2018 Pro runs extremely slowly, leaving me with a spinning wheel for several minutes. Time range can be 3 - 15 minutes of wheel spinning. I often see a fix suggestion of running the installer as administrator. However, once it’s installed do I have to run the Sketchup program as an administrator? Our IT dept. installed it as an administrator under their login. I use it under my non-administrator login. I’m on a network with my files stored on the college network, not in my machine. I’ve started importing files to my desktop, working on them while they are there and then returning them to my folder on the network. It may have made a little difference but I still have terrible lag at times.


#12

No. Don’t run the program itself as administrator. Just log in with your normal user log in and open the SketchUp.

It should have been installed under your user ID, not the system administrator’s.

This is a good practice. Keep doing this.


#13

And adding to what @DaveR said, when they install it they should log on as an ordinary user (you), right-click the installer and choose “Run as Administrator”. This process is not equivalent to being logged on as Administrator while doing the installation.


#14

Thanks Dave.

Regarding your comment

“It should have been installed under your user ID, not the system administrator’s.”

I can’t run the installer as an administrator, I get a prompt asking for my admin credentials, which I don’t have.


#15

Thanks.
I’ll be sending a copy of this conversation to our IT dept.


#16

Ask your IT department to grant you temporary credentials. Before I retired in January, I worked for the largest healthcare provider in the upper Midwest. They have computers locked down pretty tightly for obvious reasons. I could get temporary elevation of privileges when I needed to install test software and even SketchUp on my computer. Maybe your firm has a similar option.