Sketchup 2018 works in background

bug

#1

When launch Sketchup 2018, it works background for a few minutes, then it starts to work normally. What can be the problem. LayOut 2018 and Style Builder 2018 works normally.


#2

Can you explain in more detail what you mean by SketchUp working in the background? Do you mean that SketchUp does not respond to user inputs (mouse clicks, menu choices, etc.) for a few minutes? Windows 10 systems apparently suffer from problems that cause varying degrees of lag with recent version(s) of SketchUp. Search the forum for “selection lag” or “delay” and you will probably find discussions of such issues.


#3

Well;
1- I double-click on the Sketchup 2018 icon on the desktop


2-Looks like the program is not working. But in the Task Manager it seems to work in the background precesess.

3- After a few minutes it starts to work normally.


#4

Thanks for the added information. I have no idea how Windows automatically characterizes a process as an app or as a background process. In any case, during those few minutes that Windows shows SketchUp as a background process can you use SketchUp normally? Does it respond to mouse clicks, menu selections, etc. during that time? If it does, then I’m not sure what is the real problem you are experiencing.


#5

it’s in the background while it checks for your licence and or updates…

when that’s finished it opens SU’s windows in the foreground…

are you offline or a have slow connection…

john


#6

No, because the screen of the SU 2018 is not displayed on the screen.

I am online and fast connection.


#7

In an experiment I have just done, SU 2016 and SU 2017 behave the same. But this situation is very short and it is not felt.


#8

What system are you running, could the hardware be the issue?


#9


#10

I suggest searching for other reports of lag and delay in SketchUp on Windows 10 systems. Some Microsoft updates apparently cause issues, and I have read of a tweak to SketchUp’s configuration (posted by a SketchUp team member) that helped some users.

Lastly, was SketchUp Pro 2018 installed by right-clicking on the installer EXE and choosing Run as Administrator? (This is not the same as running the installer while logged into an account with Administrator privileges.) All manners of strange behaviors have been reported by users who did not properly install SketchUp by using Run as Administrator. It is also possible to Run as Administrator on the installer EXE and then choosing the Repair option, if unsure how the initial installation was performed.


#11

Here is the “Sketchup 2018 Chekup”


#12

I have read reports that the Checkup feature behaves poorly - reporting false problems - on recent systems. I would necessarily be worried about that.


#13

Yes, I choose Run as Administrator


#14

I don’t think you installed SketchUp correctly. It’s shortcut should not show the shield icon. It should look like this.
Screenshot%20-%202_22_2018%20%2C%2012_02_24%20PM


#15

Hımm. OK, I will now remove it and install it again.


#16

Make sure you are logged into Windows with your normal login and when you get set to install, right click on the installer exe file and choose Run as administrator.

If you are going to uninstall SketchUp, clean the registry too. I would get rid of any extensions you might have installed so you can test SketchUp’s startup time with no additional extensions waiting to load.


#17

I uninstalled Sketchup 2018 and cleared the registry. Then I installed choose Run as administrator. The icon changed but the process did not change. This is how the process works.


#18

Well, at least SketchUp is installed correctly now.

Do you have any extensions installed?


#19

No. I have not even used Sketchup 2018 yet.


#20

Interesting. I just tried it and don’t see Sketchup in Background Processes at all.