Sketchup Pro 2018 takes forever to open files

sketchup

#7
  • close the SketchUp Materials and Outliner tab before opening the file
  • open "Window > Model Info > Statisitics” (with “Entire model” selected) and do a “Purge Unsued” after opening the file

#8

Hi everyone,

@Box local files aren’t exactly fast, but no way near the 5-15 minutes range of network files. They open in about 20 seconds on the affected workstations.

@gkosicki, we use SU Podium, so can’t disable Vray unfortunately.

Thanks for all suggestions so far. Keep 'm coming guys :slight_smile:


#9

Do you have the OS, apps and working files running on SSD’s?


#10

Hi @GSTUDIOS, yes we have them all running on SSD’s


#11

Sometimes there is a corrupt register, you could try to copy the workspace or whole sketchup register and install on the others.

@ty_s suggestions?


#12

Hi Rick2! We may have a work around to help until we build a permanent fix.
See this post for more info: SU Slow to load models on a powerful Windows system?

-Guz


#13

Hi @TheGuz

Thanks for chiming in here! I have been out of office for the christmas hollidays now, but I have saved your suggestion for the new year. We’ll definitely look into that.

Have a good time everyone :slight_smile:


#14

#15

Hi all,

Just to let you know, this issue is resolved. It took us a while, but the definitive solution when this happens is to delete the following folders, and replace them with those from a standard Sketchup 2018 install:

  • C:\programdata\Sketchup\Sketchup 2018
  • C:\Users<UserName>\appdata\Local\Sketchup\Sketchup 2018
  • C:\Users<UserName>\appdata\Roaming\Sketchup\Sketchup 2018

After we did this we had 2 weeks of a perfectly working Sketchup. Then the issue came back for one user. Then I did the above again and pooof, issue gone again. So I know now that this is the definitve solution.

Probably you need to delete and replace only one of these folders, but I didn’t test which one was the actual culprit. I’ll do that next time the issue occurs again.

Thanks all for your help.


#16

You probably shouldn’t need to delete any of those folders in normal use. I wonder what you’re collecting in at least one of those folders that is causing a problem.


#17

@DaveR raises a good point. Such drastic action surely shouldn’t be necessary. Have you saved a copy before the deletion and shared it with the Trimble team so they can try to diagnose what is really going on? If for any reason you are reluctant to do that, could you compare the contents before and after they are deleted/regenerated to see what changes?


#18

By deleting those folders, you also delete the PrivatePreferences.json file which holds all the user preferences. SketchUp will replace it with a new one. One of the things that gets reset is the status of the tool windows and the window that has been shown to be responsible for most of the slowdowns we see is the Materials window. I would like to see if your users see a load speed increase when they keep the Materials window contracted when not in use and only expand the window when they need to access their Materials.


#19

Hi All,

@TheGuz if this happens when Sketchup is closed, e.g. when double-clicking to open a file from Windows Explorer, then can this material window still be the cause of this?

I could check again when it happens but I’m not sure it is the materials window in this case.

@slbaumgartner, I have not saved a copy of those files before deletion. Will do next time it happens. Trimble support won’t be much of help. Last time I contacted them they redirected us to the reseller who sold us the license. If this happens again I’ll zip up the folders and attach them to this thread. Then maybe someone from Trible can have a look at it :slight_smile:


#20

Hey Rick2! To clarify, “yes”. If your Preferences have been saved with the Materials window expanded it will impact the next time you attempt to load a model… at least in our test cases.


#21

@TheGuz,

Sorry for not properly testing this earlier. It is amazing, you are absolutely right about the materials pallette. The issue has just returned. I closed the materials palette and the files open and save very fast again!

Seems like this was the cause of the issue after all…


#22

solved with reply #6.


#23

Done @SketchUp3D_de


#24

Great to hear! Thank you for getting back to us with the solution that worked for you. I hope it helps others!


#25

@TheGuz while the open and save issues are now resolved, one user still has performance issues unfortunately. Whenever they click, drag or do something in Sketchup they have a 5-10 period of a freezing Sketchup with “Not Responding” added to the title screen. If they click again when this happens then it freezes completely and they have to close the program.

I’ve tried the new Sketchup 2019 and install an updated graphics card driver, but no breaktrough yet. I’ve also checked for the Materials panel especially, but it doesn’t matter in this case if this panel is closed.

I hope that you have a magic solution for this issue as well? :slight_smile:


#26

System:

  • CPU?
  • Grapics Card?
  • recent Driver Version of Graphics Card installed?
    (“Win+R > dxdiag > Display”)

Document:

  • every document or specific documents only?
  • if specific documents: what does “Window > Model Info > Statistics" with options “Entire Model” and “Show nested Components” say?

Performance:

  • ensure that the model is near the model room origin especially after importing a DXF/DWG (or use the concerning import option to avoid)
  • purge affected documents by “Window > Model Info > Statistics > Entire Model > Purge Unused”:

  • if purging doesn’t help either, you could also unhide everything, switch on all layers, select all and copy/paste to a new document

The “Not Responding” message is shown by Windows if the concerning application is not respoding because occupied by number crunching, i.e. normal behaviour.