Sketchup Pro 2018 takes forever to open files

sketchup

#1

We have 3 almost identical HP Z240 workstations running Windows 7 Pro and Sketchup Pro 2018.

Specs:

HP Z240 Tower Workstation
Intel® Xeon® CPU E3-1245 v5 @ 3.50GHz
NVIDIA Quadro M2000

  • One workstation opens files very fast, without issues
  • Two workstations have MASSIVE issues with opening files from the company network share. It can take anywhere from 5 minutes to 15 minutes or longer (never?) to open files. The files are typically around 130-180 mb in size, but from my testing experience the size doesn’t really matter. It takes so long to open files, during which Sketchup freezes completely, that we force-close the program via taskmanager.

There’s another, different, workstation whichi also opens the files from the same network share, without any issue.

What on earth could cause Sketchup to take that long to open files? Please throw anything at me that we can try to solve this issue. For the record, I shall list the things that I already tried to solve this:

  • Reinstalling Sketchup
  • Reinstalling Sketchup as Administrator
  • Changing local switches and network cables for the affected workstations.
  • Upgrading Graphics card drivers
  • Upgrading Network card drivers
  • Opening files on the same workstations, under different user accounts
  • Fix problems and purging unused in the Sketchup files
  • Check all network related settings on the server and computers and make sure they are correct

Who has the golden tip that will solve this issue? I will be forever thankful to you.


#2

First troubleshooting question would be,
are local files equally slow to open? If so it’s the PC, if not it’s the network.


#3

Are you running the same bios and settings on all the HP Z240 Tower Workstations?

Windows 7 is getting old (possible issue there) - is a Win 10 upgrade on the horizon?


#4

How about the group policy settings? Are they absolutely similar to all the workstations?
I have met similar, still unsolved problems that are not related to SketchUp. All the members of our team got their identical new Zbooks (Ok, it’s HP again…) at the same time last summer. Some of the laptops have started to take a long time to boot while most boot in seconds (Windows 10). And, I am not sure if they are the same machines that boot slowly but some get their network drive mappings wrong.


#5

Hi there,

Are you using VRAY? If so, try disabling (uninstalling) it.

Regards,
Greg


#6

Thanks guys. I’ll look into all suggestions

@GSTUDIOS, Yes, we have the same bios version, network card drivers and settings on all workstations.

One of the workstations with Windows 7 doesn’t have the issue, so I suspect that it cannot be the OS’s fault.

@Anssi, Group Policy settings should be the same for all computers. At leat the drive mappings are, this particular share is available to the whole company. Is there any specific GPO that I should look at?

Thanks for all suggestions so far. Keep 'm coming :slight_smile:


#7
  • close the SketchUp Materials and Outliner tab before opening the file
  • open "Window > Model Info > Statisitics” (with “Entire model” selected) and do a “Purge Unsued” after opening the file

#8

Hi everyone,

@Box local files aren’t exactly fast, but no way near the 5-15 minutes range of network files. They open in about 20 seconds on the affected workstations.

@gkosicki, we use SU Podium, so can’t disable Vray unfortunately.

Thanks for all suggestions so far. Keep 'm coming guys :slight_smile:


#9

Do you have the OS, apps and working files running on SSD’s?


#10

Hi @GSTUDIOS, yes we have them all running on SSD’s


#11

Sometimes there is a corrupt register, you could try to copy the workspace or whole sketchup register and install on the others.

@ty_s suggestions?


#12

Hi Rick2! We may have a work around to help until we build a permanent fix.
See this post for more info: SU Slow to load models on a powerful Windows system?

-Guz


#13

Hi @TheGuz

Thanks for chiming in here! I have been out of office for the christmas hollidays now, but I have saved your suggestion for the new year. We’ll definitely look into that.

Have a good time everyone :slight_smile:


#14

#15

Hi all,

Just to let you know, this issue is resolved. It took us a while, but the definitive solution when this happens is to delete the following folders, and replace them with those from a standard Sketchup 2018 install:

  • C:\programdata\Sketchup\Sketchup 2018
  • C:\Users<UserName>\appdata\Local\Sketchup\Sketchup 2018
  • C:\Users<UserName>\appdata\Roaming\Sketchup\Sketchup 2018

After we did this we had 2 weeks of a perfectly working Sketchup. Then the issue came back for one user. Then I did the above again and pooof, issue gone again. So I know now that this is the definitve solution.

Probably you need to delete and replace only one of these folders, but I didn’t test which one was the actual culprit. I’ll do that next time the issue occurs again.

Thanks all for your help.


#16

You probably shouldn’t need to delete any of those folders in normal use. I wonder what you’re collecting in at least one of those folders that is causing a problem.


#17

@DaveR raises a good point. Such drastic action surely shouldn’t be necessary. Have you saved a copy before the deletion and shared it with the Trimble team so they can try to diagnose what is really going on? If for any reason you are reluctant to do that, could you compare the contents before and after they are deleted/regenerated to see what changes?


#18

By deleting those folders, you also delete the PrivatePreferences.json file which holds all the user preferences. SketchUp will replace it with a new one. One of the things that gets reset is the status of the tool windows and the window that has been shown to be responsible for most of the slowdowns we see is the Materials window. I would like to see if your users see a load speed increase when they keep the Materials window contracted when not in use and only expand the window when they need to access their Materials.


#19

Hi All,

@TheGuz if this happens when Sketchup is closed, e.g. when double-clicking to open a file from Windows Explorer, then can this material window still be the cause of this?

I could check again when it happens but I’m not sure it is the materials window in this case.

@slbaumgartner, I have not saved a copy of those files before deletion. Will do next time it happens. Trimble support won’t be much of help. Last time I contacted them they redirected us to the reseller who sold us the license. If this happens again I’ll zip up the folders and attach them to this thread. Then maybe someone from Trible can have a look at it :slight_smile:


#20

Hey Rick2! To clarify, “yes”. If your Preferences have been saved with the Materials window expanded it will impact the next time you attempt to load a model… at least in our test cases.