Sketchup Pro 2018 takes forever to open files

sketchup

#21

@TheGuz,

Sorry for not properly testing this earlier. It is amazing, you are absolutely right about the materials pallette. The issue has just returned. I closed the materials palette and the files open and save very fast again!

Seems like this was the cause of the issue after all…


#22

solved with reply #6.


#23

Done @SketchUp3D_de


#24

Great to hear! Thank you for getting back to us with the solution that worked for you. I hope it helps others!


#25

@TheGuz while the open and save issues are now resolved, one user still has performance issues unfortunately. Whenever they click, drag or do something in Sketchup they have a 5-10 period of a freezing Sketchup with “Not Responding” added to the title screen. If they click again when this happens then it freezes completely and they have to close the program.

I’ve tried the new Sketchup 2019 and install an updated graphics card driver, but no breaktrough yet. I’ve also checked for the Materials panel especially, but it doesn’t matter in this case if this panel is closed.

I hope that you have a magic solution for this issue as well? :slight_smile:


#26

System:

  • CPU?
  • Grapics Card?
  • recent Driver Version of Graphics Card installed?
    (“Win+R > dxdiag > Display”)

Document:

  • every document or specific documents only?
  • if specific documents: what does “Window > Model Info > Statistics" with options “Entire Model” and “Show nested Components” say?

Performance:

  • ensure that the model is near the model room origin especially after importing a DXF/DWG (or use the concerning import option to avoid)
  • purge affected documents by “Window > Model Info > Statistics > Entire Model > Purge Unused”:

  • if purging doesn’t help either, you could also unhide everything, switch on all layers, select all and copy/paste to a new document

The “Not Responding” message is shown by Windows if the concerning application is not respoding because occupied by number crunching, i.e. normal behaviour.


#27

Excellent suggestions, SketchUp3D_de!
The user might also try the following:

  1. Make sure the actual file isn’t corrupt and hiding geometry far from the zero point. You can ask them to drag and select everything in their model… (note Ctrl-A or Cmd-A will not work as it will also grab that phantom geometry) Edit > Copy, then go to File > New, then Edit > Paste In Place into this new file. Save that file and see if they are still having “Not Responding” issues.

  2. Ask the user to review the Agile Modeler’s Guide for tips on getting the most out of their hardware. You can find it here: https://goo.gl/T5VbW4


#28

One more thing just dawned on me. If you are using a laptop with a discrete GPU but have to work on battery power, your Windows 10 system may be configured for power saving mode and revert to your integrated video card to extend battery life. This could affect load times and modeling responsiveness. There is a way to adjust the settings so that the GPU is always the primary when using SketchUp. Some good instructions for how to make this happen can be found HERE.


#29

Thanks @TheGuz and @SketchUp3D_de for your suggestions. I’m onsite again on friday and we’ll definitely have a look at it.