Unbelievable start up time!

It’s certified, vray makes this slow. After i disabled the plugins. Set up takes up 20sec again.

It’s quite troublesome isn’t it to enable and disable the plug ins all the time. too bad.

Will I be able to activate plugins using sketchucation plugin while i am using sketch up? or do i need to relaunch sketch up again?

is it possible my file size is too big? will this make vray start up slowly? FYI an empty sketchup file with vray enable start pretty quickly as well.

Never used Vray so can’t comment.

Sketchucation allows most plugins to work actively with a session without a restart.

sadly vray cant be found in the plugin.

my goodness

If I’m understanding what you mean, change the drop down at the top to look in other possible folders.

Explain further? How am I going to do what you just said?

Well, I’m still guessing due to your lack of full explanation but try this.

how come you have 3 file locations there? i only have one.

is there something i need to do to add file location to sketchucation plugin?

Apparently i found a trick to it…

For those who are facing this problem as well, here’s the trick.

  1. Open blank a file first.
  2. Proceed to disable all the plug ins. Here’s how - http://help.sketchup.com/en/article/1700320
  3. Open the file you are working with (the one that start extremely slow)
  4. Once it is open enable back all the plug ins.
  5. Copy the model.
  6. Re-open another blank file. (You should be able to see all the plug ins re-enabled)
  7. Copy your model to the blank file.
  8. TADAA!!! Required time should be reduced by 99%

Hope his helps.

Thanks you all your help guys.

Do share with me if anyone of u have new methods.

Cheers.

V-ray is installed in C:\ProgramData\SketchUp\SketchUp 2015\SketchUp\Plugins

Change the extension from RB to RBX and V-ray will be disabled.

Restart SketchUp after all.

1 Like

it works. thanks mate :heart_eyes:

Every version of V-Ray hugely increases start-up times.
You could also try installing the Sketchucation plugins manager; from over on the other SU forum. This enables you to load/disable plugins on the fly, without closing or restarting SU. That way, you could leave many scripts like the V-Ray loader disabled by default unless you actually need to use them.

hi,

I’ve tried “SketchUcation plugin manager” for the issue. After opening of the file , if you are trying to load back the vray plugin for enable it takes same long time (something like 20 min.)

so this is the very big ennoying bug from vray and sketchup… if someone has any diffrent way for fix the problem i will be very very happy …

thanx a lot…

I have been having a curious startup problem as well that seems similar. Sketchup is taking more than 10-15 minutes to open medium sized files that normally start in 30 seconds. I have older computers that will open them “normally” but my new laptop will not. First I tried disabling all my extensions and for a bit that seemed to work… then it didn’t. I thought that was curious so then updated windows and NVIDIA drivers. That worked for a day. I booted up this am and back to ridiculous load times. I can’t find a pattern or logic to it. I feel like it has to do with Windows as my older / slower machines (that are not as updated) open things just fine. I know windows meddles when it updates but I am not sure what to look at. I have the NVIDIA graphics card set to be used over the Intel Graphics.

This machine opened them fine as well until this started happening about a month ago. Any ideas of where to look would be appreciated.

SU 2018 Windows 10 64bit nVidia GeForce Pascal GTX1070 Max-Q 8GB GDDR5 DX12
CPU Coffee Lake 8th Gen:8th Gen Intel Coffee Lake Core i7-8750H, 2.6~4.1GHz

Update: I discovered in my task manager the core that is being used for skp is completely maxed out while opening the file despite running at a higher clock speed than other machines opening the same file. The other machines do not max out the core while opening like this one does.

After discovering the cpu issue I uninstalled and re-installed skp and the problem is gone. Starts up in less than 30 seconds despite file size and I cant really even tell which core skp is using in the task manager

Hopefully it stays gone but given how many times I already thought I solved this.

Its back… ugh.

It’s been worrying me for days, I knew it was going to come back after 3 years and the dates don’t lie.

Go to the Nvidia site to see if you indeed have the latest driver. If not download it from Nvidia and give it a try. When installing check the box for “clean install”. It’s in the small print

Thanks I will try that… I downloaded / reinstalled the latest yesterday but did not c;ick clean install

no joy same problem still. I might have figured out it is a plugin but it is just inconsistent enough I am not sure of that.

Just was going to mention for completeness and for posterity that the problem immediately went away for me this way.

Basically, it was sufficient to just close SketchUp’s default tray before opening a corresponding SketchUp file. I didn’t even have to do the “purge” step.