Sketchup Freeze on startup

Hello fellow SU users!

I am having a problem with sketchup… Because most of the time it freezes on startup when ik try to open a model or just a new file. i also had the same problem with sketchup 2015, thats why i upgraded to 2016. In the begining it seemed to work just fine and pretty smooth, but the next day it didnt work anymore (most of the times i try to open files) When it does open a file everything works perfect…

does anyone know whats wrong?

(sorry for bad english)

We need to find out if it is problem with SketchUp or that specific file you are trying to open.

Have you experienced the same issue when starting sketchup without opening a file?

Yes with and without opening a file

and it is freezing, Not Responding?

I’ve never experienced such issue.

But, one solution I can think of is clean install.

https://help.sketchup.com/en/article/36209

Any idea Sages?

Yes it always seems to start, loading icons etc. but not my model… when i try to do anything it says ‘not responding’.

I already tried to reinstall it, but that didn’t work… the only thing i can think of is that there is somehow a minor bug in windows 10 or something because sketchup 2015 didnt work either.

My hardware should be able to handle sketchup easily (i7 5700hq and nvidia GTX 960M)

just a quick question.

Are you running Vray?

Sometimes extensions such as Vray can cause SketchUp to load very long time.

not Vray but i have su podium installed… maybe that’s the problem? the wierd thing is that sometimes sketchup opens effortless

Try disabling all plugins and see if that changes the behavior. Also clear the Internet Explorer caches.

where can i disable them easily?

Navigate to User\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp. Rename the Plugins folder to something other than Plugins. AppData is normally a hidden directory so you’ll have to make it visible first.

If you are just disabling one or a few, you can disable them under Preferences>Extensions but there are some extensions that won’t show up in the list.

I have not used podium, but I will explain what Vray does, and podium might to the same thing.

As it opens regular SketchUp file, it converts all material data to Vray materials. This can take a very long time depending on the materials count and their types. It can hang forever, but it will eventually kick back.

This opening time will reduce once that process is done for that specific file.

The best advice is to disable the suspected plugin and see if it makes difference.

Window > Preferences > Extensions,
uncheck the extension that you want to disable.

Above process only if you can load sketchup. Follow what @DaveR says if you can’t open at all.

Okey, thanks for the help guys! I will try your instructions :slight_smile:

It this a Win10 upgrade?
Despite what they say, some graphic cards aren’t fully capable of working with Win 10.
I upgraded one hi spec laptop and everything sketchup went to hell. Reverted back to Win7 and all perfect again.

no windows 10 came pre installed, so should work okay. but i have to say that big models run about the same as speed (framerate) when i load them on my old crappy laptop… It seems also that it is only possible for sketchup to use about 20 % of my cpu even when it is running really slow… any tips for that while we are at it? :confused:

Mind you, SketchUp can only utilize a single core of your CPU. Many laptops also bottlenecks on heat which prevents your computer running at full speed.

Though i think frame rate has largely to do with graphics card than CPU.

Although Windows 10 came installed on your computer, the graphics driver may not be up to the job. If you can get to SketchUp’s Preferences, try turning off Hardware Acceleration under OpenGL. See if that helps. You might also check for driver updates from nVidia.

Okay, i tried to turn of the plugins, with no result. after that i tried to start sketchup with the intergrated graphicscard but it is still the same thing…

Time for little bit experiment to sketchup.
Go windows preferences OpenGL

Each time u follow this step restart ur sketchup

1st click on the Use hardware acceleration and see if it work

or

2nd click off the hardware acceleration and just click on click on fast feedback

or

3rd click on both hardware acceleration and just fast feedback and see if it works.

best of luck!

Check that sketchup is actually using the Nvidia card when you’ve set it to do so.
In the opengl settings, click the details button and see if it is showing the integrated card or the Nvidia card.
That was my main issue with Win 10, even though I had the card it wouldn’t use it.

On a laptop, the Nvidia control panel 3D settings default to Automatic graphic card selection, and in my experience this results in the Nvidia graphics sitting idle while the Intel chip tries to do all the things it cannot. 3D applications must be forced to use the 3D-capable card.

Anssi