Unbelievable start up time!


#1

Hi, recently I have been facing a problem with one of my sketchup files with ONLY my desktop.

The specs of my desktop are

Intel i7 4970k
16GB RAM
250GB SSD
NVidia GTX 970
Windows 7 Ultimate

But it takes up to ONE HOUR PLUS for one freaking file to open (file size 250mb). Initially it’s fine all is good, but after i installed vray and other plug ins, this problem start to arise.

Suprisingly, the same file can be open in other computer under 20seconds. I tried it on a few of my friends laptop with the same plug ins installed. I even open it on my own laptop which also takes less than 20sec. Spec wise, all of the laptop are not even compatible with the desktop. I always forced me to watch a movie before i can start drawing my sketch up =.=

Is this software problem? Should I re-install it?

PLEASE HELP :frowning: :frowning: :frowning:

I am really desperate to get this fixed.

Every comments and suggestion is much appriciated.


#2

The first thing I would try is disable all your plugins and see if that fixes it. If so you then need to determine which one or combination is the problem.
Make sure you find all plugins. Some .exe installed plugins use a different plugin folder. Make sure you don’t have the same plugins loading from different folders. What version of vray do you have? Some of the older ones were notorious for causing issues.


#3

I would suggest the same @dsgn_075
It’s easy to do. Here’s help with that…

Disabling Ruby Scripts — SketchUp Help


#4

The version of vray is 2.02.25244

I’m starting to suspect it’s the vray version… all plug ins has been disabled. but when i enabled vray again the problem is back.

Any solution to this? is it possible to disable vray everytime and only enable it when I ask it to?

Much appriciated.


#5

You can install the Sketchucation Plugin which gives you the tools to turn on and off plugin as you need them, amongst many other very useful tools.

But I would check the Vray site for updates or known problems.


#6

It’s certified, vray makes this slow. After i disabled the plugins. Set up takes up 20sec again.

It’s quite troublesome isn’t it to enable and disable the plug ins all the time. too bad.

Will I be able to activate plugins using sketchucation plugin while i am using sketch up? or do i need to relaunch sketch up again?

is it possible my file size is too big? will this make vray start up slowly? FYI an empty sketchup file with vray enable start pretty quickly as well.


#7

Never used Vray so can’t comment.

Sketchucation allows most plugins to work actively with a session without a restart.


#8

sadly vray cant be found in the plugin.

my goodness


#9

If I’m understanding what you mean, change the drop down at the top to look in other possible folders.


#10

Explain further? How am I going to do what you just said?


#11

Well, I’m still guessing due to your lack of full explanation but try this.


#12

how come you have 3 file locations there? i only have one.

is there something i need to do to add file location to sketchucation plugin?


#13

Apparently i found a trick to it…

For those who are facing this problem as well, here’s the trick.

  1. Open blank a file first.
  2. Proceed to disable all the plug ins. Here’s how - http://help.sketchup.com/en/article/1700320
  3. Open the file you are working with (the one that start extremely slow)
  4. Once it is open enable back all the plug ins.
  5. Copy the model.
  6. Re-open another blank file. (You should be able to see all the plug ins re-enabled)
  7. Copy your model to the blank file.
  8. TADAA!!! Required time should be reduced by 99%

Hope his helps.

Thanks you all your help guys.

Do share with me if anyone of u have new methods.

Cheers.


#14

V-ray is installed in C:\ProgramData\SketchUp\SketchUp 2015\SketchUp\Plugins

Change the extension from RB to RBX and V-ray will be disabled.

Restart SketchUp after all.


#15

it works. thanks mate :heart_eyes:


#16

Every version of V-Ray hugely increases start-up times.
You could also try installing the Sketchucation plugins manager; from over on the other SU forum. This enables you to load/disable plugins on the fly, without closing or restarting SU. That way, you could leave many scripts like the V-Ray loader disabled by default unless you actually need to use them.


#17

hi,

I’ve tried “SketchUcation plugin manager” for the issue. After opening of the file , if you are trying to load back the vray plugin for enable it takes same long time (something like 20 min.)

so this is the very big ennoying bug from vray and sketchup… if someone has any diffrent way for fix the problem i will be very very happy …

thanx a lot…


#18

I have been having a curious startup problem as well that seems similar. Sketchup is taking more than 10-15 minutes to open medium sized files that normally start in 30 seconds. I have older computers that will open them “normally” but my new laptop will not. First I tried disabling all my extensions and for a bit that seemed to work… then it didn’t. I thought that was curious so then updated windows and NVIDIA drivers. That worked for a day. I booted up this am and back to ridiculous load times. I can’t find a pattern or logic to it. I feel like it has to do with Windows as my older / slower machines (that are not as updated) open things just fine. I know windows meddles when it updates but I am not sure what to look at. I have the NVIDIA graphics card set to be used over the Intel Graphics.

This machine opened them fine as well until this started happening about a month ago. Any ideas of where to look would be appreciated.

SU 2018 Windows 10 64bit nVidia GeForce Pascal GTX1070 Max-Q 8GB GDDR5 DX12
CPU Coffee Lake 8th Gen:8th Gen Intel Coffee Lake Core i7-8750H, 2.6~4.1GHz

Update: I discovered in my task manager the core that is being used for skp is completely maxed out while opening the file despite running at a higher clock speed than other machines opening the same file. The other machines do not max out the core while opening like this one does.


#19

After discovering the cpu issue I uninstalled and re-installed skp and the problem is gone. Starts up in less than 30 seconds despite file size and I cant really even tell which core skp is using in the task manager

Hopefully it stays gone but given how many times I already thought I solved this.


#20

Its back… ugh.