20 min launch time - SketchUp Pro 2018

Im running SketchUp Pro 2018 on a new Windows 10 with a Nvidia P4000 graphics card literally every time and every way I try and launch it im having to wait anything between 10 - 20 mins each time. It’s a long standing issue. I have reinstalled it, wiped the system and started again, and still the same issue. The only thing that works is deleting the user preferences file, this allows it to start straight up in a regular amount of time, but all preferences are back to default doing this. Anybody else got / had this same issue? Had absolutely zero useful help from SketchUp support.

I’ve never heard of this. Perhaps there are clues in the user preferences file though. Also, are you using any extensions?

Hi, yes i have extensions but the issue exists before any of these are installed and also when they are all deactivated.

You’re not giving us much to go on.
What are the preferences that are being deleted?
Is the Nvidia card being used?
Have you updated the Graphic Card drivers?

ensure, that the latest driver version of the Quadro is installed.

Try if disabling “Window > Preferences > Fast Feedback” and configuring Anti-Aliasing to “0x” changes this behaviour.

Do you have issues similar to SU opening slow with other apps on the PC?

Hi, it’s the user prefences file generated by sketchup, the video card is being used and the drivers are upto date.

This doesn’t change startup time, thanks anyway

No, everything else is fine, just sketchup. I think i have found the cause now, its the component library. I’m loading this off a network drive and if i have the components window shut it starts up fine, if it’s left open then it takes ages

Yep. It’s not a good idea to be loading assets from a network location during start up.

@TheOnlyAaron advised to keep all trays closed (autohide) to resolve these type of loading issues.

from a share in your local network (LAN) or an internet based cloud service?

Those are all great suggestions. I’ll sum up what I would suggest starting with a potential fix followed by maintenance suggestions. The first two only apply to Windows systems.

  1. Materials Window - A painfully long start-up time is an issue experienced on some systems and we have been looking at very closely these last few months and we are working on a permanent fix. In the meantime, we have discovered a significant difference in load times when the Materials window is kept contracted and only expanded when access to Materials is needed. Please try testing this out and seeing if it makes a difference for you. On a related note, we have also heard of slowdowns attributed to an open Component window and also an open Outliner window.

  2. Driver Updates - Windows likes to conduct regular updates. To match those updates, I always recommend installing the absolute latest version of your video card drivers and keeping them updated on a regular basis. You can always rollback an unstable driver release.

  3. File Location - LAN connectivity was mentioned above. We always recommend storing your live files (files, on which, you are actively working) on your local drive and that the save path is NOT being actively synched to the cloud (in other words, if you are using a backup service like Dropbox, make sure it is not trying to synchronize the folder you are working from). Files saved to network shares or cloud storage stand a higher chance of corruption that is increased with larger files and slower or high traffic networks. If you want to ensure a secure backup of your work, I would recommend scheduling an after-hours backup of the save path or saving locally then dragging a copy to your network drive.

  4. Extensions - I’m not sure that I’ve seen slow load times attributed to Extensions, but I do like to recommend installing all extensions from the Extension Warehouse (when available). When doing so, make sure the extension says it is compatible with your current version of SketchUp. Holding on to that old 2016 extension to use with the latest SketchUp can result in anomalies.

Let us know what helps if any of it does.
Cheers!
-guz

3 Likes

Check:

Oh! Good eyes. The “Get this Extension” link there actually points to the Sefaira site to ensure the latest compatibility. We’ll get that Extension page updated shortly.

1 Like

Hi Guz & everyone else.

Me and others in my team have been facing the same issue (over a long period of time now).

SketchUp would take up to an hour to load, and there’s absolutely nothing you can do to help it along.
This is a truely awful situation to be in if you’re sitting down with a client or running an off-site presentation - you are totally stuck!!! Not to mention its a huge waste of productive time.

I have done some troubleshooting.
(I went through all the usual excuses around the cause being 3rd party extensions, drivers, bad SU install, windows updates, network issues, etc…these were not the issue). This troubleshooting took many hours, btw.

Here’s what I’ve learned:

When opening the default template (eg Architectural, Meters) it was opening with the Component Browser displayed, and opened to a category called “Recent”.

This seems to be the default SU behaviour and IMO it should be changed.

In my case, “Recent” was actually a network-located library of 3d people (over 1GB of data).
When SketchUp is starting up (loading the template) it seems to be trying to retrieve that data.
Usually it took about 5 mins on our office network, but i’m currently on wifi so it was taking about 45 mins.

Solution:

I put the Materials and Components browsers into a new Tray, and set them to point to a default place (Materials shows the basic Colours and Components shows just the default directory - not open - so all that is seen is the folder icon, not the components).
Then I saved this as a template (stored the file locally) and used the Welcome screen to select it as the default template on startup.

Now I can launch SketchUp within about 3 seconds.

(edit1) HOWEVER: I want to be clear that if you close SU with the components browser open, next time you start up it will be open again AND it will open to “Recent”. And SU will take a long time to load.

So you also have to be vigilant and close SU with the Component window closed. Otherwise you’re screwed.

As i mentioned above, I think the default template should be changed and avoid the “Recent” category. If that is not agreeable then people need an option to load sketchup using “Safe Mode” or “Troubleshooting mode” with a blank file, all extensions turned off, default template, and all preferences (including file paths and graphics settings) set to default. From there we might decide to enable our Extensions en masse, load our Preferences, etc.
Also I think preferences files should be stored in the same way that templates are - within a default SU system directory, not a user-selected location (“my documents”) or network location.

Finally, opening any component library across a network takes a very long time. Windows Explorer can display the contents in seconds (with thumbnails etc) but SU takes forever. Many Pro users have numerous large/complex components in their libraries, so we need them to load in a reasonable time…(either from a local or a network location).

Thanks.

2 Likes

Interesting discovery. It would have been extremely unlikely that anyone would have guessed your delay was caused because the Components panel was trying to open a huge network based directory.

I have SketchUp set up so that Textures, Components, and Styles all start with the In Model collections and the only In Model collection that has anything in it is Styles which contains only my default template.

When I open the template called Architectural Meters, it also goes to In Model, not to Recent.

Hi Dave, that’s interesting.
Are you on a Mac or PC?

I just edited my post above with a bit more info (and I continue to test my ‘solution’ - what I havent tested yet is when I have numerous SU files open at the same time and close one, and open a new file)

I would be very happy to start SU with the “in model” components, styles, etc (of which there would be none, if possible).

Edit: I can confirm that the “Recent” category is opened even when I open a template I’v e never used before (eg Architectural, inches)

Side issue that might be related: The Welcome screen takes ages to load if your Recent Files contain large models (further testing of network-located models is required).

I have SketchUp installed on both Mac and PC but I use the PC for Sketchup much more than the Mac.

could imagine, that as a workaround disconneting the used NIC (LAN/WLAN/GSM) could skip the delay … reconnecting after SU has launched may allow to access the shared ressources though.