SketchUp Free failure to launch

I wanted to see how SketchUp Free works, so I want to app.sketchup.com and clicked on the “Start Modeling” button. All I got was a throbbing SketchUp logo. How long does it take for Free to launch? FWIW, I’m using the latest version of Firefox, which touts its speed.

there’s probably a bit of a log jam atm…

john

While we do expect SketchUp free to work on the latest Firefox release based on our own testing, you can try the latest of Chrome as well.

Same as this thread (What’s up with SketchUp Make?): if you’re having Firefox issues, and you have 57, can you go to http://www.geeks3d.com/webgl/ and paste in (or private message me) the text report at the bottom of that page, so we can check into this? Thanks.

Firefox or Chrome. Doesn’t matter. All I see is a throbbing SketchUp logo. Someone else suggested it may be due to excess traffic.

Working OK for me around 5 pm pst, using Opera.

It’s working now. Thanks, all, for the help and advice.

Not working either now or a few hours ago in Chrome. Same message - “Sorry, we encountered a problem with your browser’s webGL support” after several tens of seconds of throbbing SU logo.

Earlier, I got the usual jokey messages below the logo, this time just the logo.

Same in Safari just now. On Mac Sierra on a MacBook Pro, latest versions of Chrome and Safari

[A few mins later] Left it alone for a couple of minutes while posting here, and I now get the introductory screen in Safari … so problem solved?

Later still…

In Safari maybe, but Chrome still not working, even after hard reload of the page.

Now that’s beginning to sound like caching issues or network issues. Does it do the same in Private / Incognito mode?

I have the same problem.

  1. Doesn’t work in: Windows 7 Service Pack 1
    1.1. FireFox Quantum 57.0 (64-бит)
    Error in browser console:
    Could not create canvas: WebGL creation failed:
  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_BUG_1137716,:(,{“antialias”:true,“alpha”:true,“depth”:true,“stencil”:true,“premultipliedAlpha”:true,“preserveDrawingBuffer”:true,“majorVersion”:2,“minorVersion”:0} raven.min.js:2nd_place_medal:
    Error: WebGL warning: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_BUG_1137716
    Error: WebGL warning: Failed to create WebGL context: WebGL creation failed:
  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_BUG_1137716

1.2 Google Chrome 62.0.3202.94
Error in browser console:
Could not create canvas: Failed to create a WebGL2 context.,:(,{“antialias”:true,“alpha”:true,“depth”:true,“stencil”:true,“premultipliedAlpha”:true,“preserveDrawingBuffer”:true,“majorVersion”:2,“minorVersion”:0}

  1. Doesn’t work in: Linux host85-28-195-248 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux
    2.1. Chromium Version 56.0.2924.76 Built on 8.7, running on Debian 8.1 (64-bit)
    Error in browser console:
    Could not create canvas: Failed to create a WebGL2 context.,:(,{“antialias”:true,“alpha”:true,“depth”:true,“stencil”:true,“premultipliedAlpha”:true,“preserveDrawingBuffer”:true,“majorVersion”:2,“minorVersion”:0}
    2.2. Google Chrome 56.0.2924.87 (64-bit)
    Error in browser console:
    Could not create canvas: Failed to create a WebGL2 context.,:(,{“antialias”:true,“alpha”:true,“depth”:true,“stencil”:true,“premultipliedAlpha”:true,“preserveDrawingBuffer”:true,“majorVersion”:2,“minorVersion”:0}

For me Sketchup Free WORKS only in:
Iceweasel 31.6.0 in Linux

Possibly, but it seems unlikely. I cleared the browser cache in Chrome. And used the same computer and therefore same network connection for Safari, which worked immediately (though slowly in getting to the opening screen) both before and after trying with Chrome.

And it still doesn’t work tonight in Chrome, either. Cleared browsing data (cached images and files) and tried again. After only eight seconds, got the same message:
“Sorry. We encountered a problem with your web browser’s WebGL support.”

[EDIT] Just worked out how to get at the console message. It says (just the same as @pattison’s previous post about Chrome):

Could not create canvas: Failed to create a WebGL2 context.,:(,{“antialias”:true,“alpha”:true,“depth”:true,“stencil”:true,“premultipliedAlpha”:true,“preserveDrawingBuffer”:true,“majorVersion”:2,“minorVersion”:0}

Exactly the same behaviour. And I’ve never used incognito mode on this computer before.

Is there some setting in Chrome that enables/disables WebGL? I haven’t time to hunt for it now (past bedtime here in UK already) but would welcome any pointers on where to look tomorrow.

I have the same problem in Chrome.

Microsoft Edge works however…

Chrome for Android version 62.0.3202.84 works on my phone.

I’m running version 60.0.3112.90 on Windows 10 (this get the WebGL error). Can’t update to the latest version of Chrome at the moment, but I have heard from at least one other person on version 62.x (Windows 7) whom has the same problem.

Some more data:

When I go to https://get.webgl.org/webgl2 in Chrome, I get the following message:

“Hmm. While your browser seems to support WebGL2, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.”

I have explicitly enabled WebGL2 in “chrome://flags”, so I don’t know why it is disabled/unavailable. Note that I have integrated Intel HD 530 graphics with a “switchable” AMD FirePro W5130M discrete GPU. However, it is not possible to use the discrete GPU in Chrome. Perhaps integrated Intel GPUs have problems with WebGL2.

When I go to the same URL on my Android phone running Chrome, it indicates that WebGL2 is supported, available, and enabled. SketchUp Free works fine (except for the fact that the interface isn’t really designed for mobile/multi-touch).

When I go to the same URL in Microsoft Edge (which DOES work with SketchUp Free), I get the following:

“Oh no! We are sorry, but your browser does not seem to support WebGL2.”

So, clearly, SketchUp free is capable of running on WebGL 1.0 only.

Maybe the application is referring to some kind of browser whitelist/blacklist in order to determine which version of WebGL to use (for which Chrome comes up as a positive), but is not ACTUALLY checking to see if it is available/enabled? If so, maybe it should fall back to WebGL 1.0 if there is a problem.

I have a brand new Windows 10 laptop with an Intel UHD 620 graphics card and I cannot get SU 2017 or 2018 to work in the desktop version nor can I get Chrome to run the free make version claiming OpenGL issues. How is this possible? Trimble has made this product unusable. Has anyone had success with this? Microsoft Edge runs, but Trimble said “hold on Cowboy” and that it hasn’t “optimized” it for Edge yet.

This is supremely frustrating considering I’ve been working in Sketchup for 10 years.

Hi guys,

Sorry you’re having trouble with SketchUp Free- we’re looking into the issues and hope to have a fix soon. Your detailed reports are helping us to reproduce the issue in our lab, which makes it much easier for us to narrow down the solution.

This week’s launch of SketchUp Free included new code to use WebGL 2.0 for rendering when it is supported by your browser. If it isn’t supported, we fail back over to a rendering pipeline that uses WebGL 1.0 instead. There appears to be some issue with browsers reporting they are WebGL 2.0 compatible when actually they aren’t. We’re looking into it as fast as we can.

john
.

Yeah, according to https://get.webgl.org/webgl2/, my browser “supports” WebGL 2.0, BUT it is unavailable.

I suspect this means that although Chrome supports it, the hardware does not for some reason. WebGL 2.0 depends on OpenGL ES 3.0, but according to “chrome://gpu/”, my integrated Intel GPU only supports OpenGL ES 2.0.

Microsoft Edge works because it never claims to support WebGL 2.0 in the 1st place.

Hi there,

Unfortunately, Intel graphics (especially those without dedicated memory like the 620) are known to have problems running SketchUp. Since both our desktop and (now) browser-based builds of SketchUp depend heavily on OpenGL performance, you’re likely going to have problems running SketchUp on your new laptop.

For more details on the subject, check out our official Hardware Requirements.

What? This is terrible news. Are you saying that I cannot run SU anymore? I’ve been using it for 10 years and haven’t needed any special hardware to do so. That is what SU was founded on. I cannot afford to buy a separate PC just so I can do SU. There must be a solution. Has Trimble really abandoned such a larger user base? BTW I have the latest Intel Gen 8 i7 processor and 16GB of memory. That should be enough to run just about anything these days.

Another thought. I can understand if I don’t have the “optimal” 3D graphics setup, but SU should at least start. Not even starting is terrible. My G card has OpenGL 4.4. I’ve never run SU on an “optimal” graphics machine. Why is this a problem now?

What is my solution?

P.S. - I’ll take SU 2014, 2015, 2016. Something must work. I don’t need the latest features.
P.P.S - 2016 doesn’t even start either.

I have switchable AMD graphics, but there is no way to enable this for web browsers such as chrome (i.e. only really works with games and other stand-alone desktop applications).

Up until yesterday (before the new WebGL 2.0 code was deployed), I was having no problem running the beta version (my.sketchup.com/app) on the same laptop.

Please fall back to WebGL 1.0 if errors are encountered during startup using WebGL 2.0 (even if the browser says its supported)!

P.S.

I also found this, which seems to say that Intel DOES support OpenGL ES 3.0:

http://opengl.gpuinfo.org/gl_generatereport.php?reportID=1723

Maybe there are bugs and Google/Chrome has blacklisted Intel graphics for OpenGL ES 3.0, reverting to 2.0?