Sketchup Free won't launch: Sorry. We encountered a problem with your web browser's WebGL support

Browser: Chrome Version 62.0.3202.94 (Official Build) (64-bit)

Desktop OS: Linux Mint 17.3 Cinnamon 64-bit with Linux Kernel 3.19.0-32-generic.

GPU: AMD RV770 LE Radeon HD 4830 GPU with generic Linux Driver. (AMD does not have a driver version for the Linux Kernel 3.19).

WebGL: Chrome is running software WebGL, but does not support WebGL2.

Problem Description: Yesterday (or the day before) I was able to use Sketchup Free (though I had a few lock-ups when I tried to make components). Tonight when trying to launch it, I just got the message at the top of the page and then nothing (blank page).

I checked and there was a new update to chrome available (the version listed above), so I updated and tried again. Since Chrome updates automatically and I leave stuff open on my desktop, I assume Chrome might have done some additional updates over the last few days without me knowing it.

So the questions are these

  1. What exactly does Sketchup Free require out of the WebGL features to run correctly, so I can figure out how to make that happen in my browser.
  2. Does anybody know how to make Chrome provide the environment needed?

7 posts were merged into an existing topic: SketchUp Free failure to launch