My.sketchup worked, sketchup free not working

Hello!
On my work computer (Arch Linux, Google Chrome version. 56.0.2924.87, do not have the ability to update) worked my.SketchUp, but after the release of SketchUp free, receive the error message:
“I’m sorry. Discovered the problem with WebGL in a web browser”

WebGL is working, checked on https://get.webgl.org

There are two versions of WebGL: WebGL1 and WebGL2. SketchUp Free has been upgraded to take advantage of WebGL2 features. This is unfortunate, because as a cloud app, users cannot keep an old version that works for their hardware.

WebGL2 is new and I suppose we will initially see the same procedure as with the first WebGL, that browsers manufacturers rigorously blacklist devices they think may not run well. Check out in about:flags, whether you can force-enable WebGL2 and whether it actually works for your hardware.

See also this thread and this.

Thank you for the info about that in SketchUp Free works on WebGL 2.0!
Included in the WebGL 2.0 in Google Chrome, but unfortunately it changed nothing, the error is the same.
Снимок экрана от 2017-11-21 12-14-40

Hi Bombalero,

Unfortunately, this issue does not seem to be a simple question of WebGL2.0 support- we’ve seen a number of different browser/os/driver combinations that are causing this error.

We’re gathering data now to try to reproduce the issue in our lab— which is the first step toward solving it. Can you share more info about your system configuration?

thanks-
john
.

Is it possible to detect when this issue occurs and fall back to WebGL 1.0 instead? SketchUp Free works for me on Microsoft Edge which doesn’t support WebGL 2.0 at all!

Hi Jbacus, of course I am willing to share the configuration of their system, but as this is my work computer, I don’t have “root” rights, and in Arch Linux not good. I hope that you will get enough information from chrome://gpu/

As I understand it, my browser shows WebGL 2.0 enabled, but in fact does not support it, does not open WebGL 2.0 Samples.

Not versed in programming, but maybe you can do that would SketchUp Free supported WebGL 1.0 and 2.0 simultaneously? Thank you!




I agree with you. I hope the developers will find a solution to this problem and give the opportunity to work on WebGL 1.0.

Unfortunately, this isn’t a simple case of WebGL 1.0 vs 2.0- it also depends on how your graphics driver, operating system and web browser implement those standards. I think the trouble folks are reporting is evidence that there’s a great deal of diversity out in the wide world of SketchUp users. In other words, it isn’t a simple matter of ‘reverting’ to WebGL 1.0…

We’re compiling data, working on releasing a fix to address the most challenging cases as soon as we can. It is almost always the case that updating your OS, Browser and graphics driver to the ‘latest’ version is the best possible way to fix the issue… but there may be a root cause that won’t be fixed with simple updates.

Linux offers a special set of challenges, as it is still, unfortunately, the case that things like display drivers aren’t always given as much attention by manufacturers as they might be given for Windows.

john
.

1 Like

I’m having the same issue, Chrome Version 62.0.3202.94 (Official Build) (64-bit), Windows 10 version 1703 (OS Build 15063.726), Intel HD Graphics Driver 8.15.10.2900, Acer Aspire (old):2017-11-27 11_32_41-Control Panel_System and Security_System

Same issue here using Firefox Quantum 57.0 (64Bit) on Mac OS X El Capitan.

It works fine for me on Safari 11.0.1 (11604.3.5.1.1).

System:
MacBook Pro (13-inch, Mid 2010)
2.66 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3
NVIDIA GeForce 320M 256 MB

Same here using both Chromium and Chrome on Ubuntu 17.04 on aGigabyte mobo with AMD FX™-8350 Eight-Core Processor and Graphics: Gallium 0.4 on AMD RV770 (DRM 2.49.0 / 4.10.0-40-generic, LLVM 4.0.0). I have several models I need to access, but am now unable to. It seems that the associated My Sketchup account has been wiped too, along with the models? - I have has to set up a new username to post this.

Crashes on loading with Win 10 Pro 1703 + Intel 945 graphics - dell laptop.

…But loads with Firefox on above same Ubuntu machine. Hooray! So there is something funny going on with the browser WebGL support flags in Chrome and Chromium…?

Those of you with this problem, please try accessing SketchUp Free through this URL:

https://app.sketchup.com/app?webgl1=true

We currently have an issue with the way we are detecting WebGL2 support, which we will be fixing soon.

Thanks!

2 Likes

Thanks!
This seems to solve the problem on my windows 10 and Ubuntu PC
both with chrome and firefox browsers

Unfortunately it didn’t work for me, this is what I got:
2017-12-06 13_38_45-SketchUp

No, help on a very old Dell Inspiron N5030:
This machine ran “my.sketchup” but fails to run “SketchUp Free”.

  • Intel® Mobile 4 Series Express chipset & graphics.

    • driver v. 8.15.10.2869 (OpenGL v. 2.1 max)
  • Win 7 SP1 & all updates.

  • Chrome versions:

    • 62.0.3202.94 (Official Build) (64-bit)
    • 63.0.3239.84 (Official Build) (64-bit)
      • Just upgraded (to v63,) restarted browser, no help.
        Now get a JS alert error box that I had not seen before. (Image inserted below.)

    image


Contents of "chrome://gpu" in a zip archive ... (click to expand) ...

gpu.htm.zip (10.4 KB)

:geek:

Hi all,

The URL I posted helps when the issue is lack of WebGL 2.0 support. However, there is a second class of problems on WebGL 1.0 as well, generally with older hardware. These machines are technically WebGL 1.0 compatible but our app requires a bit more than those minimum requirements. We are currently trying to identify and fix those issues so please bear with us.

thanks,
Bugra

Works, thank you very much!
I love Sketch Up!

I get the “Sorry, SketchUp appears to have a graphics incompatibility with your browser.” message.

My PC is not that old. It is a Dell Precision 3510 with Intel HD Graphics 530.