WebGL Fix 2017-12-13

We’ve just pushed a few updates that should resolve the WebGL issue some users were experiencing when trying to access SketchUp Free or SketchUp for Schools. If you received this error, can you try launching the app from your browser and let me know if you are still experiencing any issues?

Here are the release notes for reference:

  • Expanded support for WebGL to a wider range of hardware configurations.
  • Fixed an issue when uploading a model to 3D Warehouse.
  • Fixed a bug preventing Instructor Panel content from showing correctly in certain languages.
  • Added ability to reactivate the welcome tour while modeling.
  • Updated the UI of the welcome tour.
  • Fixed an issue when files with the .skp extension removed are opened in SketchUp from Google Drive.
  • Added SketchUp Make and SketchUp Pro desktop applications to the downloads tab.
  • Fixed a bug that caused the 3D Text tool to become stuck as the selected tool in its toolgroup.
  • Fixed miscellaneous UI issues.
2 Likes

Happy to report this now works fine in Chrome v62.0.3202.94 on iMac 27" 5K running High Sierra, which wouldn’t work the last time I tried it a week or so ago.

Thanks.

PS. Found Chrome was waiting for a Relaunch to update to a later version 63.0.3239.84, which also works fine on a quick test:

1 Like

Looks oke!
Runs on my old intel core2PC hardware with 4mb mem, windows 10 -geforce 8400G GS with Firefox, Chrome and Edge browser.
Also on my old backup PC hardware intel core2-2gb memory with Ubuntu-16.04 LTS-Geforce 8600 GT with Firefox and Chrome browser.
Thanks!

I was unable to install, do I need to download a new installer? does this apply to a web-version, or both?

This announcement applies only to SketchUp Free and SketchUp for Schools, our web-based versions of SketchUp.

Thanks jbacus,
it’s giving me an error “graphics incompatibility”, do you know if there’s an older version I can use?

Does the error you are seeing look like this one or are you seeing something different?

Yes it does (with the throbbing logo), I’m assuming my video card (or lack thereof) is insufficient. I know this conversation is drifting off-topic but it would be nice if this tool actually worked even with limited functionality, otherwise if an older version is available that would be helpful feedback as well.

Can you describe your system configuration? Specifically:

  1. Operating System (and version)
  2. Web Browser (and version)
  3. Graphics card/chipset
  4. Graphics driver version
1 Like

Well since you asked I installed Firefox which works, and iexplore works (with a Whoa there, cowboy warning). Chrome is up to date (v63.0.3239.108) but still gives the same error message.

Dell E6410, Win7 Pro, Intel® HD Graphics, Core i5 M560, 8g Ram

DxDiag:
https://drive.google.com/file/d/19Push8LDtK3nCRvUpiX60L3hXXDVPunU/view?usp=sharing

I’m happy using it in FF, tho let me know if there’s anything else I can do to help.

Thanks! SketchUp Free now works in Chrome on my old IMac.

Hi,
I am happy that it now works on my Xubuntu, both on Firefox and Chromium.

Thanks to the team for their efforts. This is a life saver for us hobbyists.

Al.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.