Problems with 2020 new install

I installed PRO 2020 last week but didn’t have time to use it. I’ve been configuring it today. It seems that every so often I get a window “configuring sketchup” which starts loading and then stops with the following:

Capture2

If I click OK I get the following Popup:

I tried repairing the installation, but it gets so far and then these windows appear again stopping the repair. I’ve got stuck in some kind of loop that seems difficult to get out of.

The Pro 2020 installer is located in my downloads folder, the same place I downloaded it to last week.

Any ideas?

1 Like

Are you running the installer thus ?
Close SketchUp/Layout, while logged into Windows as your normal user-account.
Find the installer’s exe file - probably in your Downloads folder.
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair” [for a brand new installation choose “Install”]

This should set up permissions properly - it seems that your user accounts permissions are currently messed up, and restricting SketchUp’s ability to extract its subfolders and installer files into its Temp folder…

PS: if problem isn’t immediately solved, look for the long named subfolder in your …/AppData/Local/Temp folder {E6C7…96BD} and delete it, then try doing the “Run as administrator” again…
Installing an exe file in any other way - e.g. by double-clicking the exe to “Run” it - if doomed to make unpredictable problems, often involving permissions…

Yes that’s how I first installed last week and the same for today. I have administrator user control on the laptop.

I can’t see any folder in that location starting “EC674”…

Having admin powers and using “Run” on an exe is NOT the same as using “Run as administrator” from the context-menu. Are you explicitly using that option ??

The …AppData/Local/Temp/subfolder name I gave is listed in your earlier error message it’s within {…} - at least in the error message - it starts {EC6C7… as I stated, so where did your EC674 come from ?
It’s probably a randomly generated name anyway, so it’s not mega-important

Can I suggest that you also check you Temp folder’s permissions… mine is set to allow all of the listed users/groups FULL access - what about yours ?

Somehow SketchUp is failing to write to it - and as I say this is often indicative of an incorrect installation, fouling up the permissions…

Yes, I right click and “run as administrator”. The question I’m asking myself now is how did the initial installation last week run straight through without problem. (I right clicked and ran as administrator that time too).

Full control is granted to all users.

I had to pop out but I’ll do a cold reboot and retry again…

The issue remains. A thought I’m having is that I’m not currently connected to the work server as I’m at home. I wouldn’t have thought that would cause an issue, or does it? I’ve not had the problem before.

Machines can bee configured so that %AppData% is not on the local drives, but on a server. What does %AppData% resolve to for you?

Hi Colin,

Capture3

That wouldn’t be the whole path, there was Roaming after that I imagine. The important part is that it is C drive and not a remote server.

But the user’s Temp folder is in the Local path, so %AppData% is academic ?
Sketchup.temp_dir
C:/Users/USERNAME/AppData/Local/Temp

It’s the permissions for that folder that I question ??

I will send you a PM with some images…

All looks fine - just like my set up…
Most weird…
Anyone got a cunning idea ??

Like I said before, I installed it fine initially then something caused this error to pop up and now I’m stuck in the mud not being able to repair.

SketchUp works but the error keeps popping. I don’t know whether I have the balls to completely remove 2020 then reinstall again to see if it works. Maybe that’s a bad idea.

A cup of tea maybe?

I looked for any Temp folders during an install, and didn’t get any. Also, I don’t think the current installer includes any MSI files.

My thinking is that the exe file is somewhat like a zip file, when it’s executed various files get copied somewhere [Temp?] and the ‘installer’ MSI file is perhaps one of them.
I suspect that if you change the exe file’s suffix you could extract its contents and then ‘run’ that MSI file ??

However, I’m now unsure - there’s a proper MSI in v2019’s exe [and earlier], but not in v2020’s online exe…
So does the online version download the MSI when it runs ?

Use at own risk:

  1. Fully uninstall all previous installations of SketchUp using Windows “Add or remove programs.”

  2. Clean the Temp directory:
    a. In File Explorer, right-click “Windows (C:)” > Properties > Disk Cleanup
    b. In Disk Cleanup, check “Temporary File” and uncheck everything else
    c. Click OK > Delete Files

  3. Remove any stray SketchUp MSI files:

a. Download MsiZap.exe.zip using this link:
https://drive.google.com/file/d/1oVmBga1I6H1clIRc4U04rlxQB_zubXmV/view?usp=sharing

b. Unzip the file, and note the path where the MsiZap.exe folder is located.

c. Launch a Powershell window as an Administrator; then run these commands:
PS> get-wmiobject Win32_Product | Format-Table IdentifyingNumber, Name | Out-String -Stream | Select-String “SketchUp”

d. If anything is returned by this command, then note the product codes (they are the values in curly braces {}).

e. Run this command:
PS> $msizap = “/MsiZap.exe”

e. Run the msizap command for each of those product codes (Include the curly braces in the command):

PS> & $msizap “TPG! {product_code}”

  1. Delete SketchUp keys in the system registry:
    a. Type regedit in the Windows search box to launch regedit
    b. Navigate to HKEY_CURRENT_USER > Software > SketchUp
    c. Delete "SketchUp " entries as needed
    Optional
    d. Navigate to HKEY_CLASSES_ROOT
    e. Delete .skb, .skm, skp, .layout, .style, etc. as needed
    f. Delete skbfile, skmfile, skpfile, layoutfile, stylefile, etc. as needed
    g. Delete entries in LayOut2020, SKB*, Sketch*, SketchUp2020, StyleBuilder2020, etc. as needed

Thanks for the detailed reply. This is the kind of route that bothered me, but I think I’m going to have to do it. I just don’t think now would be a good idea as I have 2019 running anyway and I need it, probably a job for the weekend. I did uninstall then reinstall 2020, and have it running successfully for the most part but I just don’t think it’s right with the file associations.

For example, I just saved this file in 2020 but it’s still associated with 2019. If I “change” the “opens with” 2020 doesn’t appear in the list and I have to dig through the PC to change it. But, then it doesn’t change anyway when I go back to it…

Also before when I had SU open and hovered over a SU FILE, that’s when the popup of my original problem would appear. It doesn’t do that anymore but I have 2x 2019 entries in the “open with” list. 2020 doesn’t appear there either.

TWO 2019

I’ll report back when I get onto it…

It’s the second of the two 2019 entries:

1 Like

Good to know thanks, maybe I do have a decent install this time then.

hi

this exact problem has happened to me too, but I think I figured it out

Sketchup 2020 looks for the sketchup2020.msi file to repair the installation everytime I delete the materials folders – in ProgramData\SketchUp\SketchUp 20xx\SketchUp\Materials

(I like to have my own personalized folders in my own language, so everytime I install sketchup I delete the standard ones and replace them with my custom ones)

this was never a problem with 2019 or earlier versions, but with 2020 it doesnt allow me to delete or rename any of these folders, or else it will look for the .msi file to repair the installation, and that whole mess happens again and again…

I’m currently on 2019 just because of this problem… is this going to be fixed?