SketchUp 2020 Installation Problem

This is serious. I downloaded the latest SketchUp 2020.1 Update and received the messages below. Capture4


So, after many tries, I uninstalled the ‘original’ 2020 version and ran the installer again (in Admin) with the same result.
Problem is, now I don’t have 2020 installed, don’t have a way of installing it and have 2020 version files which can’t be opened.
I’ve tried to clean up any remnant 2020 information as best I can. I do note that others have had similar or exact same messages but not seen how they actually fixed their problem.
Trimble haven’t been back to me with any kind of answer.

I have asked colleagues again for help about this, I gave a link to your post this time.

Were you able to copy the MSI file while you saw it in the temp folder, and run that on its own?

If not, here is a 2020.0.1 MSI installer to keep you going:

http://sketchup.com/sketchup/2020/SketchUpPro-msi

Colin,
An MSI file is in the Temp foder which I pointed it to without luck…numerous times.
I also used the one you shared…no luck.


…and the same messages result.
Mark

1 Like

To cover some more bases…
If you simply open the MSI file it should start installing - unlike the EXE installer which then loads the msi etc…

Alternatively, when you ran the EXE installer did you do it in the correct way ?
Login to Windows as your normal user-account.
Ensure that SketchUp is closed.
Fine the installer’s EXE file… in Downloads ?
Select the file and right-click > context-menu > “Run as administrator”
When prompted choose “Repair” [or “Install” if it’s a new installation].
Let it complete…
Running an installer’s EXE file by double-clicking it to “Run” it is not the same thing.
Even if your user-account has admin-powers it must be done as I outlined.

Use this in the path-bar of a Windows Explorer window:
%windir%\installer\
The folder it opens will contain the copies of all of the hundreds of installers you’ve ever used !
Sort using the Subject field and scroll down to SketchUp’s entries…
The various MSI files should be listed there…

Does that help ?

Hi TIG,
Okay.
Running the MSI directly I get the same result.
I’ve run the installer with a clean boot as Administrator and get the same result.
Repair and Uninstall are not options.
Below are the only 2 installers with SketchUp in the Subject.


This does not give me a clue.
Mark

1 Like

It’s odd that the SketchUp v2020 msi copy is not there in that list…
At least that’s more info that the SketchUp tech-guys can consider…
@colin ???

PS: Your post is not 100% clear.
You must be logged in as your usual Windows user-account, not the separate administrator - but if your account has admin-powers that’s OK.
right-click > context-menu > “Run as administrator”
is the key part you haven’t confirmed exactly…

Yes, I ran as Admin and I am the Admin.

1 Like

I have been chatting with one of the DevOps QA team. Two things to try are:

Look in add or remove programs, to make sure there is only one 2020. I had a case where there were two, and that led to some confusion when I installed.

There is an offline installer, it’s worth trying that, to rule out network issues. You can get it here:

https://help.sketchup.com/en/downloading-sketchup

I’ve checked and there is no sign of any 2020 installed.
I ran the offline installer (as Admin) and get the same messages.

Thanks for doing that test. I will update my colleague.

No luck with your guys?

I have the identical problem and have tried everything you have with the same result. Have you found a solution yet?
Thanks you

1 Like

It was resolved…but not by Trimble, which is very, very disappointing. I had assistance from an IT guru in Canada who I’m not able to find the details for right now. As I understand it there was a missing/incorrect registry entry.

1 Like

Very interesting. I had absolutely no help from Trimble on this or from Creation Engines where my subscription was purchased.
I have a feeling the bad registry entry had to do with looking for the wrong msi file since that file didn’t exist on any of my 3 computers with the 2020 installations that had no problem updating like my new 9 month old Lenovo laptop did. I was unable to even uninstall the program to start over using the standard windows uninstall procedure (came up with the same error message looking for the non-existent msi file). Yesterday I ended up downloading the free uninstall utility called Revo-Uninstaller and it was able to wipe out the installation completely. Then I installed 2020. Of course I lost my set ups but at least I have the ability to update. Hopefully the next update will not have the same problem.
Thanks for the feedback. If you find the repair to the registry I would be interested in it.

1 Like

I am having the same problem with the same sequence of events. Reading the threads Trimble has known about this problem since May? I just encountered it now, so nothing has changed on Trimbles end? Disappointing

Hello I tried downloading the file but the link says SketchUpPro-2020-2.msi not 01.msi … but Windows blocked it and said “… was blocked because it could harm your device.”

The advise by Patl1 to delete everything and reload worked. The key is to delete EVERYTHING SKETCHUP, which includes Hidden Files in the Program. The Remove App function won’t get everything … after Window 10s Remove App, use the file manager tool, click the to the View Tab and select Hidden Files then use the Find All function to find files with Sketch names. Not sure why Trimbles install file ran into problems … just happy to be working again.

This topic was automatically closed after 186 days. New replies are no longer allowed.