No Tray Thumbs on Second Monitor


I have been waiting foe a week for the support reaction on the following problem. Perhaps here I would get any clue to solve the issue. I would appreciate it.

I need a prompt assistance, please.
As shown in attached image there is no materials preview available in the material tray - all thumbs are blank. The same for all thumbs in tray that are placed on the second(ary) monitor. When moving them to the main monitor the thumbs in trays appeared. Once re-placing them back to the second monitor they disappeared.

One cay say that they are visible only on the main (principal) monitor. When changing the setting for the monitor they they are visible.

Windows 7 PRO Ent
Nvidia M4000 12 GB (or 8GB).

Thank you in advance for your kind and rapid response.
This is my second message concerning this issue - no sign from the SU Support.

Are you using SketchUp 2015 as indicated in your profile? Is it Pro or Make? Have you checked to see that the drivers for the nVidia card are up to date? Are you sure SketchUp is using the nVidia card? Does this only affect the Materials window?

There is no attached image.

Hullo and thank you for your suggestion,

I have been using a version 2017 Pro. The equipment is updated completely. Yes, the only elements affected are the thumbs in all trays - materials, components, styles.
Nvidia has been in use - double check in OpenGL section.

I think I have triea all at my side - switching physically the monitor connection, software setting - all in vain.

Indeed there is no image (it has been sent to Su Support via its form).
It presents a blank squares (white background with a tiny black outline) instead of thumbnails representing materials, colors, components, styles etc.).

Since you are using SketchUp 2015 Pro maybe you should update your profile to reflect that.

Did you install SketchUp correctly? That is, did you right click on the installer and choose Run as administrator? If you didn’t, SketchUp is not installed correctly. If you didn’t or can’t remember, do it now and use the Repair option when presented with it. See if that changes anything. Of course you need to close SketchUp before reinstalling it.

Thank you. I will.

I have done a install repair. I will try to reinstall it with admin privileges.
What is quite bizarre SU has been working well after an initial installation till… now.

Be back after reinstalling SU

Wait! Installing with admin privileges is NOT the same as using Run as administrator from the context menu. You must install/reinstall using Run as administrator from your normal log in.

Does the Nvidia control panel see the external monitor. For some obscure reason your computer might be using your Intel chip for the external monitor. How did you connect it? I am especially suspicious of USB docks. Some of them don’t support OpenGL. If you are using one of those you might test connecting the monitor directly.

This is a Dell Workstation Desktop edition. Two monitors are properly connected and well present in nVidia control panel.

As I mentioned when I switch main-second monitor there the thumbs appear and disappear depending on which monitor is set as the primary. Such the thumbs can be displayed correctly on the same monitor if it is set as the primary.

All other pieces of software work well as Sketchup till the certain moment. Alas I cannot recall any special event that could influence the functionality of SU 2017 Pro.

DaveR - I will follow your indication à la lettre. Thanks.


I have done repair install launching the install as administrator. Nothing changed.
I have run a shortcut as admin and SU started a completely new session/workspace as a brand new installed. And even in this case moving a tray to a second monitor makes the thumbs disappeared.

Once starting SU session by clicking the shortcut Su has opened my previous workspace. Same thumbs problem.

I am using a mega-company machine using exceptionally an admin pass. All my activities are performed as a standard user.

Shall I uninstall and reinstall Su instead of repairing it? Shoul all my settings, pluging, etc be preserved in this case?

What could be a culprit while all has functioned well till ‘now’?

Last suggestion for me. Do a cold reboot of your computer. Shut it down completely and turn it on again. Move the tray to the second display first. then quit SketchUp, reboot the machine and start SketchUp again.

I normally leave the tray on the same screen as the rest of the SketchUp window but I moved it over to the second display. No problem with seeing the material thumbnails.

Are the monitors set to the same resolution?

Thank you very much.

All done with no effects at all.
Yes they are set to the same resolution.

It is really very strange…

I have the same Card in a machine I use for work, I remember having isues with the second monitor. I am not sure which version of Nvidia driver ( don’t have acces now) and I have stopped the auto update around may this year.
Do you have multiple drives in your machine ? I remember uninstalling SketchUp from the D: drive to the ‘normal’ C drive had a serious effect.

I have also encountered some issues with an auto update of Microsoft this week which had an effect on certain combinations of internal graphic cards and external Nvidia cards ( Intel 530 )
Here is what solved it :

Try this : remove all Microsoft C++ Visual redistributable libraries version 14’s and install SketchUp again ( run as administrator😄)
Choose repair and it will restore those libraries .

Oh, it seems to be more complex operation.
I will transfer your recommendations to IT Dep.

Hope it will bare fruits.

I have a single drive on my machine - ssd 512TB. It is a brand new Dell Workstation desktop.

What is really strange SU has been working well, with no issue at all. I can say all of sudden I lost all thumbs on a second monitor. No nVidia driver has been updated.

I done an update yesterday, with no results.

Thank you for sharing your experience. At least someone confirms a such problem.

I have been experiencing this same issue for the past few days: material thumbs in the tool box are visible on the main display, but if I move the materials tool box over to the extended area of a second display, the thumbs are gone.

I use both SU8 and SU2014 (the latter more often recently), Windows 7. Main display is on an Acer laptop which I’ve been using for a couple years. Extended display is a 22" Acer monitor. I have had that monitor for several years, and have been using it for extended display for about two years. Resolutions on the two displays are not the same and never have been - I set each so that perspective is not distorted when I am drawing, and that everything will be displayed the same no matter which display I drag something to. I have never had the problem of material thumbs not showing until a few days ago. And while I normally have my tool boxes on the laptop display and the SU screen on the larger extended display, I often move the material tool box back and forth across the two when needed, and have never had this problem. I’ve installed no new programs, added no new peripherals… nothing about my environment has changed other than Windows updates for Windows and Microsoft products.

Don’t know if the following will be of any help to anyone, but here are three other things I’ve noticed since this issue began a few days ago:
1. I have my tool box sized in such a way that there are five thumbs on each row, and three rows visible. In SU8 it is only the first row of thumbs (five thumbs) that displays no materials. In SU2014, it is the first and second rows of thumbs (ten thumbs) that display no materials.
2. If I click on any of the thumbs MIA, they do appear in the preview window and their name appears in the information box - but still not in the respective thumb box
3. If I scroll down thru the material thumbs, the various materials are visible as I scroll down, but when I scroll back toward the top, the thumbs become blank and remain that way until I close or minimize the tool box, or minimize SU, after which, when I reopen/restore, the view returns to what I described in #1 above.

I’m not so sure I understand what @MikeWayzovski has suggested be done to alleviate the problem (looks to be way over my head)… but wanted to at least offer to the OP that he’s not the only one with this issue that has cropped up suddenly. It’s just beyond me why it happens on an extended display but not on a native one.

Good luck, @GTh

Thanks. Same to you.

Very curious situation indeed.
I have already contacted a support (twice). Still no response.

I will certainly share any update to the issue here.

BTW… I realize this thead was for Pro users, but I thought it might be helpful to know the issue is apparently not restricted to just the Pro version(s) of SU.


Here is the support response I have just got. I will proceed on Monday (my workplace) with the recommendation below:

_I apologize for the delay in responding. Our volume has been higher than normal, and we are making massive efforts to whittle it down as quickly and efficiently as we can. _

_ did see you other screenshot from your other case. It looks as though it’s not referencing the program files for SketchUp correctly, and this isn’t a common occurring issue. Please uninstall SketchUp from your computer, and reinstall by visiting

When going through to repair your SU installation following SU support’s instructions, it would be a good idea to also following the tip from @MikeWayzovski to FIRST remove Microsoft Visual Studio C++ 2015 Redistributable from the Add/Remove Programs (SU17 requires VC++ 2015, not VC++ 2014 as mentioned above).

When you reinstalled SU17, its installer examines the computer environment. When the installer detects that VC++ 2015 is missing, it will ping MS and download and install a new version of VC++ 2015.

Dating back to last December, MS released a buggy version of VC++ 2015 and since then, at least one Win10 automatic update did something bad to make VC++2015 buggy. Also, on occasion, the SU installer could not install VC++ 2015. In that case, VC++ 2015 needed to be installed separately by the SU user. See the first post at Important Update on a few Potential SketchUp 2017 issues on Windows.



I have followed all the recommendations - all in vain.
Visual Studio 2015 uninstalled, SU uninstalled and reinstalled. also I have reinstalled Visual Studio 2015 14.0.24 without any effect.

I have not been able to install Visual Studio 2015 14.0.25 update - the installation has been blocked - no solution found.
I have asked the SU support team for any solution - still awaiting it.

@GTh -
On the seperate thread I started re: this same issue, @RLGL suggested repairing the MS VC ++ Red, which I tried w/o any luck. But @catamountain suggested doing a system restore - which I decided to try since it appeared this was something you had not. I had not yet uninstalled any of the MS VC ++ Red’s.

I had to restore all the way back to 04 Aug - I had not to that point uninstalled/re-installed either of the versions of SU that I use. Believe it or not, when I slide the materials toolbox over to the 2nd monitor… all the materials thumbnails were present and accounted for. So for now… all is well.

I do, however, wonder what will happen when the MS VC ++ Red 2015 vs 14.~ is updated again …

1 Like

Thank you SkeychtUppr for your input.
Glad it has been finally working for you.

At my end there is (almost)nothing I can do. I have transmitted the issue to the IT Dep and I will transfer your infos to them as well.

I have been still waiting for the SU support response to the issue. Once received any sign I will share it here.

Once more many thanks for sharing your experience here.

1 Like