Tray Thumbs, Second Monitor, SU2014 (FREE)

Re: No Tray Thumbs on Second Monitor (from the SU Pro forum)

I’ve created another post since the original post was for Pro users and I am not a SU Pro user, nor am I a professional - but I did need a little more help/info. I am using SU8 and SU2014 - both free versions (the OP was using SU 2017 Pro)… and as I mentioned in the other thread, I was experiencing the same issue, in both SU versions, of material thumbs not showing in the materials tool box when the tool box is moved onto a second (extended) display.

After reading all the posts to date on the above mentioned thread, I understand more about where to deal with that MS Visual C ++ 20xx Redistributable. But it led to more questions, especially after @catamountain indicated that “SU17 requires VC++ 2015, not VC++ 2014,” which makes me believe that unless I choose the right program to uninstall, the problem may not be solved.

@MikeWayzovski indicated SU should be installed again after removing all “MS C++ Visual redistributable librariers version 14’s,” but to choose repair which will “restore those libraries.” There are two “14” versions in Programs & Features - so I’m assuming I would uninstall both of them (?).
MSVisC  Redist

However, @GTh’s IT Dept advised him to uninstall, and then re-install SU

@catamountain’s post seems to indicate that certain versions of MS Visual C++ Redistributables are associated with certain versions of SU - there are 12 versions on my computer, including a version 8.0.61001

  1. Should I uninstall ALL versions of MS Visual C++ Redistributable*, or just the version 8.~ and the two 14.~'s since I have SU8 and SU2014?
  2. Should I completely uninstall both versions of SU and then re-install, or
  3. Just do a repair on each?

Thanks for any help on this - the blank thumbs are REALLY getting annoying.

*Just additional [non-SU] info - I noticed just today that when I moved an Apache OpenOffice spreadsheet over to my second monitor, toolbar icons disappeared just as material thumbs do in SU. I’m guessing a similar fix would apply to this situation too. I noticed today when I made the screenshot above that the two 14 versions of the MS Visual C++ Redistributables in Programs & Features were installed on 16 Aug - that is about the time I began noticing these disappearing acts on the second monitor in SU. This makes me think that it is only the two 14 versions causing the issue - a Windows update was my first thought upon stumbling on @GTh’s OP a few days ago - and that need to be uninstalled, but again, I am no techie.

You could have kept posting in the same thread even though you are running SU17 Free.

Did you review the link I added:

The required steps dealing with removing and installing VC++ 2015 for SU17 were outlined in the first post in that above linked thread. Your forum profile indicated you are using SU8. Did you upgrade to 2017? Is SU8 still loaded on your computer and is it working OK?

Do not remove the other versions of VC++. They are required by other programs on your system. When you load some program that requires VC++2012 (for example) that program will expect to find VC++ 2012, it will not know to look for and try using a newer version of VC++ that was not around at the time that program was developed. If you want to try reinstalling other versions of VC++ you have, go to the Windows update site for fresh copies. But do check with what all is available for your machine to download from Windows update and keep track of what you are removing and reinstalling. You can reinstall all those versions of VC++ manually.

I see you have a AMD graphics card. Did you update its driver?

Hello @catamountain… and thanks for replying.

No… I did not check out the link in your post on the other thread because it’s title is “Important Update on a few Potential SU 2017 issues on Windows,” and I do not have SU 2017 - Free or Pro… I am using SU8 and SU2014 - both free versions (the OP on the other thread was using SU 2017 Pro).

Yes, SU8 is working fine - the only issue (in both my versions) is the missing material thumbs in the materials toolbox when the toolbox is moved to a second monitor - same issue @GTh is/was having - which just manifested after a recent Windows update.

According to Windows, the driver is up-to-date.

Before replying, I looked at the post you referenced. Despite that it appears to be intended primarily for users of SU2017, should I assume that the bottom line is to just uninstall the two MS VC++ Red’s that were installed on 16 August no matter what version of SU I have?

Thanks again for your time.

First, regarding the graphic card driver, don’t believe Windows Update. Go directly to AMD site and check there for the latest driver.

Interesting/odd your Win 7 machine is having the same systems as reported by others using Win 10.

As you seemed to have ID’d the specific Windows update, you can check if you can uninstall those naughty VC++ 14 updates through Control Panel > System and Security > Windows Update > View installed updates. The specific VC14++ may be listed unless it was integrated into some other Windows update.

Unfortunately you cannot directly access info about specific Windows updates through the above mentioned Windows Update dialog. You could Google the update number or go directly to Microsoft Update Catalog and look it up there.

At least you still have Win 7 and aren’t forced to automatically update everything Windows suggests. I have opted to monitor all recommended and optional updates via Control Panel > System and Security > Windows Update > Turn automatic updating on or off. There I chose the option to Check for updates but let me choose where to download and install them. When notified of pending updates there’s also the option to look up what all the pending updates include.

Keep track of your troubleshooting uninstalls in case you need to go to Microsoft to download fresh copies of what you removed. MS has released buggy versions of VC++ in the past and patches for the buggy patches on occasion have not been added to the automatic update list.

You also could try downloading a fresh download of the latest version of VC++14 from MS, uninstall VC++14 from your machine and reinstall the fresh VC++14 patch. For good measure, reboot before reinstalling.

Several of the later versions of C+++ have a “modify” button that will lead to an option to enable a repair. Possibly saving removal etc.

1 Like

Another option is to restore your system to an earlier state. Control Panel > System and Security > Backup and Restore > Recover system setting or your computer > System Restore.

1 Like

@RLGL - thank you for your input on this issue. I did try the repair, but it did not resolve the issue.

@catamountain - thank you for your input on this issue. I never did uninstall anything - MS VC ++ Red’s or my versions of SU, and I’m glad I didn’t. I happened to return here to see if there had been anymore posts on this thread and the other thread. @GTh had posted an update indicating that uninstalling and reinstalling the MS VC ++ Red’s and SU did not fix the problem. Because of this info, I decided to try a restore as you suggested.

All is well in the world - for now. Material thumbs are now visible when I slide the toolbox over to the 2nd monitor. However, as I noted for @GTh on the other thread, I can’t help but wonder how long it will last - when that MS VC ++ Red is updated again, the problem may return.

Anyway… for now, I will mark my thread as solved, but will keep an eye on my versions of SU, the MS VC++ Red’s and @GTh’s thread.

UPDATE -

@RLGL
@catamountain
@GTh /@GThib

Right after restoring my computer back to a point to rid my system of the Windows Updates on 16 August, notice of two updates immediately appeared - I’ve been putting them off since the system restore. You can see those updates in the image below
Windows Updates
Today, I got notice of the update, “Security Update for MS V C++ 2010 SP1 Red Package.” (Above)

I took a chance and allowed the updates - all three of them, hoping that MS, in all of it’s glorious benevolence (or blissful ignorance), fixed whatever it was causing the issue with the missing materials thumbs in the materials toolbox when the toolbox is moved to a second display.

So far, so good - no missing material thumbs.

@GTh - I hope this latest information may also be helpful to you if you are still dealing with the issue.
Image3

I do thank you very much SketchrUppr,

It is very kind of you, I will transfer your precious information to the IT dep. I have already notified them of the issue. Alas it takes ages they react.

Once more many thanks.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.