Default tray for SU2019 is missing

The window default tray dialog says “hide tray” which I assume means it thinks it is showing, but I can’t find it anywhere. It doesnt seem to be hiding off screen. It used to show but now it doesn’t appear. I am using a windows 10 computer.
Thanks

Go to Window>Preferences>Workspace and click on Reset Workspace. Does that help?

Actually. clicking on preferences is locking up SU

That would imply that the Preferences panel is also opening off screen. Does hitting Enter free up SketchUp again? If so, try opening Preferences again. Then, while it is active, press alt and space together, them m, then tap any arrow key and finally, without clicking, move the mouse around until the dialog appears.

Enter does free SU, however, whenever I click Preferences to open it SU locks up again.

That is certainly evidence that the Preferences panel is opening off screen. Did you try what I suggested above while the Preferences panel is opened?

So far I can never get the Preferences panel open to try what you suggested. And all the SU icons all go gray.

You’re missing the point. Select Preferences in the Window menu. Then follow the steps above to bring it back onto your screen.

Ah Ha!! Ok , I got the Preference panel from off screen. Should it come up normally now?

I expect it will. Did you try resetting the workspace, then?

Are you really still using SketchUp 7? Please complete your forum profile.

It seems to. What about the Default Tray?

No 2019

Not 2020

Sorry. I meant Windows 7.

You’re using SketchUp 2019? The title of your thread says SU2020.

Did you try resetting the workspace now that you have Preferences displaying on screen?

I meant to say 2019. Yes I reset the workspace and the default tray came up.

Thank You.
I will have to write this one down.

Do you have multiple monitors? Unplug one and see what pops up.

I edited the title of the thread.

And are you using Windows 7 or Windows 10?

At least now you have the tray displayed.

Windows 10 on this computer. At work, another computer, I still have windows 7

So just for good measure, Quit SketchUp and find the downloaded installer. Or get the latest 2019 installer from sketchup.com/download/all Right click on the installer and choose Run as administrator from the context menu. Then if prompted, select the Repair option.

And please update/complete your profile. That information helps us help you.

I won’t lose any of my extensions?