Layout 2018 can't export PDF error "There was a problem exporting to this file"

export

#1

I have been a SketchUp Pro user for 5+ years and have never had significant problems that couldn’t be resolved looking at online forums. Since upgrading to SketchUp Pro 2018 I have been unable to export my Layout documents as a PDF. I get an error stating “There was a problem exporting to this file.” and that is all. I logged a ticket with Pro support and have since spent time detailing the problem, only got one line answers and nothing of any substance or value.

Even if I just open up layout, draw a circle, have no links to SketchUp models, and try to export as a PDF, I get the same error.

Has anyone else had this issue with SketchUp 2018? I’ve run 2017 and 2016 on this same notebook computer and had no issues. The attached PDF (not created in layout…) details the steps that I’ve taken, with screen shots, and the error messages received. Any thoughts or ideas would be welcome and very much appreciated.

2017-12-23 - Layout Error - There was a problem exporting this file.pdf (981.5 KB)


Layout (SU Pro 2016) will not convert files to PDF
#2

It looks like the problem is the ampersand in the file path. It does not appear in the error message as if it has been stripped from the path and can’t save as the altered path doesn’t exist.

Try saving it to a different directory that doesn’t contain ‘&’

Edit:
I missed this part
“ I have tried exporting to a basic folder path like C:\Users\Public\Temporary\Trial.pdf
and it also gave the same error”
If it gives the error for that exact path and you have permission to write there then I don’t know.


#3

I have tried to save to a few folder paths that I do have permission to write to, such as the one listed, SketchUp Pro support suggested I remove the ampersand, which I did, and the error still remained. Thanks for your thoughts anyway, much appreciated.


#4

If you have a a file open in your PDF program with the same name it wont let you overwrite it.
simply close the PDF in your viewer program and try again. works every time.


#5

Hi Daniel,
I have the same problem. At the moment I print to PDF. but export was always easier. Have you solved the issue yet?


#6

Unfortunately no solution yet. I also use Print to PDF for a work around, though it doesn’t give me all the resolution, compression and layering options, so it is just a stop-gap. I have sketchup installed on another very low spec computer, and it exports to PDF fine, though I have no idea why.

Most recent response from SketchUp Pro support said they’d “write to their QA team letting them know about the export issue” though that was a month ago so I suspect they’ve just closed the ticket.


#7

I just tried to export a file from Layout 2017 with the same result. The last successful export I can find was around 17th Nov 2017 & that was on Layout 2018. I’m thinking it might be caused by something like a windows update. Do you think it might be worth doing a windows recovery to before that date?


#8

I too tried Layout 2017 and got the same result, whereas I’d previously been able to export to PDF from 2017. I suspect it is an update to the graphics driver or perhaps computer BIOS rather than windows, as I think that if it were a windows 10 update, this would be a widespread problem that a lot of people would be reporting. The lack of an error code and the lack of response or progress from Sketchup Pro Support suggests to me that they’ve closed the ticket/lost interest. I think the chance of me getting any progress on this one is unfortunately pretty slim.


#9

I expect it’s more likely a case of they haven’t been able to duplicate your problem and with so little to go on at this stage, they are hoping to get more reports with more useful information to help track down the issue.

Is it possible that SketchUp and LayOut weren’t installed correctly by using Run as administrator after right clicking on the installer file? Other people have reported weird stuff after they installed by double clicking on the installer instead of right clicking and selecting Run as administrator. Certainly at this point you’ve got nothing to lose by trying to repair the installation with that option.


Layout 2018 upgrade install and export issues
Layout 2018 export error - there was a problem exporting to this file
#10

I agree Dave, they’re possibly unable to duplicate it, “lost interest” was poor choice of words. I do suspect that the ticket has been closed as it has been over a month since the last contact when I was told that the technician that I was talking too would let the QA team know about the export issue that we’d run into again after the re-install.

Without an error code, or the ability to run an action log to give them information about what is happening on my computer, it would appear to be an uphill battle.

I have uninstalled and re-installed both programs as an administrator and had a couple of screen share sessions with Pro Support to ensure it was done the way SketchUp would recommend, though the outcome was the same and the issue persists.


#11

Hi Daniel,
I have the same issue for a month or so, have you found a solution to this yet? I’ve tried lots of re-installs with admin rights etc but have had no joy in getting this sorted. The issue just started without warning. I’ve not installed any new plugins or changed anything on my system to make it start.
Interested to know if you have had any success or contact with anyone from Sketchup.
Thanks
Sam


#12

Hi DaveR,
I’ve been looking for a solution to this issue too. I’ve posted on a couple of different threads and have started my own here too as I wasn’t sure whether this thread was still active.

I have tried all the suggestions that I could find from trawling around on the web but none of them have resolved the issue. Do you or anyone else at SU have any further suggestions for how to resolve this - I’ve had the issue for several months and first posted on another thread back in December. The solution to @ArtWorks export issue seemed to be a high poly object but I can’t even export a totally blank document (from a generic LO template) from a completely fresh (run as admin) install.

It doesn’t sound like @daniel.fisher’s contact with the support team has revealed a solution,

“the outcome was the same and the issue persists”

but I like him (and I’m sure others) am very keen to find a fix. I’ve wasted a lot of time uninstalling and reinstalling, resetting up my workspace etc only to find that the error is still there. Some help or feedback from the SU team would be good.

Many thanks

Sam


#13

Hi Sam,

Unfortunately there has been no progress or resolution from my end. I requested an progress update from Pro Support about a month ago, and they’d requested I do another round of tests and sample trials. I did these, sent through the requested files and have had no response for almost 4 weeks, so I’m not anticipating that anything will come of this and won’t be following up with them again. My current plan is to just stick with the current version, keep exporting using a second computer, and whenever I upgrade my main laptop to a new unit, possibly consider re-subscribing to the latest pro version of sketchup.

I’ll be sure to post if the situation changes and there is any progress.

Dan


#14

I have had this happen as well (LO 2018), however in my case it was due to having Dropbox “open” (logged in) while trying to export to .pdf.

Charlie


#15

I know its not the answer you are looking for but I had this problem many moons ago with LO ver6Pro. Found no fix. Gave up… now use cute writer free pdf. Have had no problems since and no quality issues.


#16

I have the same problem with Layout 2018. I’ve submitted a ticket. Has this issue not yet been resolved…?


#17

I wonder what is different about our systems. I haven’t had any problems exporting to PDF from LO 2018. In fact I’ve exported PDFs four different projects just in the last few minutes. None of them had any problems.

The only time I see that sort of message is if I already have a file with the same name open in Reader but that makes sense because I’m asking it to overwrite a file that is in use. Closing the file in Reader takes care of the problem.


#18

I wonder too. Running Windows 10 with latest updates and drivers. I just installed CutePDF writer and was able to create a pdf by printing to it. I would prefer to be able to export directly from LO2018.


#19

Hi ValinHawK, from my end the issue has not been resolved and I haven’t had any feedback from ProSupport for over a month. I haven’t been officially informed, though I suspect that my support ticket has been closed. I’ve tried to prod for an update a few times, but seem to just get emails asking me to repeat past actions, ie. update drivers, send screen shots, then get no response.

My current plan is to just stick with the current version, keep exporting using a second computer to export PDFs, and whenever I upgrade my main laptop to a new unit, possibly consider re-subscribing to the latest pro version of SketchUp.

I’ll be sure to post if the situation changes and there is any progress.

Dan


#20

Thanks Daniel. Not sure that updating to the latest Pro version will solve the problem for you because that’s what I’m running – Sketchup/Layout Pro 2018.