Layout (SU Pro 2016) will not convert files to PDF

Upon reinstalling SU Pro 2016, Layout still refuses to convert files to PDF. Help!


Can you export to PDF from within SketchUp?

Which method are you using to export? File > Print > 2D Graphic or File > Print > Print to PDF?

Also, do you get an error when attempting to export?

Also Ref OP’s thread from last Sept.:

While in Layout, File>Print>Print to PDF… I get an error. What’s interesting, is that while on my laptop (with SU Pro 2016) I can print to PDF just fine with Layout.

The discussion I had with Dave R. did not result in a solution.

What is the error message?

“There was a problem exporting to this file.”

Anybody know what triggers this message, and/or know what settings to check?

Its a long shot but I had a similar issue on a windows machine (happened in both windows 10 and 7) - not used Layout on a Mac for a while so don’t know if the problem is present on Mac OS. I generally use File>Export PDF method so this may not be the same issue but its worth a try…

I found that if I had already exported a PDF from layout and had the PDF selected (but not open) in a file explorer window (as per the alien image below) then when I went to try to re-export the PDF I got an error message like the one you posted. If you try closing all your file explorer windows and re-export from Layout (with no file explorer windows or the PDF open) then you may find that it will export.

For me the issue seemed to be something to do with the preview pane. If you have preview or details pane on (both of which make a preview picture show up when you select a file) and the file selected then windows wont over-save the file. You can see the alien being previewed because its selected (but not open) in the image below. Annoyingly there seems to be a memory of the preview having been open which means that even if you click off the PDF (so its not selected / previewed) in file explorer but don’t close the file explorer window, the PC still remembers that the file has been open in the preview pane, and wont save over it.

Actually having the PDF open and trying to over-save gives you a different error message; you only need to have (or have had) the file highlighted (as the Alien_Brink.jpg below) with the preview pane on for windows not to allow you to over-save.

As I said it may be something completely different but this could be worth a try. In short, when you get the error message, close all you file explorer windows and have another go and exporting / printing the PDF. You can also try selecting a different PDF / file in the same folder (which will generate a different preview) and see what happens when you re-export…

Good luck, hope you get it sorted.

1 Like

That’s not it… I can’t export a PDF file in the first place.

To be clear, you can’t print and Save as PDF (an Apple mechanism) and you can’t File->Export-> and select PDF export and have it be successful, correct? 2 completely different paths. The print will take a screen shot, similar to zooming to full page and doing cmd-ctrl-shift-3, selecting that page, and pasting into, then File->Export as PDF. The LayOut method will recognize vector renderings as such.

I’m not sure I’m following you… I have my Layout file open, when I try to export a page as a PDF, it will not convert.

There are two completely different ways of exporting to PDF in LayOut on Mac.

Method 1, and the preferred method (so you get vector), is to use File->Export… and pick PDF as your format, set your options for Output Resolution and JPEG image compression, etc…

Method 2 is Apple’s built-in method for EVERY Mac application via File->Print… and now you’re in an Apple System menu, and you can select PDF (lower left on print panel) and say “Save as PDF”. EVERY application on Mac has this, because the screen & printing model work together, (and Barry stops before stepping onto his historical soapbox). This has nothing to do with LayOut. Every application on Mac can do this. I can write an app in 10 seconds that can print to PDF.

So which method are you exporting by? If it’s method 1, we can work to try to figure out why it’s not working. If it’s method 2, go to an Apple Store and ask a genius. And try other apps before you do… e.g. - drag a picture into TextEdit and try to save as pdf and see what you get.

Method 1, and I am using a PC. No Mac for me.

Oh sheez, sorry, afraid I’m conflating 2 different threads, and my brain must have hit it’s thread limit. OK, on PC: have you tried compressing jpg’s and setting resolution to Low?

Just tried that, no go.

Hi Lemke, I am able to see the same error you are seeing when I export to pdf if a file with the same name is open by a pdf viewer.

Could this be what is happening in this situation?


Or… could it be that this pdf linked as a reference to another cad program and that other program happens to be open at the time of export?

In Windows, even keeping open the Preview pane in Windows Explorer seems to generate “file is in use” type errors.


There is nothing else open when this error message occurs… I usually only have SU and LO open.