2021 Layout PDF Export. 'There was a problem exporting to this file'

Has this bug been sorted yet?
Perhaps its because there isnt any way of assigning the PDF output, it just defaults to the OS printer settings? So, as I am working on a sheet of A2 then that size is not recognised and I get the error. All seems a bit dim and limited.

This comment will be of little use to you…Mac users don’t have to face this issue as macOS has this built in functionality that all apps utilize.

Since the update (today) of SU 2021 to the newest update (21.1.299) I now have this problem… never an issue before. I can’t export any LO file - even files that worked fine for me previously. I have tried saving PDFs to various destinations (including desktop, one drive, external disk etc) nothing works… SU seem to have screwed the programme that my business is relliant on!!!.. HELP

also screwed on my desktop as well as laptop…

Well I was half right about the defaults. Setting up to print to a PDF allowed other paper sizes to show up, and I thought yay its fixed… but no, still not working

This seems to be related to something other than just the LayOut version. I’ve not had any problems exporting to PDF on my computers with any version of SketchUp/LayOut. I am currently using the latest release of 2021 (21.1.299).

@DaveR I too have not been able to export to PDF, and only PDF. This wasn’t the case with the first file I exported a few weeks ago but certainly is now, also using ver21.1.299. I am new to the program so can’t guarantee that the fault is not mine with something I may have done to my file, but I had previously had it working… Sorry I would upload the file, however, it’s proving too much for my substandard NBN connection in the after school part of the day. Perhaps tomorrow.

I just updated SketchUp/LayOut to 21.1.299 and when I export to PDF in LayOut, it messes up some of my text bullets… The first image is what it looks like in LayOut and the second is the PDF it creates.
I created a PDF last week that was fine, but realized I had to make a change in LayOut. since then, I have updated SketchUp/LayOut and now this is what happens to my bullets that weren’t changed. It also happened to some of the numbers as shown here.

1 Like

@paul.mcalenan This is why I usually wait several weeks before updating ANY software. I was weak this time, and got sucked in.

Is there a workaround?
I need to export this project NOW!

If you have a PDF printer installed on you machine (there should be the Microsoft one) then do print to PDF instead - just make sure you set the settings to your requirements, e.g. paper size.

I have not been able to find a way to get larger than A3 out of the Microsoft PDF printer.

I use PrimoPDF.

Thank you, will try that.

I am also having this problem (using 2020), this is really creating costly delays in my professional work. Without updating to subscription (despise that by the way) is there any way I can fix this bug? Sketchup/Layout is my favorite work tool, but I’m feeling stuck. Printing to PDF doesn’t have the same quality, especially with transparency features.

Many people have found some corrupted Layout entities that cause the export to fail by first removing pages one by one until it starts working, and then deleting things one by one from the culprit page thus identified.

Have you gone through the advanced print settings of your PDF printer? Some of them default to raster printing at a low resolution. Also set your output quality to high in the Document setup.

1 Like

I had a weird letter (I used a separate “C” and “L” to make a quick Center Line notation) that when selected, it had a very large selection box off to one corner below it. It was located off the page, I ended up deleting everything off the page (my old version of Scrapbook before I knew about Scrapbook feature) and my Layout file successfully exported to PDF.
So thanks Anssi for this tip!

It has to do with the type font you are using on your layout pages, use only common know fonts. I t will solve the problem. Xiao

I also had a problem: “There was a problem exporting to this file”

the following helped:

if there is a Sketchup object on the Layout sheet with vector or hybrid graphics display and orthogonality enabled, and the corresponding scene in SU has visible dimensions perpendicular to the view display plane.
I removed the visibility of the dimensions perpendicular to the view of the display and everything worked, the export to PDF turned out.