Export to PDF from layout issues

I keep getting the following error when trying to export a PDF from LayOut. I’ve been exporting to PDF this exact same way previously without any issues. File > Export>PDF. When I printed to PDF instead I ended up with a 47MB file which was way to large to email. (the LO file is only 29MB) I exported to PDF from this same file last week and the PDF was 5MB.

I don’t know what changed that is causing this issue.

Any suggestions are greatly appreciated! thank you.

Is there a copy of the PDF file already open?

I see that message when I’ve exported a PDF from the file and it’s open in Acrobat and I try to export from LO again after I’ve made a change to the file. Closing Acrobat takes care of it.

Ik heb het zelfde probleem bij het exporteren van Lay Out naar PDF krijg ik de zelfde tekst als hierboven.
Ik heb nu Sketch Up en lay out 2020, maar nog steds het zelfde probleem. A4 en A3 formaat kan ik nog oplossen door af te drukken naar PDF, maar grotere formaten lukt mij niet. Wie kan mij helpen dit op te lossen?

We had a customer contact use with this same issue, only he had isolated what it was in the document that caused the error. I made another file that only has that element in it, and was able to add a 6kb sample file to the existing bug report.

I don’t even know what the element is, it’s a bit like hidden geometry in SketchUp. Here is my example file, look at it, notice how you see nothing, try exporting to see the error, then do a Select All. When you do that you will see the object. What is it?

dashedline.layout (6.3 KB)

@colin , we had this same problem a while ago. Your example file contains a corrupted Linear Dimension. Specifically, many of the numerical values defining the linear dimension are NANs (That is Not-A-Number). I can only guess how this corruption is happening, but wont.

Here’s some of the data from inside the layout file.

<e:rectangleBase x="-nan(ind)" y="nan" width="nan" height="nan">

<e:affineTransform m11="-nan(ind)" m12="-nan(ind)" m21="nan" m22="nan" tx="-nan(ind)" ty="nan" />

 <e:extensionLine1 id="id51" rotationAngle="0" requiresStrokeOrFill="1">
    ...
       <e:entity />
    ...
            <e:points2f>2.800428,2.166553,-nan(ind),-nan(ind)</e:points2f>
    ...
  </e:extensionLine1>

And a link back to the previous topic

Thanks for that. I will talk to the QA person who owns this bug.

This is happening in Sketchup 2020 now with one of our files. We had to save the Layout file back to 2019 and the export to PDF worked again.

I just received this error for the first time. Saved down to 2019 Layout and it worked but I had never experienced this prior to today and it was not due to having the file already open. Let me know if you need my files to help fix the issue. Thank you

I assume this means you are using SketchUp/LayOut 2020. Correct? Out of curiosity, when you installed SketchUp 2020 did you right click on the downloaded installer and select Run as administrator from the context menu?

Yes I am using 2020 during this process. Its not likely that I ran as administrator when installing.

Correct installation of SketchUp/LayOut on Windows 10 requires that you right click on the downloaded installer and select Run as administrator. Before doing anything else, I would suggest that you close SketchUp and LayOut. Then go to the downloaded installer file, right click on it and choose Run as administrator. When the options appear, choose Repair. After SketchUp and LayOut are correctly installed, try the export again and see if there’s a change.

I think I had already set my permissions to open as admin by default on executables as I have the windows admin icon in the bottom right of the install icon. Nevertheless I did as you suggested and opened the installation as admin and repaired and tested the export to PDF again. Unfortunately the issue still persists and it simply gives me an error message stating that there was a problem exporting to the file. I appreciate the help in suggestions though !