Problem exporting to this file - Layout 2018

I cannot seem to export to PDF- I have never had this issue before.
SU & LO 2018
Thanks
Balkin Trusses 2020-03-26.layout (5.8 MB)
Jill
image

It works ok here in 2020 and 2018. Your file path looks ok, but try a different filename or folder. Maybe the file already exists and you’ve got it open in another program or something?
Balkin Trusses 2020-03-26.pdf (4.9 MB)

Darn,
I’ve tried both those things. It is not open elsewhere.

On the page named T4 there are a bunch of faulty Linear Dimension objects. See the solution in this thread.

Also I’ve tried to fix the file manually. Here it is:
repaired.layout (5.8 MB)

I did delete the T4 Page and start again,

Can you explain how you knew the dimensions were faulty?

Thanks!

JD17,
To answer you question, a layout file is just a zip file. Unzip the layout file and search through the folders looking for numerical data that is shown as ‘nan’ (Not-A-Number).

For example, inside the layout file you’ll find a file named page162.xml with the following data.

<e:extensionLine2 id="id313" rotationAngle="0" requiresStrokeOrFill="1">
	<e:graphicEntity shouldFill="0" strokeColor="4282335039" strokeWidth="0.5" strokeCapStyle="2">
		<e:entity />
	</e:graphicEntity>
	<e:elements>0,1</e:elements>
	<e:points2f>-nan(ind),-nan(ind),-nan(ind),-nan(ind)</e:points2f>
	<e:arrowData startArrowType="0" startArrowSize="5" endArrowType="16" endArrowSize="5" />
</e:extensionLine2>

Do you by any chance remember what you had done before this error popped up? I don’t think anyone has figured out how to cause this error to occur.