Layout 2018 can't export PDF error "There was a problem exporting to this file"

I would love to but I don’t know how to setup dropbox. Possible to email it to you?

Major kudos to sWilliams who solved my problem. He is a miracle worker. Culprit was a faulty linear dimension. He repaired my file and all is well with the world. Thanks again sWilliams.

1 Like

It would be nice to know how to determine which dimension is faulty!

@BeccaC I feel your frustration!!!

However, as @adeshgupta1996 pointed out just a few posts above yours, there is a work around. You can just use the FILE>PRINT>PRINT PDF instead of EXPORT to PDF. If you don’t have acrobat then you may need to install a different PDF writer, there are some mentioned in the thread above.

I’ve given up on there being a fix for this. Im one of the original posters and have been looking for a solution for nearly 2 years now (first had this issue in november 2017!) - which is ridiculous!

As @chaz_plan says, the PDF quality using PRINT PDF is not as good as EXPORT but after hours poured into this thread looking for a solution, I have just accepted the drop in quality / flexibility and have had to ignore my preference for using the EXPORT method. I just PRINT to PDF and save myself the bother of waiting for a solution. That said @SketchUp3D_de has recommended a possible solution but I haven’t had time to try it out yet - if anyone else has time to try it and update this thread that would be great.

The issue with dimensions that you seem to have is similar but not the same as mine - I can’t EXPORT any PDF’s, even from a totally blank file with nothing in it. Does it do the same for you?

Given my experience with this, I wouldn’t hold your breath waiting for a solution. Just get PRINT PDF working and save yourself some frustration.

Hope you are at least able to use the PRINT function…

Sorry to say there are a few of us that are plagued with this issue, like Samyell I have tried all sorts and I opened a post in late 2017 too but this thread is the most detailed. A very few of us can no longer use the in built pdf export function even with blank documents and we are seasoned users too. There are only 3 real soultion as such: 1) complete reinstal of windows (but as I found out it may last for only a year before you need to do it all over), 2) get another pc or laptop (my laptop work fine with exporting but its tiresome swapping around) 3) give up and use another external print option using Adobe, Primo print etc as outlined above. We cannot find the glitch that trips it out and Trimble cannot either. We have all been waiting… and sketchup 2019 still produces the error, if you go backwards and use an older version ie Sketchup 2017 it still prevails so something must get overwritten.

Sounds like this won’t solve everyone’s problem since some of you can’t export blank files.
These are the instructions sWilliams gave me.

“A layout file is just a renamed zip file. To open and look inside:
Rename yourfilename.layout to yourfilename.zip
Unzip yourfilename.zip into a folder of it’s own
Browse inside to the folder named pages
The problem was in the file named page63.xml
On line 640 of that file you will find the start of the definition for a Linear Dimension”

Hope this helps some of you. Becca

2 Likes

I have pulled my hair out with this on numerous occasions. I have finally found a solution! It seems to be a corrupt object in the file. It is a tiny object and blank so cant be seen. but to find it move each object box (check all objects in groups) until you find highlighted a box of nothingness and then delete the little blighter. This has worked on every file I had that wouldnt export. Hope it helps you.

2 Likes

Lucky work around for you, not for me though! - sadly some of us cannot resolve it weve been on it 2 years no result apart form print to pdf or reinstall windows.

Not fully sure if it’s the same thing, but I had a customer case where I reduced the problems exporting to PDF down to a single character in one text object. I will be getting someone to check that out.

1 Like

I tried this and found that it worked for me. I had to figure out which page was causing the issue by exporting each page individually. When I found the page I did ctrl A to find the ghost file. Once the ghost file was deleted it exported to a pdf just fine.

2 Likes

First time I’ve had the same issue with exporting to .pdf “there was a problem exporting this file”
I had no issues 4-6 weeks ago when exporting.
Then Friday (Dec 27th), under deadline of course, I can’t get anything to export to PDF. from layout.
I tried old projects that I had previously been able to export, I tried a new blank sheet, I tried different paper sizes and resolutions.
I tried updating SU, version 19.3.253 was available. After researching in the forums, I reinstalled with administrator privileges, still nothing. Has anyone come up with a solution?

The only thing that has changed recently for me is windows 10 1909 update on 12/12/2019.

Posting in one thread on the topic is enough.

Got it, just want to make sure people see it

Had the same issue with exporting to PDF. Worked great (for years) … and then one day it didn’t.
As far as I can tell ryant & darling_i2000 have it right. I was able to determine which page was causing the issue by exporting each page individually. After I found the problem page I was able to use ctrl A to show everything on the page … and sure enough there was one “ghost” on the page. I think it was perhaps left over from a dimension that I had revised … albeit sloppily. Regardless, once the “ghost” was removed Layout once again exported to PDF just fine. Thank you ryant & darling_i2000!

1 Like

Egodsey,

Glad this worked for you. I haven’t had this issue since so hoping it was a one time occurance.

1 Like

I’ve been a paying Pro user for quite some time and just experienced this problem where LO would not export a PDF. I combed through this thread and considered the issue may have come from a recent windows update (one or two days ago) but I had been exporting PDFs since the update with no issue…even on the same day I experienced my first problem.

I did see one post that caught my eye where the issue was resolved by converting an image over to a .jpg which reminded me I recently updated our company logo on the header from a .jpg to a .tif file. Once I converted the new logo over to a .jpg, I’m able to export PDFs again.

I will note that when first I updated LO with my new .tif logo I was still able to export a handful of PDFs before the error began…so that’s weird.

This doesn’t seem to be the end-all solution since some are trying to export blank pages and are still unsuccessful, but hopefully this provides more info towards a final fix.

Using SU & LO '19.
LO version 19.0.685 (64-bit)

Interesting.

Do you see the same thing with .tiff files if you update to the latest SU/LO 2019? (2019.3.xxxx) What about with 2020?

What operating system are you using? Please complete your profile.

Just a thought: Is your tif logo saved using the CMYK colour space? SketchUp only supports RGB, I don’t actually know about LayOut.

For a logo, I would prefer PNG instead of JPG.

1 Like

SU uses FreeImage and converts CMYK plus Alpha to RGBA automatically…

on export it would be rgba.tiff or rgba.png dependant on original format…

.tiff vs .tif could be the issue…

john

I ran into this problem for the first time in the last couple of days. I have been a Pro user for years and always have the latest version. I’m an architect and I tend to use previous projects to create new ones so I don’t have to create each drawing from scratch. The file that wouldn’t print was a floor plan with lots of stuff temporarily hanging out off the page. As I am on a tight deadline on this project I was pretty frustrated when this happened. I was finally able to solve this problem for me. I had read that someone had issues with ampersands, I believe, anyway that is what I remembered. I had one of those and a couple of other special characters added into a couple of dimension. So I turned off that layer and tried to export to PDF again. Sure enough, it exported just fine. So I created another dimension layer and started changing the layer of the dimensions, then I would turn off the dims layer that was causing the problem and export again. Finally, I had exported all of the dimensions to the new dimensions layer. It still would not export to PDF with the old dims layer turned on but when it was off it exported just fine. I tried a Ctrl A to select everything and there was nothing on the layer that I could see. I could only zoom out to a certain point, so I can’t say there isn’t something way off the page. I’m hoping this helps the SU team resolve this issue for everyone. I’d be glad to share the file with the SU team if they want it.

1 Like