Layout 2018 can't export PDF error "There was a problem exporting to this file"

I have had the problem for 19 months and have just given up on there being a solution. It seems that Trimble can’t replicate the problem and as a result its very hard to find a solution. The issue for me occurs eve with a blank file from a native LO template. I open a blank A3 or A4 template, go to export PDF and get the error - there is literally nothing in the file (no text boxes, dimensions, lines, views etc) other than what Trimble programmed it to have…

I do the same as @adeshgupta1996 and have just stopped using EXPORT PDF altogether and use PRINT > PRINT PDF instead now.

according to the properties of the used PDF library “pdflib.dll” from the SU program directory the library is made by the company ‘PDFlib GmbH’ from Germany.

The library of SUP 19.2 is of version 9.0.2.0 from December 2018 whereas the recent version is 9.2.0.0 from February 2019. Fortunately they do provide downloads of their latest version which seems to work without a demo watermark if used in conjunction with a valid license key provided from the calling application (i.e. SUP).

Downloading the ‘C, C++’ x64 package allows to extract the latest lib version from the sub-directory “\pdflib” to the SketchUp program directory (typically “C:\Program Files\SketchUp\SketchUp 2019\”). Do rename the original lib from “pdflib.dll” to e.g. “pdflib.org.dll” before doing this.

Thanks @SketchUp3D_de - I’ll try this when I get some time…

@chaz_plan - perhaps you can give it a go too as you and I have both had the same issue?

Hi Sam, seems like the issue is still with some of us, like you I gave up EXPORT PDF althogether and used PRINT > PRINT PDF but after a number of months have to say the export is not as good as the one built into layout so outputs are not as good, are yours better/same/worse than layout output pdf (when it worked of course!). Interesting post by @SketchUp3D regarding pdf properties…I applaud his research and knowledge on this, - sounds more like where we should be going but I think its more in something being overwritten or directed elsewhere that produces the issue. I can use exactly the same version and download on my laptop and pdf export within layout works fine.
Like your post from 2 days ago I cannot emphasise enough a simple blank document can give the same result so it is not the file you are using its in the program, and I have had it for 19 months or more and after upgrading Win 10 as well as other programs.
I will give the pdf upgrade a go when I have time like you, upgrading to 2019 sounds like the issue will continue too:frowning_face:

Cool! I have a model where I found out that the problem was in a dimension entity inside my sketchup model.
Deleting it solved the issue. How can I get access to these parameters on the entity so I can check if the problem was the same as @Ninjoe ? Meaning, an undefined value in the entity itself

Perhaps we can find a track to a solution in this direction.

Hello @sWilliams!
As asked, the file is in the link below! Can’t post it here. Seems to be too big.

At least in my computer, the bug happens. Deleting the lower left viewport (the one with the section cut) solves the issue. In fact, digging deeper, deleting some dimensions inside this viewport solves the problem. The dimensions are not visible in the view cause the section is on ortho mode on and it is perpendicular to the point of view. They are not hidden, just invisible due to the angle we are looking at them.

Don’t know if you need the skp file as well. Let me know if so.
Sorry for the
Glad to help.

Thanks,

Felipe

I just spent a month learning how to use SketchUp. On Saturday, I converted to the paid version of SketchUp Pro (and yes I did the admin repair) and I just received “There was a problem exporting to this file”. Not happy at all. I’m not ashamed to say I actually cried reading the above thread. How can there not be a fix for this!! I have been exporting my work at least 15 times over the last month without any problems. Last night I exported different pages without any problems. The scene that fails the export is heavy with dimensions. I am able to export the scene WITHOUT dimensions. I also exported this scene before with dimensions (I added toilets and sinks and more dimensions this go around) with the free version using the same template that is failing. I should note that the dimensions have been added inside Layout not SketchUp. Any ideas would be greatly appreciated. Thank you in advance.

@BeccaC If you’ll upload your layout file to a service like Dropbox and send me a link, I’ll check it for obvious problems.

1 Like

I would love to but I don’t know how to setup dropbox. Possible to email it to you?

Major kudos to sWilliams who solved my problem. He is a miracle worker. Culprit was a faulty linear dimension. He repaired my file and all is well with the world. Thanks again sWilliams.

1 Like

It would be nice to know how to determine which dimension is faulty!

@BeccaC I feel your frustration!!!

However, as @adeshgupta1996 pointed out just a few posts above yours, there is a work around. You can just use the FILE>PRINT>PRINT PDF instead of EXPORT to PDF. If you don’t have acrobat then you may need to install a different PDF writer, there are some mentioned in the thread above.

I’ve given up on there being a fix for this. Im one of the original posters and have been looking for a solution for nearly 2 years now (first had this issue in november 2017!) - which is ridiculous!

As @chaz_plan says, the PDF quality using PRINT PDF is not as good as EXPORT but after hours poured into this thread looking for a solution, I have just accepted the drop in quality / flexibility and have had to ignore my preference for using the EXPORT method. I just PRINT to PDF and save myself the bother of waiting for a solution. That said @SketchUp3D_de has recommended a possible solution but I haven’t had time to try it out yet - if anyone else has time to try it and update this thread that would be great.

The issue with dimensions that you seem to have is similar but not the same as mine - I can’t EXPORT any PDF’s, even from a totally blank file with nothing in it. Does it do the same for you?

Given my experience with this, I wouldn’t hold your breath waiting for a solution. Just get PRINT PDF working and save yourself some frustration.

Hope you are at least able to use the PRINT function…

Sorry to say there are a few of us that are plagued with this issue, like Samyell I have tried all sorts and I opened a post in late 2017 too but this thread is the most detailed. A very few of us can no longer use the in built pdf export function even with blank documents and we are seasoned users too. There are only 3 real soultion as such: 1) complete reinstal of windows (but as I found out it may last for only a year before you need to do it all over), 2) get another pc or laptop (my laptop work fine with exporting but its tiresome swapping around) 3) give up and use another external print option using Adobe, Primo print etc as outlined above. We cannot find the glitch that trips it out and Trimble cannot either. We have all been waiting… and sketchup 2019 still produces the error, if you go backwards and use an older version ie Sketchup 2017 it still prevails so something must get overwritten.

Sounds like this won’t solve everyone’s problem since some of you can’t export blank files.
These are the instructions sWilliams gave me.

“A layout file is just a renamed zip file. To open and look inside:
Rename yourfilename.layout to yourfilename.zip
Unzip yourfilename.zip into a folder of it’s own
Browse inside to the folder named pages
The problem was in the file named page63.xml
On line 640 of that file you will find the start of the definition for a Linear Dimension”

Hope this helps some of you. Becca

2 Likes

I have pulled my hair out with this on numerous occasions. I have finally found a solution! It seems to be a corrupt object in the file. It is a tiny object and blank so cant be seen. but to find it move each object box (check all objects in groups) until you find highlighted a box of nothingness and then delete the little blighter. This has worked on every file I had that wouldnt export. Hope it helps you.

1 Like

Lucky work around for you, not for me though! - sadly some of us cannot resolve it weve been on it 2 years no result apart form print to pdf or reinstall windows.

Not fully sure if it’s the same thing, but I had a customer case where I reduced the problems exporting to PDF down to a single character in one text object. I will be getting someone to check that out.

1 Like